Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 4 of 7 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
2 Replies and 2220 Views I2C latency on the Torpedo Wireless and Linux  2220  2 Started by  Deleted User   Hello, I have connected battery gauge on the i2c-2 bus of the Torpedo Wireless. I am able to read gauge registers from application with read/write to file or from console with i2cget command, but sometimes I got some kernel warnings like: omap_device: omap_i2c.2: new worst case deactivate latency 0: 122070 user.warn kernel: &91;  420.015838&93; omap_device: omap_i2c.2: new worst case deactivate latency 0: 122070 or, omap_device: omap_i2c.2: new worst case activate lat...
2 2220
by  Deleted UserJump to last post
18 Mar 2014 05:58 AM
3 Replies and 1621 Views USB device swapped to the USB Host  1621  3 Started by  Deleted User Hello, This question is similar to the my previous post http://support.logicpd.com/TDGForum...fault.aspx, but other consequences (effects) happens. I configure Linux image to load USB Mass storage gadget, so my board will be seen as USB device. This works and I am able to transfer files over MMC card and USB, but again after some time there are some warnings from kernel Jan  1 00:19:05 Mynd user.info kernel: &91; 1147.432952&93; Setting A idle... Jan  1 00:19:05 My...
3 1621
by  Deleted UserJump to last post
18 Mar 2014 05:52 AM
9 Replies and 2748 Views Audio -- cannot record from MIC input  2748  9 Started by  Louie Earle Hello all, I have a microphone connected to J1.8 (HSMIC.P) of the Torpedo Wireless SOM.  arecord -l shows the following: **** List of CAPTURE Hardware Devices **** card 0: omap3logic &91;omap3logic&93;, device 0: TWL4030 twl4030-hifi-0 &91;&93;   Subdevices: 1/1   Subdevice 0: subdevice 0 When I type the command          arecord -d 5 -D plughw /mnt/mmcblk0/test.WAV  I expect to record 5 seconds of...
9 2748
by  Louie EarleJump to last post
21 Feb 2014 12:01 PM
3 Replies and 1872 Views OMAP-L138 - GPIO - Expansion Headers  1872  3 Started by  Deleted User Q: Subject     Accessing GPIO Product     OMAP-L138 SOM-M1 Software OS     Linux Part Number     1016660 Description     Hello, I am using your OMAP-L138 EVM board for a senior design project and I was trying to figure out if I can use the expansion headers on the board as GPIO pins. Our team was lent the board from our professor, and he seems to have misplaced the expansion board as well as the linux SD card...
3 1872
by  George BarneyJump to last post
06 Feb 2014 01:41 AM
0 Replies and 1452 Views OMAP-L138 - Uboot Environment  1452  0 Started by  Deleted User Q: Product     OMAP-L138 SOM-M1 Software OS     Linux Part Number     none Description     Dear, I've changed onto UBOOT environment variables and so, the evaluation card does'nt boot anymore with SDCard. Could you please give me the whole of environment variable for starting into SDCard. Thanks  A: Have you tried deleting the environment If U-Boot cannot find the environment it will pull the default one from the U...
0 1452
05 Feb 2014 08:47 AM
2 Replies and 1612 Views Slowing down the I2C bus speed  1612  2 Started by  Louie Earle Hello, I'm using a DM3730 Torpedo Wireless SOM on a custom embedded board. I'm using the Linux BSP. I have 2 A2D converters on the same I2C bus, and neither are detected when I run i2cdetect. Dmesg shows the following on that bus: &91;    0.468933&93; omap_i2c omap_i2c.3: bus 3 rev4.0 at 400 kHz   The A2D converters have some level-shifting circuitry on the  SCL and SDA lines, and I think it's not working properly at 400 kHz (oscope shows a signal with nothi...
2 1612
by  Louie EarleJump to last post
04 Feb 2014 09:40 AM
1 Replies and 1650 Views DM3730 - Modify DSS DISPC Registers From Userspace  1650  1 Started by  Deleted User Q: Product     DM3730 / AM3703 Torpedo SOM Software OS     Linux Part Number     1021753 Description     Hi, We are having trouble implementing a custom display. In short, we are trying to interface a monochrome 10bits OLED lcd. Our strategy is to use 24bits RGB but use only 2 component (8bits, 2bits - 6bits to GND, 8bits to GND.) The input signal will be mix accordingly by our camera driver, then piped to the tidisplaysin...
1 1650
by  Deleted UserJump to last post
04 Feb 2014 09:38 AM
2 Replies and 1469 Views Cannot load bootloader  1469  2 Started by  Deleted User Q: When trying to load the bootloader following the guide posted on this website. I get an error saying 'incorrect magic word'. Any suggestions A:  Please attach a full log of the terminal output here. Also which guide are you using
2 1469
by  Deleted UserJump to last post
28 Jan 2014 05:13 PM
0 Replies and 1491 Views OMAP-L138 DVSDK and the VM  1491  0 Started by  Deleted User Q: Is it possible to use Linux DVSDK with Windows. A: Yes, if you are new to Linux, then I would suggest using the VM&91;1&93; that we have setup, which also includes DVSDK. Also, see the README&91;2&93; that goes with the VM. Q: I received SD Card (Linux Demo) in which there is “dvsdk_omapl138-evm_04_03_00_06_setuplinux” file. I understood that this file is setting up with Ubunto 10.04 and I’m using virtual box to do it. A folder is so created which calling “ti-d...
0 1491
28 Jan 2014 10:23 AM
1 Replies and 1423 Views DM3730 CPU Frequency?  1423  1 Started by  Deleted User Q: The demo linux SD appears to limit the max cpu freq to 600MHz, although the SOM, as I understand, is rated for 1GHz max. Is it possible to set the cpu freq to 1GHz for test purposes  A:  Yes, it is possible to increase the processor frequency to 1GHz, what have you tried already Have you tried the following cpufreq-set -f 1000000 There is more information on adjusting the frequency in the Thermal Management white paper &91;1&93;. &91;1&93; http://support.logicpd.com/Desk...
1 1423
by  Joseph SteimJump to last post
20 Jan 2014 01:11 PM
0 Replies and 1469 Views USB Driver Support - Isochronous Transfers  1469  0 Started by  Deleted User Q: Subject     USB Isochronous Product     DM3730 / AM3703 Torpedo Wire Software OS     Windows Embedded CE, Linux and Android Part Number     SDK-DM3730-10-256512R Description     Does the SDK USB driver support Isochronous mode. I am interested in using it for USB audio. Same question for Android and Linux.  A: WinCE is not supported on the Torpedo Wireless which you have indicated, but I notice...
0 1469
09 Jan 2014 04:12 PM
0 Replies and 1394 Views Changing the toolchain from the default  1394  0 Started by  Deleted User Q: I have succesfully compiled this lib for another platform with gnu toolchain v4.4. But, wth the toolchain of SOM_LV, I get the following error: libtool: link: arm-none-linux-gnueabi-g -W -Wall -Wpointer-arith -g -O2 -pipe -O3 -I. -I.. -o .libs/agent agent-agent_impl.o agent-main.o agent-snmp_agent.o ../../ASNMP/asnmp/.libs/libasnmp.a ../../ace/.libs/libACE.so -lrt -lpthread -ldl -Wl,-rpath -Wl,/home/mguler/workspace/lib/trunk/ace/ACE_wrappers-6.0.3-SOM_LV-release-shared/lib /home/...
0 1394
03 Jan 2014 12:15 PM
0 Replies and 1966 Views Leopard LI-3M02 daughter board with a Aptina MT9T112 camera sensor  1966  0 Started by  Deleted User Q: I am using the Leopard LI-3M02 daughter board with a Aptina MT9T112 camera sensor. The linux kernel has a driver for this camera. How does one set this driver up to use this camera on the Camera Port This must be a linux driver configuration, right  A:  The support for that sensor is untested. Currently, we test with CONFIG_VIDEO_MT9P031 enabled. We use the Leopard Imaging LI-5M04 &91;1&93; daughter card to test the video drivers. We have provided instructions for this use case...
0 1966
30 Dec 2013 12:51 PM
0 Replies and 1265 Views What do I need to do to get u-boot on these devices?  1265  0 Started by  Deleted User Q: I have a tool flow that uses u-boot to flash and program the DM3730 torpedo wireless SOM. The devices that I purchased from Digikey boot to the losh prompt. What do I need to do to get u-boot on these devices I tried to follow Application Note 460 but I can find x-load.bin.ift. When I load u-boot (step 3.2) I cant get beyond the 3.2.3. When I run exec it comes back with the losh prompt. Where and how do I reflash these devices to a u-boot prompt A: That application note applies to O...
0 1265
10 Dec 2013 11:57 AM
13 Replies and 2572 Views Booting with Static IP  2572  13 Started by  Deleted User Q: How do I configure my system to boot with a static IP A: Sections 4.5.1.2 and 4.5.1.3 cover this topic. In short this is how you can configure your system with a static IP setenv otherbootargs ${otherbootargs} ip=ip-address::gateway-address:netmask::: saveenv reset
13 2572
by  Servo R.Jump to last post
25 Nov 2013 02:01 PM
1 Replies and 1491 Views Default Clock of ARM and DSP Cores in Linux BSP  1491  1 Started by  Deleted User Q: With LogicPD Linux BSP version 2.4-2, what is the default clock speed of the ARM core and DSP core setup to How do you change to clock setting A: This is documented in the Thermal Management white paper &91;1&93;. To see the current CPU frequency you can use cpufreq-info. DM-37x cpufreq-info cpufrequtils 005: cpufreq-info (C) Dominik Brodowski 2004-2006 Report errors and bugs to cpufreqvger.kernel.org, please. analyzing CPU 0:   driver: omap   CPUs which need to...
1 1491
by  Deleted UserJump to last post
15 Nov 2013 09:47 AM
2 Replies and 1516 Views Issues in network configuration  1516  2 Started by  Deleted User Dear all, I would like to report two troubles that I've found in BSP 2.4, all related to configuration: 1 - The file name of the configuration file defined in /etc/rc.d/init.d/network script is invalid. The problem appears when the network script is executed from a terminal, that the script is not able to read the configuration and aborts its execution: DM-37x /etc/rc.d/init.d/network start /etc/rc.d/init.d/network: line 13: /etc/rc.d/init.d/rc.conf: No such file or directory 2 - I...
2 1516
by  Deleted UserJump to last post
13 Nov 2013 04:26 PM
2 Replies and 1592 Views QT with SGX drivers  1592  2 Started by  Deleted User Dear all, I would like to use Qt with GFX drivers (opengles and powervr drivers). I've compiled successfully the GFX drivers and the samples executes OK, but the integration of Qt with GFX (opengl) fails. I've tested many procedures from TI, but all of them have failed. Do you know how integrate Qt with GFX drivers any suggestion Joaquim Duran
2 1592
by  Deleted UserJump to last post
12 Nov 2013 03:57 PM
1 Replies and 1767 Views Are there LAN9311 drivers for Linux in the AM3517 VM?  1767  1 Started by  Deleted User Is there a Linux network driver available for driving the Ethernet jacks on the application board via GPMC and LAN9311
1 1767
by  Deleted UserJump to last post
07 Nov 2013 03:07 PM
1 Replies and 1511 Views OMAP-L138 CCS Binaries on Linux  1511  1 Started by  Deleted User Hi, I'm trying to use the character LCD and LED's on the EVM. I see there is a BSL package with source files, however these appear to require code composer studio. Will CCS produce binaries that can run on the embedded Linux
1 1511
by  Deleted UserJump to last post
01 Nov 2013 10:35 AM
You are not authorized to create a new topic
Page 4 of 7 << < 23456 > >>


RSS Feed Available