Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 5 of 7 << < 34567 > >>
Topics
 Replies
 Views
 Last Post
0 Replies and 1390 Views Zoom™ AM3517 eXperimenter Kit Matrix examples on browser  1390  0 Started by  Mariano can´t launch matrix-gui-e server to access with a browser i add http output in matrix-gui-e script (GUI_OPTS='-qws http://localhost:80 transformed:Rot0 /usr/share/matrix/html/menu_main_1.html') the process is running (/usr/bin/matrix_guiE -qws http://localhost:80 trans), but accesing with mozilla to address (172.16.18.8) i get thttpd proccess response (/usr/sbin/thttpd -d /srv/www -u root -c /cgi-bin/*). i try to killing thttpd proccess but still doesn´t work. any help or ideas
0 1390
22 Oct 2013 08:02 AM
1 Replies and 1520 Views Zoom™ AM3517 eXperimenter Kit install VNC  1520  1 Started by  Mariano how to install VNC on Zoom™ AM3517 eXperimenter Kit arago-project linux i try 'opkg install x11vnc' but doesn´t work thanks
1 1520
by  MarianoJump to last post
21 Oct 2013 02:45 PM
9 Replies and 2157 Views Zoom™ AM3517 eXperimenter Kit and LINUXEZSDK-AM35X  2157  9 Started by  Mariano hello, i download and install ti-sdk-am3517-evm-06.00.00.00-Linux-x86-Install, then run 'make linux_clean', 'make linux' and 'make linux_install', after that i download to ram using uboot 'loady' command at 0x82000000 (or 0x80008000), after that 'bootm 0x82000000 (or 0x80008000)'. Booting kernel from Legacy Image at 80008000 ... Image Name: Linux-2.6.37 Image Type: ARM Linux Kernel Image (uncompressed) Data Size: 3010184 Bytes = 2.9 MB Load Address: 80008000 Entry ...
9 2157
by  MarianoJump to last post
18 Oct 2013 11:46 AM
0 Replies and 6949 Views U-Boot and NAND Flash Partitions  6949  0 Started by  Deleted User The process for adjusting the NAND partitions in U-Boot isn't clearly documented. Here's an example of how to make changes. First lets take a look at the default partitions as shown by U-Boot: OMAP Logic mtdparts device nand0 , parts = 6 : name size offset mask_flags nand_flags 0: x-loader 0x00080000 0x00000000 0 ecc_hw,repeat 1: u-bo...
0 6949
08 Oct 2013 10:57 AM
3 Replies and 1966 Views ltib build failed BSP-2.3-2  1966  3 Started by  minchun liu Hi there, I have a strange ltib failure. I have been using the PC (Ubuntu 10.04) to build the images for a few months. I don't know why it suddenly decided to quit on me. Can anyone shed some light on the issue I have been struggling to google it in vain for the last week or so. Thanks in advance. Here are the build messages: ============================ ... CC gstlfocontrolsource.o CC gstinterpolationcontrolsource.o CC lib.o CC gsthelper.o LINK libgstcontro...
3 1966
by  minchun liuJump to last post
12 Sep 2013 10:10 AM
2 Replies and 1814 Views Buildroot with Torpedo  1814  2 Started by  Deleted User Hello, Did someone try to use and set up buildroot with torpedo I think that LTIB is too old, not updated recently, and doesn't have some packages like ipkg. So I want to switch to buildroot. Regards, Dragan
2 1814
by  Deleted UserJump to last post
15 May 2013 09:21 AM
1 Replies and 1899 Views Flash blocks corruption while reading data  1899  1 Started by  Deleted User Dear all, I run linux in the DM3730 torpedo module with file system stored in a yaffs partition. I test the performance of the CPU to read data from a USB CDC ACM device. The application JUST reads the data from the device but it DOESN'T stores the data in the file system. The USB device sends data at a rate of 888000 bytes per second. When the application is running the following traces appears in the console: Quote: &91 100.138488&93 cdc_acm 2-1.2:1.0: This device cannot do calls on its o...
1 1899
by  Deleted UserJump to last post
15 May 2013 08:33 AM
1 Replies and 1411 Views Can only get wireless SOM to connect to Smartphone Hotspot  1411  1 Started by  mike.arensdorf For some reason I'm unable to get the wireless Torpedo DM3730 SOM to connect to two of our access points. Strangely, it will connect to my Android smartphone hotspot. In every case, I'm using WPA2 security. Using the following command: /etc/rc.d/init.d/network-wifi-station init Unless connecting to the smartphone, this command results in: Sending discover... Sending discover... Sending discover... No lease, forking to background... Are there any special requirements for the SSID and/or p...
1 1411
by  mike.arensdorfJump to last post
25 Mar 2013 11:05 AM
3 Replies and 1857 Views On boot from SD card LoLo launches rather than uboot.  1857  3 Started by  mike.arensdorf I have a 16GB SD card that I've been using with a DM3730 Torpedo SOM. After running makeyaffsboot from uboot I've been booting from NAND flash. Occasionally I stop uboot and re-run makeyaffsboot to install a new image. No problems. Just got a new DM3730 Torpedo Wireless SOM, and thought I could pop this same SD card into it, power up, stop uboot, change uboot environment variables (if necessary), and run makeyaffsboot. But instead of uboot, LogicLoader runs (after several seconds of no re...
3 1857
by  mike.arensdorfJump to last post
21 Feb 2013 02:12 PM
2 Replies and 1623 Views Building X for LogicPD DM3730 torpedo  1623  2 Started by  cjrice@tva.gov I am not able to build X11 or nanoX. libX11.so won't build because linker can not find library xcb-xlib. Anyone get this to work
2 1623
by  cjrice@tva.govJump to last post
18 Jan 2013 09:47 AM
0 Replies and 1429 Views Compiler optimizations  1429  0 Started by  Deleted User Dear all, The default optimization options to compile the software in the BSP of DM37x torpedo module are '-O2 -fsigned-char -mfloat-abi=softfp -mfpu=vfp', however TI suggests that the optimization options for the same processor should be: '-march=armv7-a -mtune=cortex-a8 -mfpu=neon -ftree-vectorize -ffast-math -mfloat-abi=softfp' &911&93. As you see, these options improve the usage of NEON. I would like to know why they are not applied. Thanks and Best Regards, Joaquim Duran &911&93 http...
0 1429
29 Nov 2012 02:58 AM
5 Replies and 1801 Views The router is not configured with wifi fixed address  1801  5 Started by  Deleted User Dear all, In the BSP Linux, I've found an uncommon behavior running on the DM3730 torpedo module: if the IP address of the wlan0 interface is set fixed, then the router of this interface is not configured. This doesn't happen when the interface is configured using dhcp. Here is the execution: Current interfaces and route table $ ifconfig eth0 Link encap&58;Ethernet HWaddr BA&58;DE&58;F8&58;05&58;E9&58;BA inet addr&58;192&46;168&46;1&46;189 Bcast&58;192&46;168&...
5 1801
by  Deleted UserJump to last post
13 Nov 2012 07:59 AM
0 Replies and 1387 Views Compiler 4.6.3  1387  0 Started by  Deleted User Dear all, In the release notes of the BSP2.2, one of the fixes is: --) &91DM37LINUX-657&93 X-Loader/U-Boot fail to boot when built with GCC version 4.6.3 toolchain This tool chain could be used in production or just for testing From where could I download it Thanks and Best Regards, Joaquim Duran
0 1387
13 Nov 2012 03:39 AM
1 Replies and 1433 Views S-Video on 3530 torpedo dev kit  1433  1 Started by  rexjameson I'm trying to enable the s-video out on the 3530 torpedo dev kit using the following boot args: omapfb.mode=tv:ntsc omapfb.debug=y omapdss.def_disp=tv omapdss.debug=y But the omapfb support fails with: &91 366.637756&93 OMAPFB: omapfb_init &91 366.641021&93 OMAPFB: omapfb_probe &91 366.644287&93 omapfb omapfb: no displays &91 366.648101&93 OMAPFB: free_resources &91 366.651519&93 OMAPFB: free all fbmem &91 366.654968&93 omapfb omapfb: failed to setup omapfb &91 366.659729&...
1 1433
by  jsaraoJump to last post
23 Feb 2012 05:32 PM
1 Replies and 1439 Views Building Qtopia4  1439  1 Started by  Deleted User Dear all, I'm trying to build the Qtopia4 in the Linux BSP for the DM3730 Torpedo module. While compiling qtopia4, an error that the library Xtst is missing is shown. This looks like that Qtopia4 depends on libXtsl. How can I fix the depencendes Thanks and best regards, Joaquim Duran Gem-Med
1 1439
by  Deleted UserJump to last post
20 Dec 2011 10:10 AM
1 Replies and 1496 Views Configure LogicLoader to load kernel via tftp  1496  1 Started by  jsarao I command LogicLoader to load the elf over the network e.g. load elf /tftp/192.168.1.112:/tftpboot/image.elf And that works fine. I'd like to configure my system (I guess in this case Logic Loader), so that just a u-boot loads. then I'll configure u-boot to load the kernel via tftp. I'll then configure u-boot to instruct the kernel to mount the file system via NFS. I would then like to SAVE this u-boot configuration so that every time I turn on my Torpedo dev kit it does the same thing. My e...
1 1496
by  jsaraoJump to last post
02 Nov 2011 04:38 PM
0 Replies and 1511 Views Kernel panic when booting linux, Zoom OMAP35x Torpedo Dev  1511  0 Started by  mjb I am trying to boot linux on a Zoom OMAP35x Torpedo Dev board, with the filesystem in NAND, using the latest yaffs2 image provided by Logic. Following the instructions in the Zoom OMAP35x Dev Kit section 4.13.6, I receive this error: Quote:yaffs: Attempting MTD mount on 31.4, "mtdblock4" yaffs: auto selecting yaffs2 yaffs: NAND geometry problems: chunk size 2048, type is yaffs2, inbandTags 0 List of all partitions: 1f00 128 mtdblock0 (driver) 1f01 2176 mtdblo...
0 1511
30 Jul 2010 09:22 AM
4 Replies and 1592 Views ZOOM AM3517 EVM Board - kernel panic  1592  4 Started by  qavaxb Hello, I couldn't find any topics about ZOOM AM3517 EVM Board. I'm booting precompiled kernel from TI PSP for AM3517 via tftp, using root filesystem from Arago project via NFS and I get kernel panic. My command lines (2 lines) in u-boot: setenv bootargs 'console=ttyS2,115200n8 rw eth=33&58;55&58;77&58;99&58;aa&58;bb ip=10&46;3&46;101&46;86&58;10&46;3&46;101&46;105&58;10&46;3&46;101&46;1&58;255&46;255&46;255&46;0&58;my&46;name&46;domain&58;eth0&58;off root=/dev/nfs nfsroo...
4 1592
by  qavaxbJump to last post
14 Jun 2010 01:20 AM
3 Replies and 1433 Views kernel refuses to start on cold boot after copy to RAM  1433  3 Started by  Deleted User Hi all, I've got problems with uclinux ( freescale-ltib with kernel 2.6.22 ) on a fireengine m5329EVB after Power-on Reset I built a the kernel, zipped and flashed it into the fireengines boot ROM. It works quite well after an External Reset, but when I switch of the main power and force a Power-on Reset the kernel refuses to start: Power-on Reset ...
3 1433
by  johnlongawaJump to last post
16 Mar 2009 09:36 AM
0 Replies and 1284 Views uBoot and X-Loader on ZOOM OMAP35x  1284  0 Started by  Deleted User I've tried to boot from an MMC with an MLO (X-loader) and the board freezes. If I use the MLO (NOLO) and rename the uboot.elf to lboot.elf, then the uBoot runs but it says that the NAND bus is 16 bit instead 8 bit and it freezes. Are uBoot and X-Loader supported on ZOOM OMAP35x
0 1284
21 Jan 2009 03:49 AM
You are not authorized to create a new topic
Page 5 of 7 << < 34567 > >>


RSS Feed Available