Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 2 of 7 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
4 Replies and 3479 Views VM build failed to boot up  3479  4 Started by  minchun liu I installed Virtual Machine 2.3 on a Win7 PC. I manually created a folder in rootfs/myFolder and added my application files to it which is about 7MB. The build was fine. The folder was included in the file rootfs.ext2.gz.uboot. But I got Kernel Panic during boot-up, see the attached log. Could anyone tell me how to change the size of rm0 If I remove all the files in myFolder and only keep a file with a few KBytes, it can boot up successfully. Also the same Kernel Panic happens on VM 2.2. ...
4 3479
by  Adam FordJump to last post
03 Oct 2016 06:27 AM
0 Replies and 1387 Views Getting and Setting DM3730 ethaddr in uboot  1387  0 Started by  Joe Andrieu I'd like to use the eFuse MAC as the linux MAC, but the 4.2.2 BSP's linux is setting a random MAC every time.  My current strategy is to read the eFuse address in uboot and pass it to the kernel, but that's not quite working.   First, I'm not sure I'm reading the right registers.  From https://support.logicpd.com/TDGForum/tabid/124/aft/96/Default.aspx I discovered the CONTROL_FUSE_EMAC_LSB and CONTROL_FUSE_EMAC_MSB registers (addresses 0x4800 2380 a...
0 1387
15 Sep 2016 07:29 AM
0 Replies and 1327 Views SD Card Bug Fix in U-Boot 2016.09  1327  0 Started by  Adam Ford Some kits, but not all appear to have an issue when booting from an SD card, the system may hang when starting the kernel. I pushed a fix to U-Boot which became part of the 2016.09 release which was publised on 12 September 2016.  I would suggest anyone who has started experimenting with the Beta BSP to upgrade the U-Boot release to 2016.09 if they are experiencing this issue. ftp://ftp.denx.de/pub/u-boot/u-boot-2016.09.tar.bz2   adam
0 1327
14 Sep 2016 06:47 AM
0 Replies and 1404 Views Enable WiFi in Mainstream Linux (Torpedo Wireless)  1404  0 Started by  Adam Ford When building the kernel, make sure the following is enabled in the menuconfig: Networking Support ---> Wireless ---> nl80211 testmode command  If not, the WiFi may not scan. From there, you'll need to copy the NVS file from the 3.0.x kernel BSP. The stock BSP has 3 NVS files.  That driver have been modified to identify the chip type and load the corresponding driver.  Since the mainline kernel does not have this feature, you'll have to manually copy the nvs file.   By ...
0 1404
14 Aug 2016 10:08 AM
1 Replies and 1083 Views Mainstream Linux VM Image won't download  1083  1 Started by  Carter Reynolds Does anyone have the Mainstream Linux VM Image for Torpedo SOM Wireless The link on the product download page isn't working.
1 1083
by  Adam FordJump to last post
10 Aug 2016 06:32 AM
17 Replies and 1836 Views Hidden SSID Support In BSP-2.3.2 (Linux v3.0)  1836  17 Started by  Deleted User Hi all, I want to use hidden SSID feature on DM3730 Wireless Torpedo SoM but I observe 'hidden SSID is not supported' error from wl12xx driver. I could not find a complete patch-set for hidden SSID feature. Thus, I merged related codes from vanilla Linux manually. Unfortunately, it did not work. Does anybody have an idea about that Any help is appreciated.
17 1836
by  Adam FordJump to last post
15 Feb 2016 06:51 AM
1 Replies and 1197 Views ldconfig -p yields no found libraries  1197  1 Started by  Jay Thomas   Hi all, I noticed after building and deploying an image onto the Torpedo AM37x SOM via LTIB that when I went to the command line and typed: ldconfig -p The system indicated that it could not find anything.  It complained of not having an ld.so.conf.d directory It seems that this is a requirement for Linux in general so that it can reliably find it's shared objects that are required for the embedded application. To solve the issue, I created the /etc/ld.so.conf.d directory and t...
1 1197
by  Adam FordJump to last post
11 Feb 2016 08:50 AM
2 Replies and 2644 Views GDB unable to see debug symbols  2644  2 Started by  Jay Thomas   After building the LTIB image, GDB version 6.6 is pulled into the image.  We are using the CodeSourcery toolchain: arm-none-linux-gnueabi-gcc (Sourcery CodeBench Lite 2011.09-70) 4.6.1 When running GDB at the command line, it was not able to find the debug symbols that were actually present in our files. As an attempt at fixing this, I downloaded the latest GDB from the GNU website.  This is version 7.10.1. After cross building this and installing onto the target manually, ...
2 2644
by  Adam FordJump to last post
09 Feb 2016 06:56 AM
7 Replies and 2621 Views Minicom, Termcap and LTIB  2621  7 Started by  Deleted User You may notice that if you select the Minicom package in the LTIB configuration that your build fails. It seems LTIB cannot get the termcap package from the LTIB GPP anymore. It's uncertain if this a permanent situation. An alternate source for the package and patch is here: http://bitshrine.org/gpp/termcap-mini-1.2.tar.gz http://bitshrine.org/gpp/termcap-1.2-vt102.patch The wget utility may not work. Enter the links into your browser and download them into the LTIB-package-pool di...
7 2621
by  bradbJump to last post
14 Jan 2016 08:32 AM
5 Replies and 2006 Views vim rpm not found  2006  5 Started by  Ken Willoughby I enabled vim in ltib.  When it tries to build I get. Processing: vim ============= Build path taken because: no prebuild rpm, Tesing network connectivity for gpp No network download connection available Can't get: vim-6.2.tar.bz2 at ./ltib line 1061.   Where can I download vim manually
5 2006
by  Ken WilloughbyJump to last post
12 Jan 2016 05:38 PM
1 Replies and 1513 Views Linux 4.2  1513  1 Started by  Adam Ford The stock Linux 4.2 kernel supports some of the basic Torpedo and Torpedo Wireless features.   The following patches have been pushed and pending review within the Linux community: Add TWL4030 Audio Increase I2C2 and I2C3 bus speeds to 400KHz to match the released BSP Correct VAUX1 and VAUX4 voltages generated by the PMIC Enable the Shared Transport and BTWILINK drivers necessary for Bluetooth operation. None of these patches have gone through Logic PD Quality t...
1 1513
by  Adam FordJump to last post
22 Dec 2015 07:39 AM
13 Replies and 2628 Views UART with enabled DMA  2628  13 Started by  Deleted User Hello, We switched to BSP-2.4-4, but now we have issues with serial UARTs. We are using uart at ttyO2 with hw flow ctrl (cts/rts) enabled to communicate with some chip at 3Mbps (actual throughput on ttyO2 during the streaming is around 1.3Mbps). On the previous BSP 2.3-2 this worked just fine, except note 1, see below. With the new BSP-2.4-4, we have troubles, like this: -If we stream some bigger data on debug console (ttyO0), for example 'cat command' some big file, streaming on ttyO2 is ...
13 2628
by  Adam FordJump to last post
10 Dec 2015 08:53 AM
9 Replies and 3147 Views DM3730 - NTSC Video Capture Device  3147  9 Started by  Deleted User Q: Product     DM3730 / AM3703 Torpedo Wire Software OS     Linux Part Number     1021753 Description     Hello, I am currently working on an NTSC video capture device that takes NTSC data from the ADV7180_LFCSP32 and supplies 8-Bit, 4:2:2 YCrCb&91;7:0&93; output data to to the Camera Connector (J6) on the torpedo development board. I have connected the ADV7180 LLC pin to the CMA_PCLK pin and HS and VS to their correspondin...
9 3147
by  Adam FordJump to last post
07 Dec 2015 08:27 AM
0 Replies and 1510 Views DM3730 - ADV7180  1510  0 Started by  swl Hi, First of all, I am not familiar with the ISP and it usages.   I am trying to get DM3730 to work with ADV7180 i2c driver and I realize there is this media controller framework that omap3isp uses. Is it necessary to patch ADV7180 driver with media controller framework or is there other way to bypass the ISP and use the driver direct If media controller framework is the suggested solution, is there any guide that I can reference If anyone have managed to use ADV7180 on DM3730...
0 1510
23 Nov 2015 07:00 PM
3 Replies and 1282 Views 802.11n Access Point  1282  3 Started by  Deleted User Hello, I used default /etc/rc.d/init.d/hostapd script to start access point as 802.11g. Did someone tried 802.11n What should be content of /etc/hostapd.conf file Will wl12xx driver support 802.11n Some info uname -a                                  Linux Mynd 3.0.0-BSP-dm37x-2.3-2 15 Thu Oct 1 15:21:25 CEST 2015 armv7l GNU/Linux hostapd -v hostapd v0.7.3 User space daemon for IEEE 802.11 AP mana...
3 1282
by  Adam FordJump to last post
06 Nov 2015 07:38 AM
3 Replies and 1369 Views Fail to build libX11  1369  3 Started by  Deleted User Hello, In BSP version 2.4-4, it is not possible to build libX11: Processing: libX11 ==================== Build path taken because: no prebuilt rpm,  rpmbuild --dbpath /home/gem-med/Logic_BSPs/Linux_3.0/LogicPD_Linux_BSP_2.4-4_ght_1.0_wayland/rootfs//var/lib/rpm --target arm --define '_unpackaged_files_terminate_build 0' --define '_target_cpu arm' --define '__strip strip' --define '_topdir /home/gem-med/Logic_BSPs/Linux_3.0/LogicPD_Linux_BSP_2.4-4_ght_1.0_wayland/rpm' --define '_prefi...
3 1369
by  Adam FordJump to last post
19 Oct 2015 09:15 AM
25 Replies and 6927 Views Yocto meta layer for torpedos  6927  25 Started by  dtran11
(Topic has multiple pages1 2 )
I am currently working on a meta layer for the LogicPD Torpedo boards for use with the Yocto build system. It is currently not done yet but I wanted to give a heads up to people who wants to build their own custom Linux system. Once it is done, I'll post some tutorials on how to get started. https://github.com/dtran11/meta-logicpd
25 6927
by  Sebastian HeldJump to last post
23 Sep 2015 04:59 AM
1 Replies and 1390 Views SPI bus with disabled DMA.  1390  1 Started by  Deleted User Hello all, In the BSP 2.4-3 of Torpedo Wireless module, by default, the DMA of SPI bus is disabled. Could you tell me if there is any issue that forces to disable the DMA Thanks and Best Regads, Joaquim Duran
1 1390
by  bradbJump to last post
11 Sep 2015 02:31 PM
1 Replies and 1311 Views USB ISP1763 u-boot access  1311  1 Started by  Pedro Erencia Hello, Is it possible to access usb host devices on the ISP1763 from u-boot Cheers.  
1 1311
by  bradbJump to last post
10 Sep 2015 11:22 AM
39 Replies and 5932 Views Receiving corrupted packets from wifi.  5932  39 Started by  Deleted User
(Topic has multiple pages1 2 )
Hello, On a Torpedo wireless module updated to BSP 2.4-3, we've discovered that packages are lost because they were corrupted: Jan  1 00:52:56 DM-37x user.warn kernel: &91; 3179.250488&93; wl1283: WARNING corrupted packet in RX with status: 0x1 Jan  1 00:52:56 DM-37x user.warn kernel: &91; 3179.252899&93; wl1283: WARNING corrupted packet in RX with status: 0x1 Jan  1 00:52:56 DM-37x user.warn kernel: &91; 3179.253845&93; wl1283: WARNING corrupted packet in RX wit...
39 5932
by  Deleted UserJump to last post
03 Sep 2015 11:20 AM
You are not authorized to create a new topic
Page 2 of 7 << < 12345 > >>


RSS Feed Available