Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 3 of 5 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 2039 Views 6748 EVM  2039  1 Started by  iain scott I need to download the EVM Gel files but the web site prevents me from doing so. I am logged in and have previously registered a product. Why is this Iain Scott
1 2039
by  iain scottJump to last post
15 Apr 2014 09:41 AM
1 Replies and 2142 Views USB OTG driver for vxWorks  2142  1 Started by  Anthony Fontana Has anyone implemented a vxWorks driver for USB OTG  I'd like the L138 to be a target mass storage device providing remote access to  a local SATA drive.  Windriver has davinci platform code that matches most of the controller registers but also relies on some ULPI calls that aren't supported by the L138.
1 2142
by  Joe CharboneauJump to last post
18 Mar 2014 09:15 AM
3 Replies and 2119 Views Can't Download file  2119  3 Started by  Deleted User I have a demo board of Omap-L138,I am evaluate it ,and want download document ,software and hardware source.But Ifound some file can not download,why
3 2119
by  jedaJump to last post
05 Mar 2014 09:02 AM
4 Replies and 1981 Views code speed  1981  4 Started by  Howe Robert I have been comparing how fast code is running between the OMAP-L138 EVM and the Mitty DSP -L138F by critical link. It appears that the code on EVM som is running 1/3 the speed of the Mitty DSP-L138F. Both boards are clocking at the same rate 300MHz. Could anyone tell me why this is. 
4 1981
by  Howe RobertJump to last post
05 Mar 2014 07:42 AM
0 Replies and 1789 Views Documentation Updates for OMAP-L138 SOM-M1  1789  0 Started by  Deleted User AM1808 & OMAP-L138 SOM-M1 U-Boot Software & Labs: Document Update Revision C of the AM1808 & OMAP-L138 SOM-M1 U-Boot Software & Labs download has been released. This revision includes information about how to set both the MAC address and the netmask when establishing a network connection. Please see the document's Revision History table for a more detailed explanation of all changes. You can download this document from the OMAP-L138 SOM-M1 (EVM) product page on Logic PD's s...
0 1789
28 Feb 2014 08:33 AM
0 Replies and 1763 Views Documentation Updates for OMAP-L138 SOM-M1  1763  0 Started by  Deleted User Zoom OMAP-L138 EVM Development Kit Errata: New Document Revision 02/03/14 of the Zoom OMAP-L138 EVM Development Kit Errata has been released for Errata ID E0049. This errata describes an issue in which the OMAP-L138 SOM-M1 may back power the 3.3V rail on the development kit baseboard during reset. Please refer to the Zoom OMAP-L138 EVM Development Kit Errata document for additional details, including the workaround and fix plan for this issue. You can download this document from the OMAP-L...
0 1763
14 Feb 2014 10:43 AM
0 Replies and 1787 Views ethernet communication  1787  0 Started by  Deleted User Hi, I am using OMAP L138 (only C6748) EVM and in my application I have to receive data from Ethernet and perform some operation on received data (Say addition of all the numbers ) and the transmit the sum through UART port. I am using CCS V5.1, NSP1.10.00.03 and NDK V2.21. I am planning to use HelloWorld example application (document SPRU523H) as my base program and above it I am planning to write my code for addition of received data through ethernet and the sending the sum value through UART...
0 1787
11 Feb 2014 06:18 AM
1 Replies and 1909 Views OMAP -L138 Product downloads  1909  1 Started by  Deleted User Hi , I have already registered with logic PD website ,but still I could not able  to download some of the files  (Hardware Design files/ BSL files)   http://support.logicpd.com/ProductD...rKit).aspx   But previously I’ve downloaded BSL test code from the same link Regards Antony 
1 1909
by  Deleted UserJump to last post
06 Jan 2014 03:52 PM
2 Replies and 2126 Views U-Boot is reporting incorrect memory size  2126  2 Started by  Deleted User Q: We are using OMAPL138-UNV board which contains OMAP-L138 SOM-M1. There are 128 MB DRAM on board according to the data sheets around but the U-Boot reports 64 MB after restore from this tool '1015906B_OMAP-L138_AM1808_U-Boot_Labs.zip'. A: What is the part number for the SOM It should be in the form 10xxxxx.
2 2126
by  Deleted UserJump to last post
03 Jan 2014 11:29 AM
0 Replies and 1748 Views Basebord's 3.3V-1.8V supply fail to setup  1748  0 Started by  Deleted User Q: condiction: 1.the supply is powered by the 5V adapter-OK 2. the OMAPL138 has been plugged in the baseboard 3.without anyother connection Phenomenon: 1.D5 doesn't light(3.3V-1.8V OFF) 2.R169 is low   A: 1. D5 should light up with or without the SOM properly seated. 2. R169 should be otherwise you would be asserting reset. Are you seeing any output on the terminal    
0 1748
27 Dec 2013 10:40 AM
1 Replies and 1955 Views OMAP-L138 Questions  1955  1 Started by  Deleted User Q: I would like to use the OMAPL138 EVM and interface to the uPP on it andI have several questions: 1. Can I connect an external A/D to the uPPclk at 60MSPS10b 2. Does the uPP currently interface to the ADS901 A/D   3. Are the uPP lines shared with other devices on the board A:  1. Yes the uPP supports 8 and 16 bit widths and with an I/O clock of 75MHz SDR can do 75Mw/s. The I/O clock has an upper bound of 1/4 the CPU clock. 2. Yes, the uPP can be used to interface...
1 1955
by  Yuval Ben ZionJump to last post
08 Dec 2013 01:45 AM
0 Replies and 6474 Views What Does *** Warning - bad CRC, using default environment Indicate?  6474  0 Started by  Deleted User Q: After following the PN1015906B OMAP-L138 SOM-M1 U-Boot Labs the following message returned form OMAPL138EVM BOOTME Booting with TI UBL Device OPP (300MHz, 1.2V) U-Boot 2009.11 (May 03 2010 - 15:38:40) I2C: ready DRAM: 64 MB *** Warning - bad CRC, using default environment In: serial Out: serial Err: serial ARM Clock : 300000000 Hz DDR Clock : 132000000 Hz Invalid MAC address read. Net: Ethernet PHY: GENERIC 0x00 Hit any key to stop autoboot: 0 U-Boo...
0 6474
02 Dec 2013 10:47 AM
0 Replies and 1736 Views Documentation Updates for OMAP-L138 SOM-M1  1736  0 Started by  Deleted User OMAP-L138 SOM-M1 Hardware Specification: Document Update Revision F of the OMAP-L138 SOM-M1 Hardware Specification has been released. This revision adds pick and place machine recommendations and corrects references to uP_RESETn throughout the document. Please see the document's Revision History table for a more detailed explanation of all changes. You can download this document from the OMAP-L138 SOM-M1 (EVM) product page on Logic PD's support site or at: http://support.logicpd.com/Desktop...
0 1736
22 Nov 2013 12:18 PM
1 Replies and 1835 Views MSTR_nRST_5V  1835  1 Started by  Ayumi Namiki Hello, According to the OMAP-L138 EVM Baseboard schematic (1016572B), ENABLE pin of 1.8V/3.3V LDO is connected to 5V and 'MSTR_nRST_5V'. Because R216/218 are not mounted, so need to input 5V to ENABLE from 'MSTR_nRST_5V', but no information is available about 'MSTR_nRST_5V' in the baseboard schematic and the SOM schematic (1015115C). Where is the host of 'MSTR_nRST_5V'  Thanks & Regards, Namiki  
1 1835
by  Ayumi NamikiJump to last post
19 Nov 2013 09:16 AM
3 Replies and 1933 Views Can SPI0 be used?  1933  3 Started by  Deleted User Hello, the OMAP-L138 SOM-M1 has two SPI ports. I need one SPI port in my design. I do not want to use SPI1, because the system boots from SPI1 by default. I do not want to wait for the Linux System booting, until the bus can be used by the DSP. Thus my choice is to use SPI0. The HW Spec of the SOM says, that SPI0_SIMO, SPI0_SOMI and SPI0_CLK are used for communication with the Ethernet PHY on the SOM. If I go without Ethernet PHY, is it possible to use SPI0 for own purposes, by DSP
3 1933
by  Andreas GschossmannJump to last post
11 Nov 2013 09:18 AM
1 Replies and 2077 Views Boot modes in OMAP-L138 EVM Development Kit  2077  1 Started by  Deleted User Please provide more details of different boot modes in OMAP-L138 EVM Development Kit and which mode should be used while debugging.  Also want to know ,'.out file” will be stored in which memory(flash or RAM).
1 2077
by  Deleted UserJump to last post
30 Oct 2013 03:44 PM
2 Replies and 1926 Views Using I2C0 Bus when Battery is Not Being Used?  1926  2 Started by  Deleted User Hello, I have a question about the I2C-ports of the logicpd 'L138 SOM-M1'. According to the 'OMAP-L138 SOM-M1 Hardware Specification' the SOM has the following I2C ports: - I2C0, pin 60 and 62 of J2 - I2C1, pin 97 and 99 of J1 The Spec sais that I2C0 bus is used for communication between the OMAP-L138 processor and the TPS65070 PMIC. This Chip is used for battery management. I am not using any battery in my device. If I can do without this functionality, is it possible to use this I2C ...
2 1926
by  Andreas GschossmannJump to last post
29 Oct 2013 02:35 PM
1 Replies and 2503 Views Cortex_A8_0: GEL: Error while executing OnTargetConnect(): target access failed.  2503  1 Started by  Deleted User I'm following application note document p/n, 1021646 on creating 'hello world' app in CCS v5.1.0. I got to step 10 on section 3, and got an error (see below) while trying to connect. Can you help  Cortex_A8_0: GEL Output: mDDR Hynix H8KDS0UN0MER - 2048 Mbit(256MB) on CS0, 16M x 32bit x 4Banks  Cortex_A8_0: Trouble Writing Memory Block at 0x6d000010 on Page 0 of Length 0x4: (Error -2130 0x6D000010) Unable to access device memory. Verify that the memory address is in valid memory....
1 2503
by  Aristo WibawaJump to last post
25 Oct 2013 12:38 PM
0 Replies and 1707 Views Documentation Updates for OMAP-L138 SOM-M1  1707  0 Started by  Deleted User AN 470 OMAP-L138 SOM-M1 Design Checklist: Document Update Revision D of the OMAP-L138 SOM-M1 Design Checklist application note has been released. This revision corrects several signal names in Table 2.1 and updates a link to SMSC's AN 8.13. Please see the document's Revision History table for a more detailed explanation of all changes. You can download this document from the OMAP-L138 SOM-M1 product page on Logic PD's support site or at: http://support.logicpd.com/DesktopModules/Bring2mind...
0 1707
25 Oct 2013 09:34 AM
5 Replies and 2425 Views UART Communication Failures  2425  5 Started by  Deleted User We are experiencing frequent failures when using the SOMOMAPL 138 module UART2 serial bus. A failed module is unable to send or receive serial data on TXD/RXD of UART2 (J1 97, J1 99 on the connector). Other elements of the DSP seem to continue to work properly despite the serial communication not working. At first I thought it was random/unlucky occurence but with 3-4 similar failures I believe it must be something systematic. Our current communication method involves using a USB to 3.3V con...
5 2425
by  Deleted UserJump to last post
14 Oct 2013 12:27 PM
You are not authorized to create a new topic
Page 3 of 5 << < 12345 > >>


RSS Feed Available