Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 01 May 2017 09:41 AM by  Marco Fonseca
temperature sensor and mainline
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages

Marco Fonseca



New Member


Posts:15
New Member


--
29 Apr 2017 04:50 PM

    I couldn't find any modules that handled the temperature sensing on the torpedo som for 4.9.x mainline.   I see the older kernel used omap34xx_temp.c before.  Was this removed from mainline?

    Thanks,

     

    Marco


    Adam Ford



    Advanced Member


    Posts:788
    Advanced Member


    --
    30 Apr 2017 08:39 AM
    Go into the menuconfig (make menuconfig ARCH=arm)

    Device Drivers -> Generic Thermal sysfs driver -> Texas Instruments thermal drivers

    You'll need to enable Texas Instruments OMAP3 thermal support. It's disabled by default. TI doesn't recommend using them and the comments in the menuconfig indicate they are not accurate nor close to important hotspots on the OMAP3 family.

    adam

    Marco Fonseca



    New Member


    Posts:15
    New Member


    --
    01 May 2017 09:41 AM
    Awesome, Thanks!
    You are not authorized to post a reply.