Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 06 Jul 2004 03:44 PM by  towie
WLAN interrupt
 0 Replies
Sort:
You are not authorized to post a reply.
Author Messages

towie



New Member


Posts:
New Member


--
06 Jul 2004 03:44 PM
    I'm struggling with the interrupt from the LAN controller.
    The first interrupt always occours but the line from CPLD to the processor keeps set to low. All interrupt bits in the CPLD mask register are set which means that there is no pending interrupt. Only WLAN is enable (no other interrupt source). The interrupt line only raise to high when the global interrupt disable bit in the CPLD card engine control register is set.
    As soon as this will be cleared then the interrupt line goes to LOW, even if no Touch or WLAN interrupt is pending.
    The CPLD software version is 0x34 type b. So I configured PortF3 for GPIO CPLD interrupt.

    Any hints?
    Thanks.

    Toralf
    You are not authorized to post a reply.