Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 26 Sep 2008 03:46 PM by  jwyatt
Problem booting COM Express MPC8360 with JFFS2 filesystem
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages
hendix
New Member
New Member
Posts:


--
01 Sep 2008 08:09 AM
    Hi,

    i just got a new COM Exptess MPC8360 board on my desk and tried to make it works with the JFFS2 filesystem.
    But a problem occurs.

    Basically we need 3 files to be flashed into the board right? the linux kernel, the rootfilesystem, and the DTB file.
    As i compiled the LTIB package for JFFS2 target filesyste, no new DTB file was created. The only DTB file found in the LTIB directory structure is under images/ firectory. So i used that and flashed onto the board.

    I followed every detail instruction in the BSP manual such as setting the following uboot parameters:

    => printenv
    ........................
    bootcmd=run romboot
    ........................
    romboot=setenv bootargs root=/dev/mtdblock4 rootfstype=jffs2 rw console=ttyS0,115200; bootm $flashkerneladdr - $flashftdaddr
    ........................


    but as the kernel try to boot, it says:

    ## Booting image at ff860000 ...
    Image Name: Linux-2.6.11
    Image Type: PowerPC Linux Kernel Image (gzip compressed)
    Data Size: 1394717 Bytes = 1.3 MB
    Load Address: 00000000
    Entry Point: 00000000
    Verifying Checksum ... OK
    Uncompressing Kernel Image ... OK
    ## Loading RAMDisk Image at 00000000 ...
    Bad Magic Number
    Resetting the board.


    It is weird that it is not working as it is described on the manual. I suggest that the DTB file i used is wrong, but anyway the LTIB didn't build any new DTB file!

    On the previous board as far i remembered we had the same problem, and the solution i found accidentally was to change the boot command from:

    # bootm $flashkerneladdr - $flashftdaddr


    into :

    # bootm $flashkerneladdr $flashftdaddr


    And it worked! but unfortunattely it doesnt work this time with the new board.

    Can anybody give me a hint what is going wrong here?

    Thanks in advance.
    jwyatt
    New Member
    New Member
    Posts:


    --
    26 Sep 2008 03:46 PM
    We had the same problem -- it seems that the base address of the NAND device isn't set up properly.

    It works if you use the NAND base address as the "offset in device" for the write (step 12 on page 14 of the user manual):
    => nand write.jffs2 0x1000000 0x60000000 <JFFS2 size in hex>

    This may only happen if the NAND flash is empty when uboot boots. Once you have data in the chip and reboot then it seems that the zero offset works.


    We think this method also worked, but we don't have another virgin board to verify it on:
    => nand device 0
    => nand erase 0 0xa00000
    => nand write.jffs2 0x1000000 0 0x<JFFS2 size in hex>


    You can verify whether your write took by reading back and comparing:
    => nand write.jffs2 0x1000000 0 0x708000
    => nand read.jffs2 0x2000000 0 0x708000
    => cmp.b 0x1000000 0x2000000 0x708000
    You are not authorized to post a reply.