Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 16 Jul 2009 02:47 AM by  andreas.b
mx2 framebuffer on Litekit?
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages

andreas.b



New Member


Posts:
New Member


--
26 Jun 2009 03:10 AM
    I've got Linux running on the LogicPD-board but can't get the mx2 framebuffer from freescales BSP to work. Anyone who has patched this? It compiles well but it hangs the boot right after "Uncompressing Linux.............done, booting the kernel."
    The display is tested from the bootloader so it's wired correctly, the framebuffer is tested on a iMX27 PDK board where it runs but on the litekit it just doesn't work. I have tried the patch from zyzyis for the 2.6.22 kernel with the same result.

    I'm getting pretty frustrated so any ideas is appreciated!

    andreas.b



    New Member


    Posts:
    New Member


    --
    16 Jul 2009 02:47 AM
    The framebuffer (mx2fb) is working on the Litekit for me but there is an issue with the colors. They don't show up right, red becomes turqoise, green becomes pink, and blue becomes yellow. Is the signals mapped differently on the litekit than on ADS? Anyone with an idea?
    You are not authorized to post a reply.