Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 04 Dec 2008 02:27 PM by  richard.laborde@logicpd.com
Problem with CompactFlash and SD
 9 Replies
Sort:
You are not authorized to post a reply.
Author Messages

oscarmarmar



New Member


Posts:
New Member


--
28 Nov 2008 01:02 AM
    Hi,

    In my imx31 Lite kit I don't mount the CF in LOLO 2.4.

    losh> mount fatfs /cf
    timeout resseting cf card.
    unsuccessfull mounterror: mount: unable to mount (/)

    losh> mount fatfs /dev/ata0a /cf
    timeout resseting cf card.
    unsuccessfull mounterror: mount: unable to mount (/)
    mount
    losh> mount fatfs /dev/sdmmc0a /sd
    sdmmc_open:583 Fail - 00000000!
    sdmmc error opening
    unsuccessfull mounterror: mount: unable to mount (/)

    ¿Why don't I mount the cards?

    Thanks

    richard.laborde@logicpd.com



    Basic Member


    Posts:247
    Basic Member


    --
    01 Dec 2008 01:46 PM
    oscarmarmar -

    Are you certain that the kit you have supports Lolo 2.4.0? See PCN 347 for more information.
    http://www.logicpd.com/do...iMX31_SOM-LV_PCN.pdf

    Production kits have not generally exhibited this behavior.
    You can try the old standby of removing and reseating the SOM, this has been known to fix some connection issues.
    Thanks

    Richard

    oscarmarmar



    New Member


    Posts:
    New Member


    --
    03 Dec 2008 12:47 AM
    I want to go back to an earlier version but the function update update:

    send update file:
    update failed
    error: update: file is not in update format (Found 0x837061c0)

    And with fiel .elf:

    load elf
    loading from stdin:
    0x80200000 7f 45 4c 46 61 28 38 80 34 8c d5 34 20 28 60 80 .ELFa(8.4..4 (`.
    0x80200010 80 d5 c4 44 ea f0 9f e5 f0 9f e5 f0 9f e5 f0 9f ...D............
    0x80200020 e5 a0 e1 f0 9f e5 f0 9f e5 b0 80 b0 80 b0 80 b0 ................
    0x80200030 80 b0 80 b0 ....
    ELF file must be: ARM, and elf-current:
    load failed
    ...done
    load failed
    error: load: unable to read master header ()

    Can I install other bootloader? What do I do to install it?

    Thank you.

    oscarmarmar



    New Member


    Posts:
    New Member


    --
    03 Dec 2008 12:51 AM
    My litekit is Beta2 and For Beta 2 hardware: LoLo 2.3.1 or 2.3.3 must be used.

    richard.laborde@logicpd.com



    Basic Member


    Posts:247
    Basic Member


    --
    03 Dec 2008 07:51 AM
    oscarmarmar -

    Be sure the binary checkbox is checked when you do the update.
    I just completed this process on a Beta 2 Kit:

    *****************************************************************

    LogicLoader

    (c) Copyright 2002-2006, Logic Product Development, Inc.
    All Rights Reserved.
    Version 2.4.0-IMX31_10 0001
    *****************************************************************

    losh> update
    send update file:
    ...............................
    Nor flash erase: The area (or parts of it) 0x0 - 0x40000 is locked.
    erasing flash: 100%
    burning flash: 100%
    update done.
    losh>
    *****************************************************************

    LogicLoader

    (c) Copyright 2002-2006, Logic Product Development, Inc.
    All Rights Reserved.
    Version 2.3.3-IMX31_10 0001
    *****************************************************************

    losh>

    Richard

    oscarmarmar



    New Member


    Posts:
    New Member


    --
    03 Dec 2008 08:24 AM
    Thank you,

    This was my problem.

    But now, with logicloader 2.3.3 I don't mount cf.

    I'm looking my new problem:

    mount fatfs /cf
    timeout resetting cf card
    error: mount: failed to open (ATA)

    I test the mount with delay , for example:
    sleep 100; mount fafts /cf

    But I have the same results:
    timeout resetting cf card
    error: mount: failed to open (ATA)

    oscarmarmar



    New Member


    Posts:
    New Member


    --
    03 Dec 2008 08:30 AM
    I send the results with LogicLoader 2.3.3

    losh> ls /dev
    S : nand0 0
    S : flash0 0
    S : null 0
    S : serial_imx31_ff 0
    S : config 0
    losh> ls /
    D : tftp 0
    D : etc 0
    D : dev 0

    This is correct?

    Thank you

    richard.laborde@logicpd.com



    Basic Member


    Posts:247
    Basic Member


    --
    03 Dec 2008 03:54 PM
    oscarmarmar -

    Yes that looks correct.

    *****************************************************************

    LogicLoader

    (c) Copyright 2002-2006, Logic Product Development, Inc.
    All Rights Reserved.
    Version 2.3.3-IMX31_10 0001
    *****************************************************************

    losh> ls /dev
    S : nand0 0
    S : flash0 0
    S : null 0
    S : serial_imx31_ff 0
    S : config 0
    losh> ls /
    D : tftp 0
    D : etc 0
    D : dev 0
    losh> mount fatfs /cf
    losh> cd /cf
    losh> ls
    r: NK_31release.bin 31282043
    r: NK_imx31_pshow.bin 12674163
    r: iMX31-10 SOM-LV Sample Show Image Release Notes.txt 4674
    D : Documents and Settings 0
    D : PSM 0
    losh>

    PCN 348 has more information on CF on the Kits. Look under the LiteKit PCN.
    fwiw - my J3 jumper is on 1&2 and the J4 jumper is off.

    Richard

    oscarmarmar



    New Member


    Posts:
    New Member


    --
    04 Dec 2008 08:01 AM
    My compact flash is 256 MB and type I

    I don't find the document PCN 348. Only I find PCN 347

    Switch
    JP2 is conected 5&6
    JP1 is conected 2&3
    JP3 is conected 1&2
    Jp4 is off
    J5, J8, J9, J17, all pins off

    I can´t read the CF.
    How do I read data from the SD card?
    Are my jumpers ok?

    richard.laborde@logicpd.com



    Basic Member


    Posts:247
    Basic Member


    --
    04 Dec 2008 02:27 PM
    oscarmarmar -

    PCN 347 is under the SOM, PCN 348 is under the LiteKit - next section down.

    The jumper settings look OK if you mean that one jumper is on 5 and one is on 6 for J2.
    See the Quick Start Guide for JP2 settings- http://www.logicpd.com/do..._iMX_LITEKIT_QSG.pdf

    If you have a different CF card I'd try that. We have had the best success with Industrial cards on the early kits.
    Thanks

    Richard
    You are not authorized to post a reply.