Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 17 Apr 2008 01:34 PM by  freem
NVCC3 is over voltage
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages

freem



New Member


Posts:
New Member


--
02 Apr 2008 05:42 PM
    Logic

    When LOLO boots, NVCC3 is set to 2.8V. However, I have found NVCC3 is getting set to 3.3V by Window CE after it boots, this is not good. Max voltage on NVCC1 and NVCC3 - NVCC10 rails is 3.1V.


    PS
    Any answers on my last post yet?

    freem



    New Member


    Posts:
    New Member


    --
    17 Apr 2008 01:34 PM
    Follow up,

    The problem was within our design. I want to post this so others will not have same issue. We are using NXP's GTL2002 for level shifting. If there is no load on an NVCCx that the GTL2002 is using for a voltage ref(SREF), the GTL2002 will leak a little current(less than 100uA) back thru the SREF. This will increase the NVCC voltage to whatever the higher voltage logic pull-ups are.


    I like to say thanks to Freescale for helping in this manner.
    You are not authorized to post a reply.