Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 27 Oct 2008 01:44 PM by  mathieu
USB Ports on Expansion board
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages

arjun.kv@7lf-tech.com



New Member


Posts:
New Member


--
08 Nov 2007 11:12 PM
    I tried to use the USB3 and USB4 ports on the expansion board. But i could not detect any usb device connected to the ports, no messages come through. Although when i connect a mouse or usb the light comes up(i.e. powered up). Anyone knows what could be the problem here?

    Thanks

    mathieu



    New Member


    Posts:
    New Member


    --
    27 Oct 2008 01:44 PM
    hi

    are you sure your kernel supports these 2 usb ports?

    I have a 2.6.22 kernel patched for imx31 litekit and it only has 2 usb ports

    this might be your problem

    when you do make ARCH=arm menuconfig

    look in Device Drivers->USB support

    under support for Freescale controller
    there is only USB1 port and USB2 port in mine

    hope that helps
    -M
    You are not authorized to post a reply.