Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 16 Apr 2009 01:59 PM by  asmoak
TI Xloader 1.41 ECC Failed, Error
 3 Replies
Sort:
You are not authorized to post a reply.
Author Messages

asmoak



New Member


Posts:
New Member


--
16 Apr 2009 12:25 PM
    All, I'm trying to get Android loaded on Zoom MDK. I used the omap droid sites, etc. to figure out how to (almost) to build and reprogram the device.

    I reprogrammed the boot loaders, etc. and now get the error:

    ECC Failed, page 0x00080000 followed with a good bit of hex data
    12 0 0 ea 14 f0 9f e5 14 f0 9f e5 14 .......

    I looked around for any info on this but couldn't really find anything.

    At this point I don't get a prompt when I power the device on, only the error message.

    Is there a way to recover from this?

    Thanks.

    Andy Smoak

    richard.laborde@logicpd.com



    Basic Member


    Posts:247
    Basic Member


    --
    16 Apr 2009 01:03 PM
    Andy,

    Look for the bootable SD card files in your account on our web site. There is documentation available to help you get u-boot back on the device.

    Thanks

    Richard

    asmoak



    New Member


    Posts:
    New Member


    --
    16 Apr 2009 01:17 PM
    Richard,
    Thanks for the quick reply. Since I posted I have tried a couple of things.

    1. Took an SD card, created 2 partitions on it. The first was a bootable Fat32 partition. 64 Megabytes. Second partition is a Linux partition, not listed as bootable by fdisk
    2. Downloaded the MicroSD card bootable objects from your website, copied them to the first partition. (actually I also tried the ones I built too)
    3. Powered off the Zoom, inserted the card, powered on.
    4. I get the same result, I get stuck with the error message on the screen.

    I didn't actually see any instructions on how to use the boot files, so I'm assuming I did the right thing. If there are some instructions I missed, I would appreciate it if you could provide a pointer. My concern is that this is an x-loader problem too.

    Andy Smoak

    asmoak



    New Member


    Posts:
    New Member


    --
    16 Apr 2009 01:59 PM
    Problem solved.

    The files downloaded from the LogicPD website worked for me. I missed a statement on an online page that said that the SD file system had to be set up in an exact manner (Partion 1, with 255 heads and 63 sectors).

    I repartitioned the SD card and re-copied the files that are from the website, now I'm back to a boot prompt. I should be able to reprogram from there.

    Thanks.
    You are not authorized to post a reply.