Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 04 Dec 2005 11:28 PM by  sailqiu@163.com
Confused about on board flash booting?
 2 Replies
Sort:
You are not authorized to post a reply.
Author Messages

sailqiu@163.com



New Member


Posts:
New Member


--
28 Nov 2005 06:46 PM
    Hello, all
    I have added jffs2 support and also mtd support to the kernel, and rebuilder kernel, but it seemed not any change when boot on target.
    (my platform is LH79520-10 with 8M Strataflash and 2.4.17-rmk2-lineo5)

    So I added to "linux/arch/arm/config.in" direct
    CONFIG_MTD=y
    CONFIG_MTD_PARTITIONS=y
    CONFIG_MTD_CHAR=y
    CONFIG_MTD_BLOCK=y
    CONFIG_MTD_CFI=y
    CONFIG_MTD_CFI_INTELEXT=y

    rebuild kernel and download
    On the target, "cat /proc/device" I can find devices
    90 mtd
    31 mtdblock
    but "cat /proc/mtd" I can not find any device, and there aren't mtd and mtdblock devices in "/dev"

    I'm still not sure which files under /maps is used for my flash?
    When "make menuconfig", there are three devices for flash:
    NORA, INTEGRATOR and XScale

    What's the problem?

    Thanks a lot!

    Anonymous





    Posts:


    --
    02 Dec 2005 05:34 PM
    Hello Sail,

    This Linux port is not directly supported by Logic. I would suggest contacting Sharp for assistance since they are now the one's that maintain this code:

    http://forum.sharpsma.com/

    http://www.sharpsma.com/support.php

    If you need specific development assistance these questions could be handled under a support contract.

    Thanks,

    sailqiu@163.com



    New Member


    Posts:
    New Member


    --
    04 Dec 2005 11:28 PM
    Thanks
    I have solved the problem....
    It's OK after I changed my CROSS_COMPILE
    You are not authorized to post a reply.