Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 26 Jan 2006 11:05 AM by  Anonymous
Problem connecting with IAR Jlink probe
 7 Replies
Sort:
You are not authorized to post a reply.
Author Messages
Nick Bodis
New Member
New Member
Posts:


--
03 Oct 2005 08:09 AM
    I'm evaluating the IAR Workbench IDE with Jlink (JTAG) probe for the LH79520. I'm using windows XP. I'am unable to connect to the target. Error dialogs indicate the JTAG probe is unable to correctly communicate with the ARM core.

    I've tried various target connections from the IAR options dialog without success.
    kurtl@logicpd.com
    New Member
    New Member
    Posts:


    --
    03 Oct 2005 10:20 AM
    Have you tried setting the jumpers on J6 to short pins 1,3 and 4,6? That will put the processor in JTAG mode.
    Nick Bodis
    New Member
    New Member
    Posts:


    --
    03 Oct 2005 10:32 AM
    Yes I have set the jumpers, - I should have mentioned that in the post. The J6 jumpers are the only jumpers I configured on the board.
    kurtl@logicpd.com
    New Member
    New Member
    Posts:


    --
    03 Oct 2005 12:33 PM
    Next step would be to check the pinout of the IAR JTAG cable to make sure it is the same as the J36 header on the SDK baseboard. The signals names can be found on the SDK schematics page 9. http://www.logicpd.com/do...lce-app-10_Rev_H.pdf

    If they look good, the next step would be to verify the LH79520's required nRESETIN and nTRST timing versus what the IAR outputs. Most JTAG devices allow for timing modifications to be made to the nRESET/nTRST signals to be adaptable to multiple processors.

    Have you contacted IAR to find out if they have successfully made their device work with the LH79520 ARM 7 processor?
    Nick Bodis
    New Member
    New Member
    Posts:


    --
    03 Oct 2005 02:12 PM
    I spoke to a customer of IAR that has used jLink with the Sharp LH79520. My version and his may be different and/or possibly I'm missing something in my setup. When he returns from a field trip later this week I will look into this.

    I'm verifying the JTAG pinout and timeouts.

    Thanks very much for your suggestions.
    Nick Bodis
    New Member
    New Member
    Posts:


    --
    04 Oct 2005 12:22 PM
    After securing the JTAG connector the download works fine.

    I have downloaded Micrium's uC/OS RTOS and their network stack using IAR's embedded workbench IDE. The development tools, RTOS and network stack are working just fine.
    mbashiri
    New Member
    New Member
    Posts:


    --
    26 Jan 2006 08:26 AM
    Hi Nick,

    I started to work SDK 79520 and IAR J_Link, please more explain about the connection and softwares.
    What's mean securing?

    Best regards,
    Masood
    Anonymous
    Posts:


    --
    26 Jan 2006 11:05 AM
    Hello Masood,

    IAR has experience working with our kits with their tools. I'd recommend contacting their support department for more information in this regard. I personally don't have any information about using these tools but I do know that many customers are using them with our kits.

    http://www.iar.com/

    Thanks,
    You are not authorized to post a reply.