Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 10 Jan 2006 09:44 AM by  mikee@logicpd.com
Network Working ?
 4 Replies
Sort:
You are not authorized to post a reply.
Author Messages
philwil@sysdcs.com
New Member
New Member
Posts:


--
12 May 2003 04:41 PM
    HI,
    I am trying to get the networking set up
    on the Zoom Cardengine.

    I ran the system test which prompted me to
    enter the last 3 digits of the MAC address.
    I can do an ifconfig on sm0 but the system does not seem to bring up the interface
    properly.

    I see no 10/100 link lights on the hub
    and I get a
    "Partition " light on my SMC Hub.

    Cables etc are all fine.

    best regards
    Phil WIlshire
    mikee@logicpd.com
    New Member
    New Member
    Posts:


    --
    20 May 2003 09:02 AM
    Hi Phil,

    Could you please tell me a little more about your setup? For instance, are you connecting to a hub, switch, etc.? Also, does the hub support both 10 and 100 MBs Ethernet speed? Finally, how old is the hub? The SmSC 91C111 Ethernet chip uses an auto-negotiation algorithm to determine which speed (10/100) and duplex (half/full) to run at. Some older networking equipment has trouble with this.

    As to the system test prompting you to enter the last three digits of the MAC address. The test should have asked you if you would like to change the MAC address however, it shouldn't have been necessary to actually do so. Please make sure that you still have a valid Ethernet MAC address. Note that all 0xff's and all zeros are reserved.

    Finally, could you please tell me the exact command line you gave to ifconfig? It should have been something like:

    ifconfig sm0 dhcp

    Oh, and of course you need to have a DHCP server running on your network in order to get a proper IP address.

    Please respond and we will work this through with you.

    Best regards,

    --mikee
    aaron_spear
    New Member
    New Member
    Posts:


    --
    09 Jan 2006 10:43 PM
    oK, I realize that this thread is ancient, but I am seeing the exact same symptoms. with my Rev B LH7A404 Card Engine and Rev K Zoom board. I have not been able to get the networking to work until after I run the "test-net" program, and conceivably it resets the MAC address of the board. it is like the MAC address is not getting persisted at all. Where is the MAC stored? In the EEROM?

    Below is what I get when I just type in test-net. it forces me to input a new MAC address. Note that after I do this, I can run ifconfig, set an ip address and then run the ping test and such fine. However, if I reset the board or power cycle it, the MAC address is gone again (all zeros from the looks of it)

    losh> test-net


    Programming Ethernet MAC Addr:

    00-08-ee-xx-xx-xx:
    Enter Last Three Bytes of MAC Address and hit enter:
    in the form: 0xFF 0xFF 0xFF
    0x00 0x84 0xB2
    Current MAC Address: 00:08:ee:00:84:b2

    MAC Address will be: 00:08:ee:00:84:b2

    The board must be Reset for the Ethernet
    Chips to detect new addresses
    ..............................
    Functional Hardware Test Complete.
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    FAIL FAIL FAIL FAIL FAIL
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    LoLo Version : 1.4.4p6-LLH7a404_10 0001
    ETHERNETTEST - No packet received
    losh>


    regards,
    Aaron Spear
    Mentor Graphics Corp.
    aaron_spear
    New Member
    New Member
    Posts:


    --
    09 Jan 2006 11:11 PM
    I guess i should say that it is hooked up to a 10 base T hub at the moment. Before I had it hooked up to a 100 T switch, but have had issues with some chipsets and that box before so I decided to remove the variable.

    Aaron spear
    mikee@logicpd.com
    New Member
    New Member
    Posts:


    --
    10 Jan 2006 09:44 AM
    Aaron,

    First things first, you should *really* update to the latest version of the Logic Loader software. The fact that you can run 'test net' at all leads me to believe that you are running a very old version. Please log in to the downloads section of our website and upgrade.

    If the 'ifconfig' commands don't work at that point, post back and we'll work from there.

    Thanks,
    --mikee
    You are not authorized to post a reply.