Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 16 Aug 2005 01:40 PM by  Anonymous
Logicloader bitmap problems
 1 Replies
You are not authorized to post a reply.
Author Messages
New Member
New Member

11 Aug 2005 03:35 PM
    Has anyone had any luck loading a bitmap from flash? I have followed the instructions to the "t" but I haven't been able to get any bitmaps to load.

    I have tried with 8 bit (256 colors) and 24 bit (thousands of colors) bitmaps. I have tried ones that are the full size of the screen and ones that are very small. I have placed them by specifying ranges, and with the default. I have specified ranges that are larger than the files, the same size as the files and smaller than the files. I have opened screen with "video-open 6 8" and also "video-open 6 16" and still no luck.

    In fact, I have tried every combination of the above options and I still can't get a bitmap to load. The bitmaps are ".bmp" files created with ms paint, they aren't compressed, and I have tried loading them with and without the dot bmp extension.


    The bitmaps themselves seem to load from left to right and from the bottom of the screen up. They start out loading correctly for the first 10 or so lines (I can see the bottoms of the pictures I have loaded) but they soon turn to black pixels only and fill the rest of the specified area.

    I can take the flash card out and pop it back in my pc and the images are perfectly readable still,it's not as though they were corrupted and only the bottom of them is there.

    It seems as though some sort of buffer is giving up after the first x pixels and tossing black pixels on the screen thereafter. Is this a problem with my hardware, or a bug in the LogicLoader program? The screen works when I paint a flag on it, or use the paint program, (although it only works for so long before freezing up when using paint, one of many glitches it seems).

    If anyone has any thoughts I'd appreciate it since I would certainly want to rule out a hardware problem before I started really putting this kit through its paces.

    Thank you all in advance for any thoughts you may have.


    <edit> if any of the support team out there wants copies of the bitmaps I am using I would be happy to pass them along. All of them load correctly for a few lines and then turn to black.

    I am starting to believe that there is no fundamental problem with the hardware, but rather that there is an error in LoLo that prevents bitmaps from displaying with these specific logicpd devices.

    16 Aug 2005 01:40 PM
    Hello Leeds,

    If you are still having problems with this issue please email with bitmaps in question and I'll take a look at this for you.

    You are not authorized to post a reply.