Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

PrevPrev Go to previous topic
NextNext Go to next topic
Last Post 04 Dec 2007 02:06 AM by  ruudelsinghorst
Getting started with the lh7a404: make tool errors.
 1 Replies
Sort:
You are not authorized to post a reply.
Author Messages
ruudelsinghorst
New Member
New Member
Posts:


--
19 Nov 2007 03:33 PM
    Environment setup problem getting started with the lh7a404.
    I solved some of the problems with the environment variables but when running make I get the following output:

    C:\sharpmcu\software>make --debug
    GNU Make 3.80
    Copyright (C) 2002 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.
    There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
    PARTICULAR PURPOSE.
    Reading makefiles...
    Updating goal targets....
    File `libs' does not exist.
    File `csp' does not exist.
    Must remake target `csp'.
    compiling lh7a404 chip support package source -> C:sharpmcusoftware/csps/lh7a404
    /source
    GNU Make 3.80
    Copyright (C) 2002 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.
    There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
    PARTICULAR PURPOSE.
    Reading makefiles...
    Updating goal targets....
    File `objs' does not exist.
    File `LH7A404_clcdc_driver.o' does not exist.
    Must remake target `LH7A404_clcdc_driver.o'.
    make[1]: Entering directory `/cygdrive/c/sharpmcu/software/csps/lh7a404/source'
    C:\cygwin\logicpd\gnutools\v3-1\bin\arm-elf-gcc -c -mcpu=arm920t -gdwarf-2 -Wall
    -O3 -mapcs-frame -mno-sched-prolog -fno-hosted -mno-thumb-interwork -IC:\cygwin
    \logicpd\gnutools\v3-1\arm-elf\include -IC:\cygwin\logicpd\gnutools\v3-1\include
    -IC:\sharpmcu\software/csps/lh7a404/include -IC:\sharpmcu\software/csps/lh7a40
    4/bsps/sdk7a404/include -IC:\sharpmcu\software/abl/include -I../Include LH7A404_
    clcdc_driver.c -o LH7A404_clcdc_driver.o
    make[1]: *** [LH7A404_clcdc_driver.o] Error 57
    make[1]: Leaving directory `/cygdrive/c/sharpmcu/software/csps/lh7a404/source'
    make: *** [csp] Error 2



    Does somebody know what error 57 is, or what I did wrong?
    Also a question about the text: `/cygdrive/c/sharpmcu/software/csps/lh7a404/source'
    Is this just output from make or does it indicate an error with the path since this path does not exist and should it be changed somewhere to
    `c:\sharpmcu/software/csps/lh7a404/source'
    (I noticed it is allowed now to use both slash and backslash in a MS-XP DOS-shell)

    Is there another way running make to get more usefull error messages?
    I alreay tried make -d. It gave a lot more output but I did not find more usefull error messages.

    Any help would be appreciated.
    Ruud
    ruudelsinghorst
    New Member
    New Member
    Posts:


    --
    04 Dec 2007 02:06 AM
    The problem is solved. I found the answer in the FAQ:
    Update Cygwin.
    http://www.logicpd.com/su...q/faq.php?faq_id=186
    You are not authorized to post a reply.