Go to previous topic
Go to next topic
Last Post 23 Apr 2018 08:25 AM by  mfonseca@keywcorp.com
RTC issues on 4.9.x ?
 2 Replies
Author Messages
mfonseca@keywcorp.com
New Member
New Member
Posts:15


--
19 Apr 2018 05:42 PM

    Hello Adam,                                                                                                                                        
     

    Are there any known problems with the RTC using a mainline kernel?  I'm currently at 4.9.94 and seeing inconsistant readings from the rtc.    I sprinkled twl_rtc_read_time() with some logging and noticed about half the time I get incorrect values.

     

    Also, I noticed (via another thread) you are close to release a 4.9 kernel.  Are there patches on your end that are not in mainline that would be avalible?

                                                                                         
    Thanks,                                                                                                                                       

    Marco Fonseca

    adam.ford@logicpd.com
    Advanced Member
    Advanced Member
    Posts:783


    --
    23 Apr 2018 06:59 AM
    The patches I submitted to help are: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/arch/arm/boot/dts/logicpd-torpedo-som.dtsi?h=v4.9.95&id=c737c8d04d16c4259ced96fdd69e6664aa64d926

    I think they part of 4.9.94, so if you're still having issues, try slowing the I2C1 clock from 2.6MHz to 400KHz.

    &i2c1 {
    pinctrl-names = "default";
    pinctrl-0 = <&i2c1_pins>;
    clock-frequency = <400000>;
    ...
    };
    mfonseca@keywcorp.com
    New Member
    New Member
    Posts:15


    --
    23 Apr 2018 08:25 AM

    Changing the clock form 2.6mhz to 400khz did indeed solve the problem!

    Also as you said, the patch you linked to had alread been applied.

    Thank you!

     

    Marco Fonseca



    ---