Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 1 of 212 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 2230 Views 32 bit access on lh524 on external connector  2230  1 Started by  sreedhar Hi, I am trying to port code from lh520 to lh524 and need to read from a 32bit io resource. In the lh520 board, Video_nCS was available and worked for 32 bit access at address 0x44000000 In lh524, I could not see how to get Video to work. So, I am trying both fast_nmcs and slow_nmcs signals to access the same 32 bit resource on my application board ( custom ). The moment I switch the configuration of the SMC to 32 bit, the board quits getting either of the chip selects. Can someone clarify ...
1 2230
by  Kevin DarmasaputraJump to last post
22 Nov 2017 01:34 PM
0 Replies and 1033 Views LH79524 Card Engine .DSN and .MAX  1033  0 Started by  Kevin Darmasaputra Hi, Is LH79524 Card Engine .DSN and .MAX available anywhere In the support website they only have .DSN and .MAX for the SDK app board. Any help will be greatly appreciated. Thank you
0 1033
17 Nov 2016 06:53 PM
6 Replies and 2158 Views how to register legacy product  2158  6 Started by  Deleted User i have 6 new sets of the zoom sdk with nxp lh79524 from e-bay. I try to register the first of these sets on your site, but the type is not longer listed in the drop down box. Without registering I can't download all the packages i would need for hardware pinout information and also the software is missing . can you help me please to figure out, what i should do thank you for the service Best Regards
6 2158
by  Kevin DarmasaputraJump to last post
17 Nov 2016 12:44 PM
1 Replies and 1957 Views Linux bootloader  1957  1 Started by  Deleted User Hi, I want to up and run Linux on my LH79524 board. i need Zimage for same but i didn't get. even i didn't got any patch for kernel. &91b&93(zImage-lpd79524)&91/b&93 Please help me to solve this problem.
1 1957
by  Deleted UserJump to last post
29 Sep 2011 08:29 AM
0 Replies and 1912 Views LH79525 - JTAG Communication using IAR  1912  0 Started by  steveli Hi, We have a Board on LH79525 and using IAR debugger. When we tried to download code using J-Link, we are getting some warning messages as shown below : Tue Aug 31 16:06:53 2010: JLINK command: ProjectFile = D:\Project 350\Firmware\100826_Project350_CSDES Program\settings\ BasicLcd_DebugRunFromFlash.jlink, return = 0 Tue Aug 31 16:06:53 2010: JLINK command: device = LH79525, return = 0 Tue Aug 31 16:06:53 2010: DLL version: V4.14i, compiled Aug 12 2010 20:19:20 Tue Aug 31 16:06:53 2010: Fi...
0 1912
06 Sep 2010 04:49 AM
0 Replies and 1682 Views LH79524 LCD display  1682  0 Started by  steveli Hi, We are working on Programming for NXP – LH79524 EVB. We also bought LH79524 Zoom SDK (SDK-LH79524-10-3216R) from Logic PD (http://www.logicpd.com/products/develop ... 84A2-sdk). We have downloaded Sample program from NXP website – Basic LCD display and could display on Sharp LCD. But there is some problem with display. It is repeating at bottom & right side. The sample image is not fitting into entire LCD screen. How to resolve this Can anyone has problem like this Also Can anyo...
0 1682
15 Jul 2010 12:51 AM
2 Replies and 1648 Views Display not listed!!  1648  2 Started by  kaursat We are using the 3.6" Sharp Display - LQ036Q1DA01. However, help video-open doesnot list our display. Please suggest. In the user manual under the Video section, it says we can save upto 8 LCD settings by using the 'config' command with 'V' option. It then says: To store the custom setting, "we need to set up the controller". How do I set up the controller Below is the portion from the manual for reference. Kindly comment. Video: A customer may save up to eight custom LCD ...
2 1648
by  MswinnyJump to last post
09 Sep 2008 04:28 AM
1 Replies and 1950 Views LH79524/79525 memory  1950  1 Started by  nambinhngo Hi all, I need some help. I am currently working on the project which utilizes the LH79525 MCU. I designed my own board, which used SRAM instead of SDRAM comparing to the logic sdk79524 eval board. the SRAM is mapped on CS0 location 0x40000000, and the flash is at 0x44000000. I loaded the startup program from the BSP package, and the unit did not initialize at all. I tried the led_flasher examples and added the memory-init, clock init, gpio, and iomux. the unit initialized such as CLKOUT = HCLK...
1 1950
by  nambinhngoJump to last post
08 Sep 2008 04:30 PM
0 Replies and 1823 Views Keil JTAG cannot download code to LH79524  1823  0 Started by  steveh_iniche Hi, I am using Keil uVision3 3.62c IDE to develop a standalone application for the LH79524 eval board. I am using the ULINK-ME JTAG interface. I cannot download code to either the SDRAM at 0x20000000 or the SRAM at 0x44000000. All I get is either "Full Chip Erase Failed!" or "Erase Failed!". Build target 'Target 1' linking... Program Size: Code=113944 RO-data=3952 RW-data=3860 ZI-data=12556 ".\obj\nichelite.axf" - 0 Error(s), 0 Warning(s). Full Ch...
0 1823
09 Jul 2008 07:57 PM
0 Replies and 1640 Views Logic Loader for LH79525  1640  0 Started by  nambinhngo I am using the LH79525 for me new design. Will Lolo be compatible with the LH79525
0 1640
26 Jun 2008 11:35 AM
5 Replies and 3077 Views IAR JTAG Cannot Talk to NXP LH79524  3077  5 Started by  dwills Hi, For some reason, my JTAG cannot connect to the ARM. The J-Trace recognizes board power but not the chip. The starter kit baseboard quick start guide shows n/a for the jumper settings on J6. I assume this means no jumpers, but I tried all combinations of jumpers on J6 and none work. Both the J-Trace and the Zoom starter kit are new out of the box, so it's unlikely either is bad. Anyone have any ideas of what I might try next Thanks, Dave
5 3077
by  addyyangJump to last post
03 Jun 2008 02:53 PM
1 Replies and 1866 Views issue when mount fatfs /cf in logic loader  1866  1 Started by  addyyang i got a 'bad partition magic (00 00)' error... please advice...thanks! losh> mount fatfs /cf read_partition_info: bad partition magic (00 00) 0x200441fc 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 0x2004420c 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 0x2004421c 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 0x2004422c 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................ 0x2004423c 00 00 00 00 00 00 00 00 00 0...
1 1866
by  addyyangJump to last post
03 Jun 2008 02:51 PM
0 Replies and 1500 Views Adding extra serial ports using quad UART device  1500  0 Started by  colin324 I have added 4 serial ports to the LH79254 card, using the ST16C554A Quad UART. Using SLOW_nMCS, nIOWR, nIORD, address and data lines I can sometimes get data onto the scratchpad in the UART, sometimes I can read it back too. The issue I have is that sometimes both the nIOWR and nIORD lines seem to both occur together. Do I need any further control lines I am using the memory area 0x4900 0000 – 0x49FF FFFF, as the technical info states for my IO.
0 1500
05 Dec 2007 08:57 AM
1 Replies and 1770 Views SHARP LH79525 & SAMSUNG K9F1G08U0A  1770  1 Started by  Deleted User Hello, LOGICPD! ========== With standart configuration of &91LH79524 Zoom Starter Development Kit&93 in SEGGER JTAG SOFTWARE used following initialization of CPU SHARP LH79524 and flash SHARP LH28F128SPHTD-PTL12. ======================================================== 01) Action "Reset startup" by address &910x00000000&93 write value &910x00000000&93. 02) Action "Enable APB register write access" by address &910xFFFE2000&93 write value &910x00000260&93. 03) Act...
1 1770
by  Deleted UserJump to last post
04 Aug 2007 01:04 AM
10 Replies and 1855 Views Restoring Logic Loader  1855  10 Started by  rrobbins6111 I am using the Rowley CrossStudio and CrossConnect. Everyting was going well until I tried to execute a program out of flash. Now whenever I try and do anything with the JTAG I get a message 'Cannot Stop Target', and I cannot load any of the .ELF files provided for restoring Logic Loader. Are there any specific instructions on how to do this or do you have any other suggestions
10 1855
by  rrobbins6111Jump to last post
13 Jul 2007 12:49 AM
0 Replies and 1345 Views Problem in using I2c Bus  1345  0 Started by  Deleted User I am trying to interface a keyboard with the dev kit through the MAX7349 controller using the I2C module of the 79524. I have taken connection form Expansion slot J38's pin 57 (MFP23,K2) as SCL and pin 58 (MFP24,K3) as SDA I first wrote a small C program in Logic Loader but when I tried to access the MUXCTRL4 register to define I2C for the i/o pins, I get a segmentation fault. What am I doing wrong So instead I tried to create a small module inside the Linux kernel. This is what I do inside t...
0 1345
16 Dec 2006 03:31 AM
0 Replies and 1399 Views I2C communication to external peripherals  1399  0 Started by  gaspertom Does anyone know of any sample code or library to communicate with external periphials using the I2C protocol via the GPIO pins
0 1399
30 Nov 2006 03:58 PM
1 Replies and 1699 Views CF Card not recognized  1699  1 Started by  Deleted User Hi, Am trying to load linux using the CF card. However, when I try to detect the CF card on LoLo, I get the following errors. losh> mount fatfs /cf ata_wait_drq (1): bsy wait timeout 20279000 20283000 timeout resetting cf card ata_wait err: 37 ata_wait err: 33 ata_wait err: 47 ata_wait err: 47 ata_wait err: 47 ata_wait err: 47 ata_wait_drq (0): bsy wait timeout 20295000 20300000 error: mount: failed to open (ATA) I am using a Sandisk 128MB card which I formatted both as Fat and as ext2 and ...
1 1699
by  Jump to last post
06 Oct 2006 03:17 PM
5 Replies and 1801 Views Fried LogicLoader  1801  5 Started by  Deleted User Hi, I was trying to attempt to modify the Apex bootloader to boot over the network and somewhere issued a 'delete $env' command. Now the SDK can't seem to boot up. I have a JTAG-ICE but that doesn't seem to work with the kit. Any ideas on how I can restore logic loader without using the Jtag interface Thanks, Joy.
5 1801
by  Jump to last post
28 Sep 2006 09:15 AM
1 Replies and 1781 Views Booting over Network  1781  1 Started by  Deleted User Hello, I do not have a compact flash card and wish to load linux over the network. The configuration that is used with the bsp assumes a compact flash card to be used for loading the kernel. What would I need to do in order to accomplish booting over the lan network and not a compact flash card Any help will be much appreciated. Regards, Joy.
1 1781
by  Jump to last post
05 Sep 2006 10:39 AM
You are not authorized to create a new topic
Page 1 of 212 > >>


RSS Feed Available