Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 4 of 6 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
2 Replies and 1176 Views Lolo and Bolo can't be restored.  1176  2 Started by  hiroki Hi everyone, I'm trying to restore the lolo and bolo on my sdk-lh79520 board with reffering the LogicPD's Application Note 248. But the restore sequence failed after I hit 'Ctrl-C' on the gdb prompt. The following message has displayed at that time: Attempt to force processor to enter debug state failed - excution continues. Could you help me
2 1176
by  hirokiJump to last post
08 Sep 2004 10:07 PM
1 Replies and 1188 Views I/O controller headaches  1188  1 Started by  Deleted User Would anyone know the reason why when I peek and poke at the card engines control register at 0x54200000 under LOLO, I/m not able to clear the LAN power enable bit... When I read back the registers value, I also see that bit 1 is sometimes set (no documentation I've seen refers to this bit as being of any use)... I've only been able to download logics P/N: 70000015 I/O controller spec sheet (next to useless), and would like to know where I can get my hands on some detailed timing data, bit d...
1 1188
by  mike teschJump to last post
22 Aug 2004 06:39 AM
1 Replies and 1279 Views Problems with LOLO Boot scripts that use network interface  1279  1 Started by  JadePhoenix Greetings, while testing the 'LOLO boot script' feature i seem to have problems to get remote boot (image via TFTP) to work ... I doesnt matter if i use static or dynamic (DHCP) config. Quote: echo 'LOLO ifconfig sm0 198.120.75.7 255.255.255.0 198.120.75.252 ; ifconfig sm0 up ; exit\n' /dev/serial_eeprom Quote: losh> Àlosh> ifconfig sm0 198.120.75.7 255.255.255.0 198.120.75.252 ; ifconfig sm0 up ; exit MAC Address: 00:08:ee:00:50:74 MAC Address: 00:08:ee:00:50:74 *******************...
1 1279
by  scottpitcherJump to last post
16 Aug 2004 08:08 PM
1 Replies and 1154 Views Nested Interrupts using LH79520  1154  1 Started by  Deleted User Hi, Has anybody implemented nesting of interrupts in LH79520 I have a requirement where I need to switch to a higher priority interrupt when the controller is already processing in a lower prioroty ISR. Thanks for the help. Regards, Srikanth
1 1154
by  mike teschJump to last post
15 Aug 2004 02:44 PM
2 Replies and 1202 Views LCD - LQ64D343 (sharp) does now work.  1202  2 Started by  Deleted User Hi, I have taken the starter kit and after putting all things togather losh comes up and works fine. I have LQ64D343 LCD separate and have made the LCD cable according to specs. Upon connecting all things and doing 'video-open 5 16' on losh prompt does not work. It gives time out and LCD remains as it is with some random vertical lines. Any inputs Is this proper way to test ( Logic ) or we can't use separate LCD and our data cable I will appreciate any input on this.. thanks bye ketan
2 1202
by  Deleted UserJump to last post
12 Aug 2004 08:02 AM
3 Replies and 1225 Views newer arm-linux-gcc crosscompiler toolchain possible?  1225  3 Started by  JadePhoenix Greetings! I just want to know if someone successfully used a newer arm-linux-gcc cross toolchain either prebuild or self-made. The one supplied with the BDK is rather old (2.95.x) and is not suited for our application development needs (C, templates) . Is upgrading to newer toolchain (3.4.x with glibc 2.2x, libstdc v3) for this platform possible without much work/sidefalls Did someone use cross toolchain build scripts like 'crosstool' for this purpose Thanks in advance. Best regards.
3 1225
by  JadePhoenixJump to last post
14 Jul 2004 08:26 AM
2 Replies and 1217 Views Wiggler problems  1217  2 Started by  peter_vc I've downloaded the free JTAG software from Macraigor, set my parallel port to both standard and EPP in the CMOS, connected a full 25pin straight through cable to the Wiggler, ensured my jumper settings are correct on the SDK board but the software keeps giving me a 'cable disconnected' error. The LED's flash on the board untill I try to connect to it from the software, then they stop flashing and Status LED 1 remains lit. If I then hit the reset button, all the LED's remain off and I gotta pu...
2 1217
by  peter_vcJump to last post
15 Jun 2004 06:02 AM
1 Replies and 1155 Views Lolo and Threadx  1155  1 Started by  jmcclin2 Hi, I want to run Threadx app on the evaluation board in SDRAM; how can encapsulate the interrupts and exceptions for ThreadX if Lolo is down at location 0 where my interrupt/exception table should be (Or am I missing something here). All of the low-level threadX code that I have seen requires you to 'route' the interrupts and exceptions through Threadx so that it can save/restore the context properly. Any insight would be great, thanks, Jeremy
1 1155
by  Jump to last post
11 Jun 2004 03:02 PM
1 Replies and 1186 Views Lineo changes to build.sh for ncurses (20 May 2004)  1186  1 Started by  noonan Lineo (Metrowerks) posted a new build.sh script on their download site on 20 May 2004. Apparently, ncurses fails to build in the lh79520 BDK. It does not find the correct librairies. diff shows the following change between the new and original script&058; Quote:1650c1649 < make --- > make libdir=$DEV_IMAGE/$prefix/lib This make command is at line 1668, just below the line that reads cd $PROJECT_DIR/build/rpmdir/BUILD/ncurses-5&46;2 I made this change to the LogicPD supplied build....
1 1186
by  noonanJump to last post
25 May 2004 02:54 PM
3 Replies and 1297 Views Possible Documentation Error  1297  3 Started by  Anonymous The PeriphClkCtrl register in the RCPC is documented in the Sharp literature as: b3 : (reserved) b4 : 0=Enable timer 0 & 1 clock. 1=disable. b5 : 0=Enable timer 2 & 3 clock. 1=disable. b6 : (reserved) But, in the include file src/inc/sharp/LH79520_rcpc.h, we see... define RCPC_CLKCTRL_CT0_DISABLE _BIT(3) define RCPC_CLKCTRL_CT1_DISABLE _BIT(4) define RCPC_CLKCTRL_CT2_DISABLE _BIT(5) define RCPC_CLKCTRL_CT3_DISABLE _BIT(6) Who's right
3 1297
by  Jump to last post
23 Mar 2004 10:32 AM
2 Replies and 1329 Views BoLo wont flash LoLo  1329  2 Started by  Anonymous I have overwritten LoLo with our application code to make sure it starts correctly on a reset. It does, so I then tried to use BoLo to re-flash the LoLo back in. The LoLo ELF image loads OK, but the burn command reports unable to open /dev/flash11 for burn Typeing 'burn /dev/flash11' gives the same result. How can I reflash LoLo into the card engine Many thanks. P.S. Are these support questions actually monitored or acted upon
2 1329
by  Jump to last post
15 Mar 2004 04:04 AM
6 Replies and 2005 Views Console: switching to colour frame buffer device 30x40  2005  6 Started by  Deleted User I'm not sure what this message means. It is the last thing I see printed when the kernel boots. Yet, I'm not finding it by grep'ing through the kernel source. Here's everything. In this case, I tried to change the console to ttyAM0 in case that's the problem. Any pointers Uncompressing Linux.......................................... done, booting the kernel. Linux version 2.4.17-rmk2-lineo5 (elfflorence) (gcc version 3.2.3 20030221 (Deb ian prerelease)) 1 Sun Jun 8 10:54:56 PDT 2003 Pr...
6 2005
by  Deleted UserJump to last post
21 Feb 2004 06:02 AM
6 Replies and 1326 Views problem loading 'elf VMLINUX'  1326  6 Started by  Deleted User hi I have a 256 MB CF card, on which i have made the partitions as mentioned in teh readme and copied VMLINUX on the fat partition(bootable). when i try the command - load elf VMLINUX through tera term , I am getting the following error- (i have pasted the whole screen for reference) losh> mount fatfs /f act c h s type c h s lba sects part 0: 00 001 01 00 83 00e 30 7a 00000030 000159c0 unknown type part 1: 80 000 01 7b 06 00e 30 af 000159f0 00009510 ...
6 1326
by  Deleted UserJump to last post
05 Feb 2004 07:50 PM
1 Replies and 1165 Views Support fro LCD-6.4-VGA-10  1165  1 Started by  Deleted User Hi What should I do to be able to use the 6.4 inch display instead of the default 3.5 inch TFT together with a Linux OS. I have installed the development tools out of the CD image 'sharp_lh79520_embedix_bdk.iso' onto a Linux PC. Compiled and installed the kernel and files into the target ARM based LOGIC SDK-LH79520-10 using a Compact Flash disk. I get everything up and running but the display LCD-6.4-VGA-10 / LQ64D343 only shows random vertical color lines. In the 'Linux Application Note ...
1 1165
by  Deleted UserJump to last post
04 Feb 2004 11:12 AM
1 Replies and 1132 Views CompactFlash  1132  1 Started by  Deleted User I just got a Zoom SDK. I installed a PQI 128MB CompactFlash card. When I run a funtest (do not know how to check the CF directly yet) the SDK reports back not Compact Flash found.
1 1132
by  Jump to last post
27 Jan 2004 09:12 AM
5 Replies and 1220 Views networking under linux  1220  5 Started by  Deleted User Hello - I can do ifconfig sm0 dhcp from Lolo and get an IP address and even ping my gateway. However, when I start linux, there is no device sm0 and the eth0 device wont start as expected. The IP I get when I use ifconfig from Lolo is 192.168.1.119. I've tried various things: starting the kernel with: exec root=/dev/hda1 ip=dhcp and exec root=/dev/hda1 ip=192.168.1.119 with no success (with and without having Lolo bring up the adapter first) I've also tried the following after the ...
5 1220
by  Deleted UserJump to last post
12 Dec 2003 11:18 AM
1 Replies and 1223 Views mount PQI FC064 COMPACT FLASH CARD  1223  1 Started by  Deleted User Hi! I'm using PQI 64 meg compact flash. I have 2 partitions created according Card Engine document. First partition is the Linux type, second fat16 type with all necessary files copied on those partitions. After that I truing to run mount command and I'm getting back error: losh> mount fatfs /f fatfs_init: ata_read failed (0x80). Any help will be appreciated Thanks, Alexander
1 1223
by  Jump to last post
02 Dec 2003 04:32 PM
2 Replies and 1176 Views CF Reader/Writer for RedHat8.0 - getting file system onto  1176  2 Started by  mpinton I want to copy the file system generated by the build process to a CompactFlash card (yes, type 1) but haven't bought a reader/writer. Does anyone have suggestions for CF reader/writers that are known to work with RH I figure via USB. Can I just use any USB-based CF r/w Any other way to get the file system onto the CF card (anyway to do it from a Windows PC for instance) Thanks.
2 1176
by  mpintonJump to last post
17 Nov 2003 12:37 PM
4 Replies and 1187 Views root file system in onboard Flash not CF memory card  1187  4 Started by  mpinton Hi, Does the current distribution support having the file system located in the onboard FLASH We would like to dispense with the CF for cost and space issues. If it currently doesn't, do you plan on adding this functionality Thanks, /michel
4 1187
by  mpintonJump to last post
12 Nov 2003 12:52 PM
15 Replies and 1264 Views problems copying rootfilesystem to CF partition  1264  15 Started by  mpinton Hi, As a first attempt, I want to load linux from the CF card, so I partitioned my CF card per the directions in the Linux App Note (Logic DN: 70000071 Rev A). However, when I go to copy the rootfsdir to my mount point (the first partition of the card) I get a ton of output from cp indicating problems: - cannot create symbolic links .... Operation not permitted - cannot create special file .... Operation not permitted - failed to preserve ownership .... Operation not permitted A bunch of stuf...
15 1264
by  mpintonJump to last post
11 Nov 2003 08:00 AM
You are not authorized to create a new topic
Page 4 of 6 << < 23456 > >>


RSS Feed Available