Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 2 of 6 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
4 Replies and 1225 Views General Purpose I/O pins  1225  4 Started by  Nick Bodis Can some one direct me to documentation identifying the jumper and pin s for GPIO
4 1225
by  Nick BodisJump to last post
12 Oct 2005 04:15 PM
1 Replies and 1293 Views programming intel flash with lauterbach  1293  1 Started by  oenem000 Hello, I try to erase the intel flash on the LH79520 Zoom board but i can't reach the memory. Can anyone tell me how to do this I used : flash.create 1. 0x40000000--0x403fffff 0x20000 I28f200j3 word to create the flash. Then : flash.erase.all. Flash erase error appears. Thanks. Feike
1 1293
by  Jump to last post
03 Oct 2005 05:30 PM
2 Replies and 1255 Views Linux-2.6 Patches and BSP  1255  2 Started by  Deleted User There is now official support of the LPD79520 for the 2.6 linux kernel. The patches are available by FTP or with the BSP. The best place to start is my wiki. http&58;//wiki&46;buici&46;com.
2 1255
by  michaelJump to last post
21 Sep 2005 07:46 PM
0 Replies and 1069 Views Touch-screen controller and interrupts.  1069  0 Started by  Deleted User I've written a touch-screen controller driver for the Linux kernel. It seems to work. BTW: > The CE has P/N 80000113-057 rev e04. > The CPLD reports revision number 0x20a I haven't been able to determine the role of the PIRQ bit. When I clear the bit, the touch interrupt bit goes low. However, if I leave PIRQ high, the touch controller appears to work correctly. The documentation states that the touch interrupt pin has to be driven for correct operation of the touch cont...
0 1069
10 Aug 2005 08:43 PM
7 Replies and 1227 Views CPLD I2S transmits 8 bits per channel? Or 10?  1227  7 Started by  Deleted User According to the documentation, the CPLD will shift 10 bits per channel, bits 15-6. The output I'm seeing on an oscilloscope shows that there are only 8 bits transmitted per channel. My audio data is a bonafide 16 bits per sample.&91/b&93
7 1227
by  Deleted UserJump to last post
03 Aug 2005 06:36 PM
2 Replies and 1180 Views Audio Codec TLV320DAC23  1180  2 Started by  miguelgu Hi LogicPD Does BSP for LH79520-10 Zoom Development Kit have support to the audio codec Thanks for your help.
2 1180
by  miguelguJump to last post
03 Aug 2005 10:48 AM
5 Replies and 1185 Views Problem when Filesystem is in Compact Flash  1185  5 Started by  Deleted User As per the documentation given ... Logic DN: 70000071 REV:A Loading linux from CF card (Topic 5.2) We have copied the rootfilesystem in the compact flash ... the kernel boots up and ... we keep getting this message in between - before and after having logged in... hda: write_intr: status=0x50 { DriveReady SeekComplete } which eventually corrupts the filesystem in the compact flash. So linux cannot be booted again until the the entire steps to load the files on the CF card are redone (Topi...
5 1185
by  Jump to last post
18 Jul 2005 04:45 PM
2 Replies and 1198 Views LCD becomes unresponsive  1198  2 Started by  tozyagcilar Hello, About 15-20 mins after startup (say, the penguin logo comes up), the display shuts off or becomes somewhat greyish, and it won't respond to any refreshing/drawing. I end up having to restart. Is there a timer to protect the LCD somewhere How to disable it Has anybody else come across this Talat.
2 1198
by  Jump to last post
17 Jun 2005 12:17 PM
1 Replies and 1094 Views Where is the flash image for BOLO?  1094  1 Started by  Deleted User I can find the LOLO flash image in the download area, but the BOLO flash image doesn't appear to be available. There is a RAM image for BOLO which is handy for bootstrapping.
1 1094
by  Jump to last post
02 Jun 2005 09:07 AM
18 Replies and 1399 Views is on board flash booting possible/feasible?  1399  18 Started by  tozyagcilar Hello all, I am wondering if it is possible to boot linux from internal flash(on-board, 8 to 16MB) instead of tftp or CompactFlash. How hard would this be and what needs to be done I am assuming that the two partitions created on CF should somehow be created on the on-board flash also, since the kernel will be looking for the rootfs. How can this be done if at all Is there a way of doing this without partioning Any suggestions/ideas/opinions are welcome... Thanks! Talat,
18 1399
by  tozyagcilarJump to last post
01 Jun 2005 12:00 PM
4 Replies and 1184 Views Display "Ghosting" on LCD3.5-QVGA-10 LCD Module  1184  4 Started by  Deleted User Hi I'm currently in the process of driving LCD3.5-QVGA-10 LCD Module via the SDK-LH79520-10 application board. The problem i'm seeing is that there appears to be display ghosting on the lower half of the display, ie, any bitmap image that's drawn in the upper half of the display replicates itself in the lower half. Bitmap images are drawn to the display via a frame buffer that i've configured the UPBASE register to point to. I'm not sure if this is related but writing to the first 960 locatio...
4 1184
by  Deleted UserJump to last post
01 Jun 2005 11:50 AM
3 Replies and 1232 Views Flash Programming  1232  3 Started by  Deleted User I'm trying to program flash, but to do so, it appears I need to set the VPEN pin high on the flash part. The VPEN signal can be traced back to the CPLD. Can you give me some information on how to control the CPLD to raise this pin.
3 1232
by  iorlovichJump to last post
28 May 2005 06:34 PM
11 Replies and 2517 Views Bad exit status from /var/tmp/rpm-tmp.95425  2517  11 Started by  tozyagcilar Hello all, I am trying to install the bdk under Fedora Core 3. I have been following the document named 'LPD-README' that came with the lpd-linux-LLH79520-1.0.1b.tgz. I ran the script that the document suggested using the modern option as follows: 'sudo ./install-lpd-linux79530-lineo-overlay.sh modern' and once this was done everything seemed fine. I did not see any error messages due to misplaced libraries. I verified the 4 variables in the new build.sh script. Following this I did 'make ...
11 2517
by  gbtwJump to last post
19 May 2005 02:28 AM
2 Replies and 1098 Views Hitachi Colour STN LCD Problem  1098  2 Started by  Deleted User Hi I'm attempting to connect an Hitachi, 320*240, SX14Q004 colour STN LCD (8-bit colour mode) to the 79520 starter kit but with only partial success. The LCD appears to be semi-working, ie, it can flood filled with various colours but the positional accuracy of individual pixels is not quite right. Looking at the signals, specifically, Frame, Load and CP, reveals their quality to be very poor - approx 25 noise with the CP signal being particularly bad. Could this effect the positional ac...
2 1098
by  Deleted UserJump to last post
29 Apr 2005 10:30 AM
6 Replies and 1315 Views How can I escape the boot-time script using LOLO?  1315  6 Started by  Anonymous Note: Refer to the LogicLoader User's Manual, chapter 6, 'Boot-time Scripts' for more information about the following subject. Question: How can escape the executing of this script using LOLO, it seems if I put this contents in eeprom, there is no way I can go to LOLO prompt. Answer: There are two ways to get to the LoLo prompt. The first solution is to hold the 'q' key down and bring the kit up in BoLo. The serial_eeprom script you wrote for LoLo to jump to your application can be overwritt...
6 1315
by  Jump to last post
21 Apr 2005 09:43 AM
4 Replies and 1214 Views LCD problem  1214  4 Started by  tozyagcilar I am using the Logic Loader's losh prompt. I type the command 'funtest' and choose the DISP_LQ035Q7DB02 (which is the LCD I have). Only half of the square seems to be drawn properly. The botton half of the screen has horizantal strobing lines. The jumper settings on the LCD are as follows: - SPR is at - HORZ is at - VERT is at - I think this is a hardware issue, but maybe not. Did anybody come across this If this is a defect, what is the fastest way of replacing the part. Filling o...
4 1214
by  bruno.pillet@arturia.comJump to last post
20 Apr 2005 09:31 AM
5 Replies and 1246 Views /dev/pwm0 error, LCD-6.4-VGA-10  1246  5 Started by  simon Hi guys, I've got a LH79520-10 SDK and the LCD-6.4-VGA-10 Display Kit. I've followed the directions given by the pdf's and am also using the patches as suggested by JadePheonix. I have also changed the kernel-config file to indicate that my display is the 6.4' by doing this: CONFIG_PL110_LQ39=y - original setting CONFIG_PL110_LQ64=y I've added in a file /etc/pointercal as i was getting an error trying to open it. I can tftp and nfs root with no probs, though i do get a modprobe: modprobe:...
5 1246
by  tozyagcilarJump to last post
08 Apr 2005 09:04 AM
2 Replies and 1132 Views CF Card Issue  1132  2 Started by  simon Hi All, I know there are a few CF card posts, but my problem is slighty different. I have followed the app note and can successfully load VMLINUX and exec root=/dev/hda1 with no worries. This is the kernel that I am running with: Linux version 2.4.17-rmk2-lineo5 The system boots up, and all looks ok until BusyBox loads. Here is what I am getting after booting: ---------------------------------- init started: BusyBox v0.52 (2004.07.23-06:320000) multi-call binary *** Running rc.modules *** ...
2 1132
by  simonJump to last post
06 Apr 2005 04:42 PM
7 Replies and 1487 Views problem with console device (symbolic link missing?)  1487  7 Started by  JadePhoenix Greetings! i've just started with LH79520 eval board and managed to build a kerneluserland using Lineo BDKlogic pd build scripts. Host: Fedora 2 Core (2.6.x Linux) Running TFTP and NFS server I downloaded the vmlinux image using TFTP and NFS and start it. It mounts NFS root system but then fails: Quote: losh> load elf /tftp/198.120.75.6:/vmlinux loading from /tftp/198.120.75.6:/vmlinux: F..... elf file type : 0x0002 machine type: 0028 version: 1 prog start addr : 0x40100000 num prog he...
7 1487
by  tozyagcilarJump to last post
05 Apr 2005 11:37 AM
1 Replies and 1183 Views Where is timer tick value located in LOLO?  1183  1 Started by  david.clarke I am using the 79520 SDK without an operating system and have a need for a timer tick. I notice that LOLO seems to use Time0 for a 1MS timer tick interrupt, which is exactly what I need. So rather than setting up my own timer-tick interrupt, I thought I would just read the tick value already kept by LOLO. Can someone tell me where the timer tick value that LOLO keeps is stored, and what size it is
1 1183
by  Jump to last post
04 Apr 2005 11:44 AM
You are not authorized to create a new topic
Page 2 of 6 << < 12345 > >>


RSS Feed Available