Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 1 of 612345 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 2952 Views Port A GPIO and SSP  2952  1 Started by  Deleted User Hi, I am working on a SSP driver for the LH79520. According to NXP's documentation on the CPU, there is a pin called PA0/SSPEN that is available to the user. Unfortunately I cannot find any references to this pin whatsoever in Logic's documentation. Is this pin not routed to the card engine outputs or am I missing something
1 2952
by  Deleted UserJump to last post
25 Apr 2008 01:06 PM
1 Replies and 1855 Views How to connect 39vf160 to lh79520?  1855  1 Started by  Deleted User Hello, all Did anybody have the experience that connect the nor flash 39vf160 to lh79520,my board can not work when use 39vf160; I want to know whether is right: 39vf160 lh79520 A0 ADDR1 ..... A19 ADDR20 DQ0 D0 .... DQ15 D15 CE NCS0 NOE NOE NWE NWE NRESET NRESET RY/BY (NC) NBYTE (3.3V) then how to config the SMC register THANKS A LOT!
1 1855
by  Jump to last post
21 Aug 2006 10:02 AM
3 Replies and 1847 Views Unable to restore BOLO/LOLO using IAR & JTAG  1847  3 Started by  Deleted User Hi all, I am new to 79520SDK and trying to recover BOLO/LOLO. I erased block zero of flash accidentally and now I can recover neither bolo nor lolo. I have IAR development kit and J-link(JTAG) in my hand but I cannot download and run any code to the board. I tried programming flash and SDRAM but none of them seems to be responding. When I tried to write to the flash it gives "memory timed out error". I download to SDRAM but nothing appears to be coming. I thought that SDRAM should...
3 1847
by  Jump to last post
17 Jul 2006 04:40 PM
1 Replies and 1834 Views Need help with CF Drivers  1834  1 Started by  ryu2112 Hello, I am using the CF drivers from the bsps package (lh79520_sdk_cf_driver.c) provided by sharp and I am having a lot of trouble. What I am trying to do is read data from the compact flash card given a sector. (as told by the bsps code). this is what i have: RAM_STAT is linked to the SDRAM on my Logic Board. (i am only writing 16 bytes for testing purposes). typedef struct { UNS_16 data1; UNS_16 data2; UNS_16 data3; UNS_16 data4; UNS_16 data5; UNS_16 data6; UNS_16 data7; UNS_1...
1 1834
by  Jump to last post
21 Apr 2006 02:28 PM
4 Replies and 1829 Views Using BITMAP command with Custom Display  1829  4 Started by  NetHog I'm testing the SDK-LH79520-10 with an LQ043T3DX02 (4.3" 480x272) Sharp display. I would like to use the 'bitmap' command to display images on the screen. I need to find the register settings for this display. I found a FAQ about customizing the registers for several displays with a PXA270-10 card ( http://www.logicpd.com/support/faq/faq.phpfaq_id=139 ). If I'm understanding this right, I need to set the correct register addresses with the correct values using the 'w' command. What w...
4 1829
by  NetHogJump to last post
20 Apr 2006 01:26 PM
1 Replies and 1961 Views Using the 'w' and 'x' commands in Logic Loader  1961  1 Started by  ryu2112 I am trying to write values in the memory space for the SDRAM. When I read I type the command: "x 0x200c000" and it shows values in four columns 0x200c000 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF 0x200c010 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF when I write using "w 0x200c000 0x00" 0x200c000 00000000 FFFFFFFF FFFFFFFF FFFFFFFF 0x200c010 FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF How do I write values to the 2nd, 3rd, and 4th columns such as: 0x200c000 00000000 00000000 00000000...
1 1961
by  ryu2112Jump to last post
23 Mar 2006 06:45 AM
1 Replies and 1814 Views CF to LCD Display Problems  1814  1 Started by  tnakonsut38 I am using logic loader to display bitmaps from the compact flash port. All the initial tests, such as, draw-flag, and draw-test have been working. After mounting my compact flash card and then entering the command "bitmap /cf/test1.bmp 0,0 640,480 5" the LCD does not display the image. I am using a 128 mb viking compact flash card. Any help
1 1814
by  Jump to last post
21 Mar 2006 10:58 AM
2 Replies and 1691 Views SOLVED: get Embedix BDK to work on newer Linux Distributions  1691  2 Started by  JadePhoenix Hello again, i finally got the Embedix BDK to work on newer linux distributions. These instructions apply for 'Fedora Core 2' but might work for others. As i mentioned in another thread, the main problem is that some commandline tools in the supplied chrooted chain are not large filesystem aware. This results in some spawned makes to exit prematurely or return incorrect results (like the MAKEDEV package). Following steps to fix this. I had to reinstall the BDK because i couldnt get some pack...
2 1691
by  peter_vcJump to last post
03 Mar 2006 08:40 PM
4 Replies and 1931 Views fseek error message from Lolo  1931  4 Started by  WildWilly Hello, I have a SDK-LH79520 board that I am tyring to get Linux up and running on (using Sharp's BSP package 1.2.9). I am following the quick start guide and every think works up until the point where I try to use Lolo to load their APEX bootloader. I get the following error message: <start Tera Term copy and paste> losh> mount fatfs /cf losh> ls D : cf 0 D : tftp 0 D : dev 0 losh> cd ...
4 1931
by  Jump to last post
06 Feb 2006 11:57 AM
7 Replies and 1720 Views Problem connecting with IAR Jlink probe  1720  7 Started by  Nick Bodis I'm evaluating the IAR Workbench IDE with Jlink (JTAG) probe for the LH79520. I'm using windows XP. I'am unable to connect to the target. Error dialogs indicate the JTAG probe is unable to correctly communicate with the ARM core. I've tried various target connections from the IAR options dialog without success.
7 1720
by  Jump to last post
26 Jan 2006 11:05 AM
2 Replies and 1470 Views Zoom LH79520 with IAR EWARM evironment under Windows  1470  2 Started by  Patrick Perdu Hi all, I am a new user of the LH79520 SDK and I use the IAR EWARM environment. I am currently trying to define the proper 'xlink' linker configuration file (.xcl) thance thanksat will properly define the memory mapping for the Zoom SDK. Then I tought maybe somebody here already has been using the same developmet environment and already has such a file. If such is the case, that would be really nice to share it with me and everyone. In advance thanks
2 1470
by  mbashiriJump to last post
26 Jan 2006 08:17 AM
5 Replies and 1708 Views LCD Questions  1708  5 Started by  totalslacker Hello, I'm trying to get a STN 320 x 240 4bpp display working and the lcd controller seems to be hating me. It looks like the pl110fb.c driver is really only set up for color TFT panels, so I'm sure that's the source of my problems. I have been going through what the driver is setting the lcd registers to and either making changes to the panel's lh_info struct or, in some case, modifying code to get it to do what looks to be the right thing (in cases where the code only supports tft panels). ...
5 1708
by  bethelJump to last post
19 Jan 2006 10:46 PM
1 Replies and 1830 Views Schematic in PowerPCB, CorelDraw format  1830  1 Started by  jlam Could I have the schematic in PowerPCB, CorelDraw format in the download section Thanks.
1 1830
by  Jump to last post
13 Jan 2006 11:47 AM
4 Replies and 1569 Views Network Working ?  1569  4 Started by  Deleted User HI, I am trying to get the networking set up on the Zoom Cardengine. I ran the system test which prompted me to enter the last 3 digits of the MAC address. I can do an ifconfig on sm0 but the system does not seem to bring up the interface properly. I see no 10/100 link lights on the hub and I get a 'Partition ' light on my SMC Hub. Cables etc are all fine. best regards Phil WIlshire
4 1569
by  Deleted UserJump to last post
10 Jan 2006 09:44 AM
1 Replies and 2085 Views IAR compiler: burning images into flash  2085  1 Started by  dcostant I've compiled a small program with the IAR Embedded Workbench compiler. I can build and load it into RAM using LogicLoader. The problem occurs when I try to build and load it into flash. The environment came with a linker file named lh79520_lnk_flash.xcl I attempt to load the generated srec file and I get the following: losh> load srec loading from stdin: download of 'F08_1' complete: bytes: 535979179 records: 5711 start: 201f0000 extent: 0x201f0000-0x1ff264ab ignoring rest of...
1 2085
by  Jump to last post
20 Dec 2005 01:57 PM
2 Replies and 1594 Views Confused about on board flash booting?  1594  2 Started by  Deleted User Hello, all I have added jffs2 support and also mtd support to the kernel, and rebuilder kernel, but it seemed not any change when boot on target. (my platform is LH79520-10 with 8M Strataflash and 2.4.17-rmk2-lineo5) So I added to 'linux/arch/arm/config.in' direct CONFIG_MTD=y CONFIG_MTD_PARTITIONS=y CONFIG_MTD_CHAR=y CONFIG_MTD_BLOCK=y CONFIG_MTD_CFI=y CONFIG_MTD_CFI_INTELEXT=y rebuild kernel and download On the target, 'cat /proc/device' I can find devices 90 mtd 31 mtdblock but 'cat /pr...
2 1594
by  Deleted UserJump to last post
04 Dec 2005 11:28 PM
2 Replies and 1540 Views Flash Chip  1540  2 Started by  miguelgu Hi LPD, I need a bit information about the flash chip used by you in LH79520 Card Engine. I'm trying to use jffs2 and I need to know which driver (if already done) is available. Anyone tried to use jffs2 before in this hardware Any help will be welcome, thanks in advanced.
2 1540
by  miguelguJump to last post
25 Nov 2005 01:01 AM
3 Replies and 4366 Views Exclusive chip select signal for user memory mapped devices  4366  3 Started by  Deleted User Hi everyone, I am facing the problem to attach a memory mapped device our company developed to the Sharp Zoom SDK evaluation board. I got two different card engines (LH79520 and LH79524) and the board. Since I need an exclusive chip select signal and there is an open memory block that is free for utilization by the user I am wondering if there is a cs signal that comes out of the CPLD when I access these addresses (referenced to in the io controller spec). That is 0x5700 0000 – 0x57FF FFF...
3 4366
by  Deleted UserJump to last post
27 Oct 2005 10:33 AM
7 Replies and 2055 Views How to compile and link a ".c" program??  2055  7 Started by  Deleted User I am just get LH79520 and I have run the Embedix linux Now I compile my program in redhat linux, and I have unzip gnuarm_linux.tar.gz to redhat linux But I don't know how to use gnuarm_linux tools, and how to compile and link my program runing in Embedix linux Please give me a sample or tell me where can I get the referrence Thanks
7 2055
by  Deleted UserJump to last post
27 Oct 2005 07:49 AM
3 Replies and 1752 Views help:Unable to mount root fs???  1752  3 Started by  Deleted User Who can give me a favor 'root=nfs' is wrong losh> load elf tftp/192.168.1.18:/vmlinux loading from /tftp/192.168.1.18:/vmlinux: R........... elf file type : 0x0002 machine type: 0028 version: 1 prog start addr : 0x200c8000 num prog headers: 1 num sect headers: 10 offset : 0x00008000 disk length: 0x00157c73 mem len: 0x0017f39c phyaddr: 0x200c8000 vaddr : 0x200c8000 dl addr: 0x200c8000 losh> exec ip=dhcp root=nfs kernel cmdline: 'ip=dhcp root...
3 1752
by  Deleted UserJump to last post
25 Oct 2005 01:51 AM
You are not authorized to create a new topic
Page 1 of 612345 > >>


RSS Feed Available