Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 5 of 6 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
2 Replies and 1189 Views how to use nPCWAIT signal?  1189  2 Started by  yuanfei I am wondering what is the purpose nPCWAIT signal. I did not see any hardware signal generation depends on this signal. according to Application notes 'Interfacing Static memory controller with IO devices' . Seems the wait state generation is also not depends on it, instead just counting clock. So how this pin is used exactly. Does any where get soem concrete documents or timing diagram for this Thanks
2 1189
by  yuanfeiJump to last post
02 May 2005 07:41 PM
2 Replies and 1158 Views Can Sharp LH7A404's SMC Directly interface a Flash module?  1158  2 Started by  yuanfei Can Sharp LH7A404 's SMC directly inteface with a flash module say Micron's Q-Flash series. with out help from CPLD and any additional extern timing circuit Thanks
2 1158
by  yuanfeiJump to last post
02 May 2005 07:39 PM
8 Replies and 1162 Views ActiveSync problem  1162  8 Started by  Deleted User I am using ActiveSync 3.8 with no problem with my A400 platform under CE4.2 but I can not get a connection with my A404 under CE5.0 no matter what I include in the image, anyone have a clue
8 1162
by  Jump to last post
26 Apr 2005 03:10 PM
1 Replies and 1223 Views Flash File System Driver - msflashfmd  1223  1 Started by  Deleted User I'm wondering if there is any documentation available for this driver I'm looking for the API it supports. Thanks for any help you can give me. -Sharon
1 1223
by  Deleted UserJump to last post
18 Apr 2005 07:01 PM
1 Replies and 1191 Views Replacing program in flash  1191  1 Started by  caande I need to replace the program loaded in the flash of the card with my own. I then need to debug this program with my Lauterbach Trace32. When I try to program the flash with the Lauterbach the program returns a flash erase or program error. I then checked the VPEN pin on the flash and found out that this pin is controlled by the cpld. During my tries to program and erase this pin stays low. This mean that the flash cannot be programmed. Does anyone know of a way to control this pin
1 1191
by  Jump to last post
18 Apr 2005 04:35 PM
1 Replies and 1172 Views Where to get CPLD code.  1172  1 Started by  yuanfei I am using Logic PD LPD7a404 Card Engine. I need the source code of the cpld, in order to route my own board. Where Can I get the CPLD source code. What the CPLD used for Thanks.
1 1172
by  Jump to last post
15 Apr 2005 01:04 PM
2 Replies and 1158 Views Small and simple OS  1158  2 Started by  Gadeberg Hi, Does anybody know of a simple and straight forward (and if possible free) OS for the LH7a404 I just need something to take care of a few processes and interrupts - there is a lot of talk about WinCE in these groups, but that’s way to advanced for me (I think) If somebody could point me in the right direction, it would be greatly appreciated... Thanks in advance, Jesper
2 1158
by  Jump to last post
01 Apr 2005 11:20 AM
6 Replies and 1326 Views WinCE BSP framebuffer & on-chip 80KB SRAM  1326  6 Started by  noonan The WinCE 4.2 BSP indicates that the on-chip SRAM can be used as part of the framebuffer. I found this in the SetVisibleSurface() function in the PLATFORM\SDKLH7A404\DRIVERS\SOCLCD\soclcd.cpp file. Both the LCDUpBase and LCDOverflw registers are set here. Looks like it would require some code changes to make this work properly, plus some changes to MMU setup to make the internal SRAM/SDRAM combination look like one chunk of memory to the ARM processor. Is my guess about MMU setup correct If s...
6 1326
by  noonanJump to last post
30 Mar 2005 10:16 AM
13 Replies and 1280 Views Running CE Sample Development Images with other displays  1280  13 Started by  noshtims Hello, is it possible to load the sample development images on my platform using a display other then the display kits I have a 1024x768 TFT 16BPP DCLK=50 to 60MHz. I am able to get the display to work from LOLO by setting the display driver parameters accordingly. It is not clear to me, however, about how this is done for the demo images. Can this be done using a boot script If so can you provide some details on how this might be done Thanks, -Bill
13 1280
by  noshtimsJump to last post
23 Mar 2005 07:06 AM
2 Replies and 1117 Views Touch Screen going wonky  1117  2 Started by  abailie I have been working with the WinCE 5.0 image for about a week now and haven't manged to get my touch screen to work properly yet. It works fine under LoLo - I can calibrate it, draw pretty pictures and all the usual nonesense, but under CE it's got a mind of its own. It took me ten or fifteen attempts to get the device calibrated, as the screen stopped responding at different points through the process. Now that I have it calibrated it works quite well (sometimes gets the co-ordinates wrong) f...
2 1117
by  abailieJump to last post
18 Mar 2005 01:56 AM
1 Replies and 1219 Views WinCE 5.0 Platform Builder OS maximum size?  1219  1 Started by  Deleted User I am trying to get an OS image with Internet Client, (Internet Explorer 6.0 for Windows CE) along with a wired LAN connection. This is to show using the development kit as an Internet Appliance connected to a simple embedded web server via the ethernet port. I get &91color=red:3qm45svw&93Error: Ram start overlaps rom binary, showing total ROM size as 18,169,50 bytes. I am assuming that the maximum is 16Kbytes, based on the FLASH or the RAM size I have a 32 Mbyte Compact Flash card if that...
1 1219
by  Jump to last post
17 Mar 2005 09:16 AM
4 Replies and 1185 Views Loading from Compact Flash  1185  4 Started by  abailie I have been working with the Zoom SDK for about a week now and I've not yet managed to run a Win CE image from CF. I have followed the steps outlined in the SDK eval guide but so far without success. The image loads and the checksums are verified but when I issue the execute command there not much response from the device. Here is a list of the debug serial data that comes back from the device: losh> exec rtc:rtc_a404_int:dbg_serial:A404_UART:disp_num:60000007..... ...
4 1185
by  Jump to last post
10 Mar 2005 10:26 AM
2 Replies and 1212 Views TX14D11VM1 Hitachi Display  1212  2 Started by  patrick.louis@trump.be I'am trying to use a TX14D11VM1 TFT display from Hitachi with a LH7A404-10 Zoom SDK. This display is supported by the last version of lolo and I open it with the command video-open 14 16. I have connected the Dclk and Mdisp signal from the sdk to the Dclk and Dtmg signal of the display (and of course the datas). I also verified all the timing with a digital scope and everything is perfect. Unfortunately this doesnt work, there is a timing problem and a grey line is moving from bottom to top ...
2 1212
by  patrick.louis@trump.beJump to last post
03 Mar 2005 10:31 AM
2 Replies and 1171 Views Can't find Binary BSP Display Reg Keys in Platform Builder  1171  2 Started by  noshtims Hi All, I recently set up the Binary BSP in Platform Builder in preparation to build an Image. In order for the image to support my display I need to modify the registry accordingly. I had done this previously using the LPD sample image and the remote registry editor but I now would like to include the keys in the platform. I checked common.reg, platform.reg and project.reg but found nothing that looked similar to what I was expecting. Do I need to manualy add these keys somwhere or have I faile...
2 1171
by  noshtimsJump to last post
03 Mar 2005 10:17 AM
1 Replies and 1179 Views Including IESIMPLE.exe in the OS Image  1179  1 Started by  noshtims Hi All, Has anyone had any luck including the IESIMPLE application in their image as opposed to the IESAMPLE I saw some info on MSDN regarding some Sysgen commands; set __SYSGEN_IESIMPLE=1 set SYSGEN_IESAMPLE= <no value> It is not clear to me where I should be setting this. Should this be done in the cesysgen.bat within my workspace root directory Any help would be apreciated. Thanks, - Bill
1 1179
by  noshtimsJump to last post
19 Feb 2005 11:15 PM
5 Replies and 1184 Views error when running cross-compiled program in linux  1184  5 Started by  osto_82@hotmail.com Hello, I have Linux on my LH7A404 board. I made c-program that controls board's leds. Then i Cross-compiled program without errors and warnings. Then i ran it on my LH7A404 and get following message: ./prog pc : &91<000083d0>&93 lr : &91<400756f4>&93 Not tainted sp : bffffe54 ip : 00000000 fp : bffffe60 r10: 40135198 r9 : 000083a0 r8 : 00000001 r7 : 40021ae4 r6 : 0000825c r5 : bffffe84 r4 : 000007c8 r3 : 04331d80 r2 : 04331d80 r1 : 04331d80 r0 : 0000000d Fla...
5 1184
by  osto_82@hotmail.comJump to last post
27 Jan 2005 09:53 AM
3 Replies and 1209 Views Problems Establishing ActiveSync connection?  1209  3 Started by  noshtims Hi All, When attempting step: 6 in the, Zoom Starter Development Kit Windows CE Evaluation Guide, I get the following error message; Quote:Unable to Connect The Microsoft ActiveSync Reported the following error: Unable to establish a connection with the device. Please check server configuration settings. I noticed that my development board has C72 installed, with respect to the USB reset problem documented on the Logic website. Is this known to cause this type of problem What are the server...
3 1209
by  Jump to last post
25 Jan 2005 12:42 PM
2 Replies and 1177 Views LCD Timing Adjustment in WinCE  1177  2 Started by  scottl Any idea how I can adjust the timing parameters of the default LCD when I build the Wince 4.2 binary I see on the x400 board, from the app notes, you can do this through registry settings. But I dont see any equivalent registry entries in this BSP. Thanks!
2 1177
by  Jump to last post
18 Jan 2005 04:24 PM
3 Replies and 1268 Views Application with WinCE 5.0 Sample Development Image?  1268  3 Started by  ggirzon Is there a way to download (eg., using Activesync) and run an actual application on the pre-built WinCE 5.0 Sample Development Image I have been able to load NK.BIN from CF card and get a WinCE startup window. Should Activesync run using the Client USB port (Does not on my host). I am looking for a way using EVC but will consider Platform Builder. Thanks, Gary
3 1268
by  Jump to last post
18 Jan 2005 04:16 PM
1 Replies and 1131 Views Updated patches for linux-2.6.10 & New APEX Bootloader  1131  1 Started by  Deleted User I've updated the linux patches to support linux-2.6.10. At this point, the only pieces not in the kernel are the IDE driver and an MTD/maps driver (which isn't really necessary). There is also a new bootloader, APEX. I wrote it to superceed BLOB since BLOB is so difficult to build and modify. <http://projects.buici.com/arm/lpd7a40x> Cheers.
1 1131
by  Jump to last post
14 Jan 2005 08:06 AM
You are not authorized to create a new topic
Page 5 of 6 << < 23456 > >>


RSS Feed Available