Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 4 of 12 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
2 Replies and 1263 Views GetSystemTime RTC  1263  2 Started by  Deleted User Hi guys, I have a customer who has built his own CE 4.2 image and is not seeing his CE system time increment. GetSystemTime() consistently returns a time with 0 for minute, seconds, and milliseconds. My best guess is that the RTC is not being initialized (via IOCTL_HAL_INIT_RTC kernel IOCTL on cold boot) The platform this customer built was described to me as 'stripped down' (unfortunately I'm about 3 degrees of separation from those who created the platform so don't have a lot of details ye...
2 1263
by  Deleted UserJump to last post
03 Mar 2005 10:06 AM
8 Replies and 1304 Views Question about SDRAM initialization  1304  8 Started by  Deleted User Hi all, In my previous post, I reported that blob could not initialize the SDRAM correctly. And later on , Marc Singer released a new boot loader (thanks!) I did tried it on my board again. Unfortunately , it fall into the same problem. After read the code of bs_7400_dbg.elf, I tried to merge them and finally get apex work on my LPD7A400. By the method of try and error, I found a interesting behaviour. If I disable the write to PCMCIACON (0x3. PC Card 1 and 2 Enable), bs_7400_dbg...
8 1304
by  Deleted UserJump to last post
23 Feb 2005 09:18 PM
1 Replies and 1291 Views Regarding LEDs in SDK LH7A400  1291  1 Started by  snair Hi, I was trying to Turn ON the GPIO and Status2 LEDs by using the following code in C file (This code is used as a part of the intialization code) cpld_enable_led&40;LED_GPIO, 1&41;; cpld_enable_led&40;LED_STATUS1, 0&41;; cpld_enable_led&40;LED_STATUS2, 1&41;; But when I execute it, after loading the whole program in the flash, all the 3 LEDs gets turned ON. I tried using the same code with the LEDs in state 0 (OFF), but even then it gets turned ON. Of course, when I comment off the ...
1 1291
by  snairJump to last post
19 Feb 2005 11:28 PM
2 Replies and 1289 Views SDK-LH7A400 BSP from Sharp  1289  2 Started by  snair Hi, I am trying to use the startup code available in the SDK-LH7A400 BSP in the sharp website with IAR as the compiler. Since the code supplied by Sharp isnt for IAR tool chain, I am wondering if anyone has made it to work with the kit. If so, could I please know what are the changes that need to be put in to accomodate the code in IAR. Thanks, Sajiv
2 1289
by  snairJump to last post
18 Feb 2005 12:15 PM
1 Replies and 1193 Views RELOCATE_FROM_FLASH does not work for WinCE 5.0 builds  1193  1 Started by  cdwhatley In WinCE 4.2, LPD had a special environment variable called RELOCATE_FROM_FLASH that you could use to create an image that could be burned to FLASH, but would be relocated to RAM upon boot. I tried using this env var in a WinCE 5.0 build which incorporates the LPD BSP and Kernel. When I download the build via Platform Builder to the card engine, an 'R' appears instead of an 'F' at the start of the download in LoLo. This indicates that the build is a RAM build. In WinCE 4.2, if RELOCTATE_FROM...
1 1193
by  Jump to last post
18 Feb 2005 10:56 AM
11 Replies and 1225 Views Accesssing 64M SDRAM  1225  11 Started by  colin howard Hi I am trying to get access to the full 64M SDRAM on the SDK and I am having a little trouble. In my application the data from 0xC0000000..0xC1FFFFFF appears to be repeated at 0xC2000000..0xC3FFFFFF. From the losh prompt I can write to 0xC2000000 using the w command and read back the correct data using the x command. I can also verify that the data at 0xC0000000 has not changed. If I load the mini application shown: *&40;UNS_8 *&41;&40;0xC0000000L&41; = '1'; *&40;UNS_8 *&41...
11 1225
by  colin howardJump to last post
03 Feb 2005 09:14 AM
5 Replies and 1312 Views LH7A400 details - EEPROM  1312  5 Started by  snair Could I please know: -What is the importance of the serial EEPROM and where it is located in the overall memory map -If I write my own boot loader program, would I have to specifically change anything in regard with the EEPROM -I have my own program which does some command operations like read and write to memory location in the SRAM. Now if I want to load my program after the BoLo has initialized all the settings, what would be the procedure to do so Thanks. Regards, -Sajiv
5 1312
by  snairJump to last post
02 Feb 2005 08:11 AM
1 Replies and 2945 Views Error: IAR - ARM linker symbols  2945  1 Started by  snair Hi, I am trying to compile a startup code. I get an error in one of the include files that has the following code: /* ARM linker symbols */ extern UNS_32 Image$$ER_RO$$Base; extern UNS_32 Image$$ER_RO$$Length; extern UNS_32 Load$$ER_RO$$Base; extern UNS_32 Image$$ER_RW$$Base; extern UNS_32 Image$$ER_RW$$Length; extern UNS_32 Load$$ER_RW$$Base; extern UNS_32 Image$$ER_ZI$$ZI$$Base; extern UNS_32 Image$$ER_ZI$$ZI$$Length; I am using IAR for compling and linking...This is the error that I get E...
1 2945
by  snairJump to last post
31 Jan 2005 03:01 PM
1 Replies and 1196 Views Problem w/ VS.NET to WinCE 5.0 LPD connection via ActiveSync  1196  1 Started by  cdwhatley I was able to connect to a WinCE 4.2 image running on the LPD7A400 from Visual Studio .NET 2003 over ActiveSync (AS 3.7.1). However, I am not able to establish a connection to the target when using WinCE 5.0. I have built in all the necessary components for ActiveSync over USB into my image: - ActiveSync - Network User Interface - Telephone API - Dial-Up Support (w/ Unimodem) - USB Function for Serial Device - LPD USB Function Driver I can get an ActiveSync connection with my WinCE 5.0 image...
1 1196
by  cdwhatleyJump to last post
27 Jan 2005 02:37 PM
14 Replies and 1272 Views Problem with LoLo  1272  14 Started by  snair Hello, I am working SDK-LH7A400-10 kit. I also use a JTAG debugger from Signum, JTAG jet USB 2.0. I have a strange problem; when I reset the board with power or by reset button, the 3 LEDs on the board keep flashing fast. And the board seems to go to a state that it isnt able to load the LoLo not able to communicate to the board. But interestingly, when I run IAR in debug session with a simple code and simultaneously open the terminal window, the LoLo loads up. I am not sure what the problem...
14 1272
by  snairJump to last post
27 Jan 2005 10:21 AM
20 Replies and 2178 Views Foo Driver using the Timerx interrupts  2178  20 Started by  lucb
(Topic has multiple pages1 2 )
I am starting to modify the foo driver to work with the board timer interrupts rather than the GPIOs. Is there any issue with that Is the windows multimedia timer (1ms) already using one of those timers It seems that I need to change the interrupt from 0x05 (GPIO) to 0x08 (timer1). Anything else obvious I noticed that my kernel is version a400_50_2_1_2_0 but the Sample dev image is using a400_50_2_1_3_0. It would be nice to be able to get some more details on how the sample dev image was bu...
20 2178
by  lucbJump to last post
21 Jan 2005 06:55 AM
5 Replies and 1252 Views Execution speed on the SDK  1252  5 Started by  colin howard Hi I am trying to get a handle on execution speed on my SDK. I have written some extremely simple code to toggle a port: while &40;1&41; &123; GPIO->pedr ^= 0x03; &125; This is done with interrupts off and is running from external RAM (0xc00c0000 ...) after being loaded in via LOLO. The info from LOSH is sect c0000000 -> c0000000 WBC dom&58;4 Which I think tells me that cache is enabled for this range. The execution time of one pass of ...
5 1252
by  colin howardJump to last post
20 Jan 2005 07:20 PM
9 Replies and 1235 Views use of remap in Lolo API  1235  9 Started by  lucb I am trying to validate the MMU for the locations from 0x63000000 for a length of 0x200000 (2MB) It works when I type losh>remap 0x63000000 0x63000000 0x200000 but I am trying to put this into my code using the Lolo API. The remap call is not too well documented. I am trying to figure what values to use for the last parameter: void cpu_remap ( u_int paddr, u_int vaddr, u_int len, u_int prot ) The cpu_remap() function remaps physical addresses to virtual ...
9 1235
by  lucbJump to last post
20 Jan 2005 01:09 PM
14 Replies and 1259 Views Debugger Swap Error  1259  14 Started by  dchermak I am using the new LPD_ARMV4_SDK_002 and I am getting the Debugger Swap Error dialog when I try to debug an application. I didn't get this with the previous SDK. Did someone forget to do the 'ARMV4 mojo' when this new SDK was built Thanks, Dale
14 1259
by  Jump to last post
18 Jan 2005 04:52 PM
13 Replies and 2310 Views pcmcia ref design  2310  13 Started by  Deleted User It looks like the OE and LE should be switched on U28. PCMCIA Control Register.
13 2310
by  Terry FowlerJump to last post
17 Jan 2005 04:55 PM
5 Replies and 1152 Views Boot Problem  1152  5 Started by  AcceliTom I have successfully built my image for the LH7A404-11-504HC card engine. When I attach to the device via Platform Builder 5.0 and download the image all appears fine except after successfully loading the image I execute the following command from the boot loader : exec dbg_serial:A404_UART:dbg_enet:91C111:dbg_enet_bas e:0x70000000::share_eth:1:disp_num:6 The screen appears to initialize but nothing is shown, status LED0 remains on and status LED1 is glowing slightly with what appears to be a ...
5 1152
by  Jump to last post
14 Jan 2005 10:54 AM
1 Replies and 1147 Views Updated patches for linux-2.6.10 & New APEX Bootloader  1147  1 Started by  Deleted User I've updated the linux patches to support linux 2.6.10. At this point, the only things not in the kernel are the IDE driver and an MTD/maps driver (which isn't really necessary). There is also a new bootloader available, APEX. I wrote it because BLOB is difficult to build and modify. <http://projects.buici.com/arm/lpd7a40x> Cheers.
1 1147
by  Jump to last post
14 Jan 2005 08:06 AM
3 Replies and 1234 Views LH7A400 from logicPD fat and ext2 problem--update info  1234  3 Started by  testingmoore Dear people, we have the above stated evaluation board. however we have had zero luck getting it to run linux, NEW INFO: the installer for linux does correctly place the installed image onto the card, however the cf card is now formated in ext2. the eval board only supports fat file system, it refuces to mount anything except the fat file system. does anyone know of a method out of this without having to re-flash the whole of the existing operating system so it recognises ext2 the loader i...
3 1234
by  Jump to last post
11 Jan 2005 04:13 PM
1 Replies and 1123 Views Question about USB host function with LH7A400-10 SDK  1123  1 Started by  Deleted User Hello all, Can the LH7A400-10 card engine support USB hosting I want to connect a 128MB/256MB USB memory stick to the SDK board. The SDK board has both a USB-A connector and a USB-B connector. However I notice from the data sheet, that the LH7A400 sharp uP has only the USB slave side. While the LH7A404 uP has both. Any help on this would be cool. EZ
1 1123
by  Deleted UserJump to last post
31 Dec 2004 10:00 AM
2 Replies and 1234 Views JTAG: CPLD goes braindead?  1234  2 Started by  Deleted User I seem to be seeing a situation in which you attach a JTAG to control the ARM CPU and somehow the CPLD becomes dysfunctional. The problem shows up about 90 of the time when using JTAG to connect to the LH7A400-10 board. The CPLD refused to respond to external logic events, it is dead. Looking at the schematic, the JTAG pins to the CPLD are connected to the host CPU via the U19 buffer. Are you using the JTAG in lolo to communicate periodically with the CPLD Is that why the CPLD goes inert ...
2 1234
by  Deleted UserJump to last post
21 Dec 2004 12:44 PM
You are not authorized to create a new topic
Page 4 of 12 << < 23456 > >>


RSS Feed Available