Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 7 of 8 << < 45678 > >>
Topics
 Replies
 Views
 Last Post
2 Replies and 1328 Views Coldfire P&E low-voltage parallel port BDM  1328  2 Started by  macfarlk@faro.com Is anybody else having trouble getting the P&E parallel port BDM that came with the ColdFire M5475EVB kit to work I’m trying to get it to work with the copy of Metrowerks CodeWarrior that was included. The IDE seems to recognize that the BDM is there and it attempts to interact with the processor, but it is intermittent at best. In the hardware diagnostics I can sometimes write and then read a byte from memory, but trying to load programs or anything else ends with complete failure. I m...
2 1328
by  Jump to last post
06 Jun 2005 04:53 PM
1 Replies and 1371 Views new version evb's boot  1371  1 Started by  liuyoulin@mindray.com.cn I had a M5475evb board ,rev b, with Motorola Dbug as the bootloader last night, I reflashed the bootflash without storing the original one Later, I used an old version, 3b.1a.1b instead, but did not work There was a source copy which had the version 4a.1b.1c on freescale's web, also did the same result Where could I find a workful Dbug boot Thanks!
1 1371
by  Jump to last post
26 May 2005 09:03 AM
2 Replies and 1361 Views Programming the boot flash on M5475CFE Rev B board  1361  2 Started by  jwang@oyogeospace.com Last month I got M5475CFE replacement board, Rev B (replacing my old board, Rev 305). It came with dBUG v4a.1a.1d (Dec 6 2004 build) installed and seemed working fine. Recently I tried to reprogram the boot flash (for practice of my own dBUG, but tried Freescale's dBUG first), but it did not work. I used M54X5EVB updater. It seemed going through ok but, after rebooting, the dBUG v4a.1a.1d was still there. Since M54X5EVB updater does not have 'verify' capability, I then used Freescale's CF F...
2 1361
by  jwang@oyogeospace.comJump to last post
19 May 2005 06:54 PM
2 Replies and 1385 Views How to add application in image.bin  1385  2 Started by  fakharmtc@yahoo.com Hi, I am using mcf547x_8x-non-pcs_bsp-050321 and trying to add my test application in compiled image. I have taken all steps in Quick Start manual My user/config.in file changes are as follows bool 'strace' CONFIG_USER_STRACE bool 'ncurses library' CONFIG_USER_NCURSES ****My change Start******* bool 'client' CONFIG_USER_CLIENT bool 'server' CONFIG_USER_SERVER ****My change End******* user/Makefile changes in their respective ta...
2 1385
by  Deleted UserJump to last post
03 May 2005 02:33 AM
9 Replies and 1322 Views LoLo at F8000000 or FFE00000?  1322  9 Started by  warden@softessn.com Hello, Out of the box, my CF5475 eval board did not seem to have LoLo running on it--I set the baud rate to 115200 in dBug, executed go FF840000, and the board froze, with no response from the terminal program. So, I figure I need to flash LoLo--went to the d/l site and got the lolo_1.5.4_MCF5475.zip file. In it, I find the likely candidate 1000587_evb-dbug_lolo.srec. However, when I attempt to load the file (after typing the 'dl 0x800000' command in dbug as in the Application note 257), I g...
9 1322
by  warden@softessn.comJump to last post
17 Apr 2005 08:20 PM
1 Replies and 1570 Views BCM5222 PHY connect failures  1570  1 Started by  stout@blunkmicro.com Blunk Microsystems has developed a TargetOS BSP for the M54XXEVB that includes an Ethernet driver for TargetTCP, our embedded TCP/IP stack. I have found that I am unable to connect to a 1000/100/10Mbps switch. The PHY never completes auto-negotiation. We have one customer who sometimes has trouble getting a physical connection on their network, depending on which device they plug into. Another customer is also unable to connect via a 1000/100/10Mbps switch. I have not seen any PHY connect pro...
1 1570
by  stout@blunkmicro.comJump to last post
17 Apr 2005 07:53 PM
6 Replies and 1259 Views More CF eval / LoLo questions  1259  6 Started by  warden@softessn.com (1) How can I make LoLo boot-up at reset (instead of dBUG) (2) Does dBUG need to use a serial EEPROM to function properly and/or to be able to execute a script after reset When I type go FFE40000 from dBUG, I get the message: serial eeprom not initialized: cpld code not detected. Do I need to have the CPLD programmed for a reset script to work (3) I would like to load a file that executes from RAM in low memory--what is the easiest way to have this application execute on reset If I l...
6 1259
by  Jump to last post
23 Mar 2005 11:51 AM
5 Replies and 1463 Views FlexBus R/W  1463  5 Started by  ron.choy@viasyshc.com Has anyone analysed the timing for the FlexBus The implementation of the R/W signal looks kind of odd to me. The EVB has the R/W signal connecting to WE of the Boot Flash. During a write cycle, the R/W goes low after the first rising edge of the clock and it is de-asserted at the end of the bus cycle. First, if you do multiple write, you may violate the WE's 'high width duration' requirement of the boot flash since a new bus cycle will start immediately after the completion of prior bu...
5 1463
by  ron.choy@viasyshc.comJump to last post
14 Mar 2005 04:06 PM
1 Replies and 1339 Views PCI Support, USB Host  1339  1 Started by  rames@pobox.com Hi All, I am looking for example code for setting up the PCI Bus Controller on the MCF5485 so the processor can access the USB Host controller on the PCI bus. Can anyone provide any pointers or examples Thanks, Richard
1 1339
by  Jump to last post
14 Mar 2005 12:33 PM
5 Replies and 1404 Views USB Problems  1404  5 Started by  jeroen.coulembier@pandora.be Hi, I'm having problems to get the USB device to work. When I plug the device in a host the Vendor ID and Device ID are 0000. How do I upload the descriptors to the Descriptor RAM The USB device doesn't work when de Dev board is powered. When I unplug the power the device is detected but the RAMEN bit is reset to 0. Greets, JeroenC
5 1404
by  jeroen.coulembier@pandora.beJump to last post
24 Feb 2005 09:41 AM
1 Replies and 1298 Views USB Driver  1298  1 Started by  jeroen.coulembier@pandora.be I want to develop USB functionality for my M5475 embedded application. I can't seem to find any drivers in the package. There isn't much support for USB developing with the M5475 either. Greets, JeroenC
1 1298
by  Jump to last post
15 Feb 2005 12:33 PM
8 Replies and 1353 Views How to use the Code Flash  1353  8 Started by  augiedog@comcast.net I can't find any info on burning the code flash. How is this done I saw a note in another group about the Flash Burner in CodeWarrior not supported by LOGICPD, and the UPDATER utility seems to just want to do the dBUG update which is at a different address. (I tried using the CodeWarrior tool and had all kinds of problems.) How do you do this at LOGICPD Also I saw an indication that there was a version of EVB that didn't handle the code flash addressing properly and needed a hardware change. ...
8 1353
by  Deleted UserJump to last post
07 Feb 2005 10:00 AM
2 Replies and 1297 Views M5475EVB Battery  1297  2 Started by  edsternberg@earthlink.net There's a place on the Mini-ITX board for a battery. Can anyone tell me the product number of the battery that's suppose to go in there Also, what is the purpose of the battery, is it necessary Thanks for any help in advance. eds711
2 1297
by  edsternberg@earthlink.netJump to last post
02 Feb 2005 05:19 PM
1 Replies and 1328 Views SREC files for LogicLoader  1328  1 Started by  augiedog@comcast.net I'm trying to burn an app in flash memory. I'm guessing that's what LogicLoader can do for me, since the CodeWarrior tools don't seem to be able to run for the MCF548xEVB. I've registered my board with LOGIC, but I can't find the LoLo SREC files that are supposed to be downloadable acording to the app note that tells me how to restore that utility. I'm guessing the utility was clobbered as I have followed the dBUG instructions to go and run from 0xFF840000, but nothing comes up. Even after I ave...
1 1328
by  Jump to last post
02 Feb 2005 01:51 PM
1 Replies and 1235 Views Application Flash issue in MCF5485EVB  1235  1 Started by  kkumar@northernpower.com Hello, I am encountering a strange duplication of data write during FLASH write operation. I am using MCF5485EVB from LogicPD and Codewarrior IDE for Coldfire (V5) . Application Flash start address : 0xE0000000 a) Write operation When I successfully program/write into the sector-0; sector-16 also gets written with same data as in sector-0!!. When I successfully program/write into the sector-1;sector-17 also gets written with same data as in sector-1. This continues... I confirmed this by peek...
1 1235
by  Jump to last post
13 Jan 2005 05:22 PM
1 Replies and 1335 Views debugger project/source for GCC  1335  1 Started by  mike.atkins@futureelectronics.com Is any version of the MCF5475 debugger available in GCC compatible project and makefiles Freescale's web-site only has Codewarrior project/source files.
1 1335
by  Jump to last post
06 Jan 2005 01:31 PM
9 Replies and 1538 Views MCF5485EVB Ethernet issues  1538  9 Started by  kkumar@northernpower.com Hello, I have MCF5485EVB board with standard configuration and I am using CodeWarrior IDE. I ran into issues with regard to Ethernet communication. 1. I am using default FEC driver code and example Tx test code from Freescale. 2. I hooked up a patch cable between ethernet port 0 and the hub, the example code runs fine and I get the message that Transmisson test is passed. Now, if hook up the patch cable between Port 1 and the hub, run the same code with transmisson occuring at FEC 1. I get th...
9 1538
by  kkumar@northernpower.comJump to last post
28 Nov 2004 10:36 AM
1 Replies and 1509 Views Codewarrior's Flash Programmer issue  1509  1 Started by  kkumar@northernpower.com Hello, I am trying to Flash simple standalone application into the boot flash memory but I am running into problem with codewarrior Flash programmer. Following steps I did: 1. At Codewarrior IDE-> Flash Programmer, loaded the settings 'M5485EVB_BootFlash.xml' found in Codewarrior's directory chain&91Metrowerks\CodeWarrior\E68K_Support\Initialization_Files &93 2.When I tried to Program the ELF to Flash, I get the message that it is programming but it stays there even after 20-25 minutes !!...
1 1509
by  kkumar@northernpower.comJump to last post
24 Nov 2004 09:46 AM
5 Replies and 1239 Views No CPLD code on my M5475EVB  1239  5 Started by  keithm@transmeta.com I've recently started playing with an M5475EVB and have lolo running. If I do 'info arch', I get the string 'CPLD not programmed.' Should it be I'd like to be able to access the compact flash on the board.
5 1239
by  keithm@transmeta.comJump to last post
16 Nov 2004 11:34 AM
1 Replies and 1220 Views RTC in MCF5485EVB  1220  1 Started by  kkumar@northernpower.com Hi, Does standard MCF5485EVB comes with RTC with the battery I see the battery socket being empty in the board. Thanks in advance. -Kiran
1 1220
by  kkumar@northernpower.comJump to last post
15 Nov 2004 12:49 PM
You are not authorized to create a new topic
Page 7 of 8 << < 45678 > >>


RSS Feed Available