Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 6 of 8 << < 45678 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 1393 Views boot_from_flash  1393  1 Started by  yanhua347@sohu.com hi: I have a 5474lit board, but the source is so simple. now,I want the code of a bootloader instead the dBUG ,so I download mcf547x_8x-non-PCS_2.6_bsp-050413.tar.gz ,in it the colilo cann`t boot form ff800000. And I also download mcf54x5_x4-20050802-ltib.iso,but cann`t be installed even 'no_root> /mnt/cdrom/install',it say ltib problem,cann`t mdir ,cann`t find something and so on. In all ,I want the something can compile out the mcf5474.bin for boot from ff800000.and the code of it . than...
1 1393
by  Jump to last post
03 Nov 2005 12:19 PM
4 Replies and 1301 Views FlexBus CS pins and accessing unallocated memory space  1301  4 Started by  ghlavenka@usbiometrics.com I have the feeling this is really a simple question, but it's a hurdle I have to get over... We've bought a couple of the Logic eval kits (FireEngine/ITX) to do development on. I want to hang a bytewide parallel device onto a CF processor; for the sake of discussion let's say it's a Hitachi character LCD. Looking at the ITX board schematics, I see that the PC104 connectors have FlexBus signals on them, including 3 FBCS lines. I decide I want to generate FBCS3 for my LCD. I cleaned the sold...
4 1301
by  ghlavenka@usbiometrics.comJump to last post
02 Nov 2005 01:22 PM
3 Replies and 1447 Views M5474LITE PCI INTA connected to IRQ7?  1447  3 Started by  aaronjstewart@gmail.com Hi - we've started working with the PCI slot on this board, only to realize that PCI INTA is tied to IRQ7. From what I can tell, IRQ7 is an NMI, and is not configurable in the interrupt controller. This would imply that I can never mask interrupts generated from my PCI card, which will cause problems in our OS which needs to disable all interrupts during certain sections of the code. Assuming my interpretation of IRQ7 is correct, I either need to run my PCI card in polling mode (not use the INTA...
3 1447
by  Deleted UserJump to last post
31 Oct 2005 03:07 PM
3 Replies and 1282 Views Latest Memory Map  1282  3 Started by  cbaron@nordson.com I'm using the M5485AFE ColdFire board with Logic Loader version 2.02. I understand that BoLo is gone, what is the latest memory map (flash/ram) for LoLo newuser
3 1282
by  cbaron@nordson.comJump to last post
28 Oct 2005 06:23 AM
5 Replies and 1225 Views Load command  1225  5 Started by  cbaron@nordson.com Is there any error checking on the file transfer using the 'load' command. newuser
5 1225
by  Jump to last post
27 Oct 2005 08:36 AM
3 Replies and 1221 Views TFTP  1221  3 Started by  cbaron@nordson.com Thanks Bruce, I see there is a 'load elf/tftp/my_server:my_file' command example. I assume that this a TFTP file transfer would TFTP support error detection Thanks Carl
3 1221
by  Jump to last post
27 Oct 2005 08:34 AM
2 Replies and 1338 Views MIPS with DDR RAM and Coldfire MFC5485  1338  2 Started by  aaronjstewart@gmail.com With the DDRRAM and the Coldfire MCF5485 embedded in the M5485EVB development board, How many MIPS can be expected with code executed from the DDR (CLKIN = 50 MHz CACHE disabled)
2 1338
by  lucien.perrin@schneider-num.comJump to last post
27 Oct 2005 12:57 AM
7 Replies and 1372 Views Boot-up sequence  1372  7 Started by  cbaron@nordson.com In my past applications at boot-up the loader(not LoLo or BoLo) looks for a character at the serial port. If the character is seen the loader executes commands to transfered a program file from a PC and burn to flash. If no character is seen the loader then jumps to a progarm location in flash. Since BoLo is gone, is there a way to reproduce the above steps using LoLo scripts newuser
7 1372
by  Jump to last post
24 Oct 2005 04:18 PM
9 Replies and 1330 Views Can't build the Metrowerks BSP kernel  1330  9 Started by  rnotari@curtisswright.com I am trying to build the Metrowerks MCF547x 2.4 kernel (non pcs) under cygwin running under Windows XP. The first 2 steps seems to go ok ('make fresh', 'make config-m547xlite'). The third step ('make dep') runs for about 2 minutes and crashes with a 'too many arguements' error. Does anyone have any experience with this BSP version Please don't answer with a lot on UNIX techno-babble. I have never seen UNIX before, so all this is brand new to me.
9 1330
by  rnotari@curtisswright.comJump to last post
20 Oct 2005 10:52 PM
6 Replies and 1492 Views rcu_dereference() return NULL pointer  1492  6 Started by  overet@securitydate.it Hi, i have a problem with the linux kernel non PCS 2.6.10 version. The Bridge module not works properly on the coldfire arch. I seen that it have a problem with rcu_dereference() function, that return a NULL pointer while it shouldn't. Do you have found the same problem in some situation Best regards, Giuseppe Gottardi
6 1492
by  hatzfeld.f@duerr.deJump to last post
23 Sep 2005 12:53 AM
2 Replies and 1307 Views Lolo network commands on M548xEVB lite  1307  2 Started by  andrew.cox@timeomatic.com When I enter 'losh> help net' it lists no available commands. Is lolo network functionality completely disabled for this board Thanks.
2 1307
by  andrew.cox@timeomatic.comJump to last post
22 Sep 2005 09:57 AM
1 Replies and 1315 Views Ethernet on PCI error  1315  1 Started by  overet@securitydate.it Hi, I have developed an embedded system with 2.6.10 kernel (LinuxBSP package) and linux system works fine on the board. Now i need to use additional PCI Ethernet but i have a problem making the new image. When i add a '3Com cards' on 'Networking support' in the kernel configuration i have this error at the compiling time: undefined reference to 'pci_dma_sync_single_for_device'. I tried to change NIC adapter but i have the same problem. Could you help me, please. Best regards, Giuseppe Gottard...
1 1315
by  Jump to last post
15 Sep 2005 02:26 PM
1 Replies and 1392 Views Running RT Linux pro  1392  1 Started by  ameer.youssef@mdacorporation.com On the logic pd website it says that the MC5485 can run linux. Is RT Linux included in this I am thinking of using RT Linux pro but I don't know if it will run or not. Thanks in advance.
1 1392
by  Jump to last post
15 Sep 2005 02:08 PM
4 Replies and 1274 Views MCF5485 power problem?  1274  4 Started by  overet@securitydate.it Hi, I'm using a LinuxBSP non PCS (kernel 2.6.10) and i have compiled 'ne2k_pci' module for a NE2000 PCI ethernet card. The compilation works fine. After the Linux sytem booting, i load the ne2k_pci module for my card but the card doesn't work. Making the command 'lspci' the card isn't found. Anyone know a solution for this problem Are there a power problem for some PCI cards Anyone know a PCI ethernet card or USB ethernet adapter that works fine with the MCF5485 board Tanks. Regards, Giu...
4 1274
by  overet@securitydate.itJump to last post
01 Sep 2005 05:42 AM
3 Replies and 1326 Views Problem loading lolo  1326  3 Started by  ameer.youssef@mdacorporation.com I tried to load lolo by typing 'go ffe40000' (as indicated in the quick start guide of the M5484EVB kit). But I get a message back saying it is an illegal instruction: dBUG> go ffe40000 Illegal instruction at 0xFFE40000 PC: FFE40000 SR: 2000 &91t.Sm.000...xnzvc&93 An: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 04000000 Dn: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 FFE40000: 0000 DC.W 0x0000 dBUG> What is the reason...
3 1326
by  ameer.youssef@mdacorporation.comJump to last post
29 Aug 2005 11:29 AM
3 Replies and 1224 Views M5484EVB dBUG screen not appearing in tera term  1224  3 Started by  ameer.youssef@mdacorporation.com I just received the M5484EVBkit. I followed the start up instructions, but the dBUG monitor doesn't appear. I checked all the connections, tera term settings, and pressed reset but still nothing appears!!
3 1224
by  Jump to last post
26 Aug 2005 01:17 PM
5 Replies and 1253 Views M54xxEVB USB device wiring  1253  5 Started by  csaba.kormendy@quadros.com I recently heard that there may be a USB device related wiring problem with the M54xxEVBs. I have a rev B M5485EVB (Fire Engine) board. Is this rev affected I am developing a USB device driver and I am starting to suspect that I am having a physical layer problem. I know my cable is good because it works with another USB device. I initialize the USB device controller as indicated by the MCF5485 manual. However the USB controller never seems to come out of reset (USBISR&91RSTSTOP&93 neve...
5 1253
by  Jump to last post
09 Aug 2005 08:19 AM
2 Replies and 1439 Views CAN Bus not working  1439  2 Started by  ewald.mack@samtec.de Hello, we have the M548x EVB LITE / REV-A with Metroworks Linux 2.6. Presently we are testing the CAN implementing (CAN4Linux) on this board and have many problems. If we send a can frame on CAN1 (CAN0 is not connected on the development board), we see some signals on an oszilloscope, but it's not really a CAN frame (also we get a bus error on a parallel connected CAN analyser). Did anybody here get the CAN controller working What software (OS) and what hardware do you use (REV-) Are th...
2 1439
by  jkinross@medrad.comJump to last post
04 Aug 2005 07:18 PM
4 Replies and 1325 Views Running from user flash  1325  4 Started by  jkinross@medrad.com Hello, I have a simple application that I can run from boot flash but not user flash. I convert the elf file to raw with objcopy and I can move it any where in boot flash (0xFF80-0000) with LoLo's load and burn commands and at the dBug prompt type go <addr> and it runs fine. As soon as I move it to user flash (0xE000-0000) and type go <addr> the dBug hangs. I've tried changing my memory map without success. Also using exec or jump from LoLo hangs LoLo as well, regardless ...
4 1325
by  jkinross@medrad.comJump to last post
06 Jul 2005 03:45 PM
8 Replies and 1432 Views MCF547XEVB (Fire Engine) with USB support.  1432  8 Started by  narayan@crestron.com Hi folks, Has anybody brought up linux BSP of Metrowerks on a Logic Products MCF547X EVB with USB host support. I manually turned on the USB HOST (OHCI and EHCI) flags in the config file 'defconfig/linux mcf547xevb' file as I could not get 'xconfig' to set this up properly. When I loaded the image files using colilo, the console freezes after the following .... host/usb-ohci.c: USB OHCI at membase 0xd0000000, IRQ 69 host/usb-ohci.c: usb-00:01.0, Philips Semiconductors USB 1.1 Host Contro...
8 1432
by  narayan@crestron.comJump to last post
04 Jul 2005 08:12 PM
You are not authorized to create a new topic
Page 6 of 8 << < 45678 > >>


RSS Feed Available