Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 5 of 8 << < 34567 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 1380 Views Boot linux image problem on CF5485EVB, kernel panic  1380  1 Started by  yingbohu I try to boot the sample linux image on 5485EvB. I have donwloaded and burnt all the image to the flash according to the instruction. but when I boot the kernel, some kernel panic will occur, following is the log: ***************************************************************** LogicLoader (c) Copyright 2002-2005, Logic Product Development, Inc. All Rights Reserved. Version 2.0.4-MCF5485_10 0001 ***************************************************************** ...
1 1380
by  yingbohuJump to last post
10 Feb 2006 10:41 AM
1 Replies and 1468 Views CompactFlash Driver on MCF5485EvB  1468  1 Started by  yingbohu I tried to develop our own CompactFlash driver on MCF5485EvB, I have the CPLD code and I can successfully read out the CPLD hardware and software revision and signture. I can also read/write the CompactFlash ATA register but after I issue IDENTIFY DEVICE command, the data returned is not correct I could not find the CompactFlash signture there and other information, all the 512 bytes data contains the same data pattern. I also try to use the sample code in the linux BSP CompactFlash driver but t...
1 1468
by  yingbohuJump to last post
31 Jan 2006 04:11 PM
2 Replies and 1516 Views linux 2.6 on coldfire mcf5485?  1516  2 Started by  Deleted User hi, anyone gotten linux-2.6 running on the 5485 yet if so, care to share your config/patchset
2 1516
by  vitaly@luban.orgJump to last post
30 Jan 2006 04:51 PM
4 Replies and 1737 Views bad code flash  1737  4 Started by  hadi_dewan Hi, I am using &91/b&93using MCF-547x coldfire eval board. I think I have bad code flash. I have erased the code flash several time. However I still get the same error during boot up. I follow the exact steps to download and burn linux on the code flash provided by logicPd linux Distribution. I can see Linux pick up the flash config fine. However duing bootup it complain about bad flash block. Following is my output. This is a brand new box. And I never used code flash before.. So I am not su...
4 1737
by  hadi_dewanJump to last post
05 Jan 2006 09:08 AM
1 Replies and 1495 Views M547XEVB - boot uClinux?  1495  1 Started by  Deleted User hi all, i've recently received a Freescale M547xEVB board with the 5485 Fire Engine &91Coldfire&93. i've built a uClinux image using the config for M5475EVB, linux-2.4.x, uClibc .. and i can 'dn -i image.bin' this image to my board just fine .. however when i issue the command 'go 0x20000' &91per the Documentation/FREESCALE-M5275EVB-HOWTO instructions&93 all i get is '.''s printed over and over .. has anyone been able to successfully build a uClinux kernel for this board on their own, and...
1 1495
by  Jump to last post
29 Dec 2005 11:33 AM
4 Replies and 1679 Views Help with M5484LITE  1679  4 Started by  KA4EPD Well I just received my 5484LITEKit today and already have lots of questions. After reading this group I have even more! I am trying to get lolo to start up. It seems from this group that the entry point has moved. When I do a g 0xff840000 it goes out in the weeds. Tried the other entry suggested in http://www.logicpd.com/downloads/archiv ... _Rev_B.pdf but no luck. Tried to download the code and reflash it using freescale tools but the website will not let me have it. (contact webmaster ...
4 1679
by  KA4EPDJump to last post
20 Dec 2005 03:22 PM
2 Replies and 1436 Views USB Issue on MCF5474  1436  2 Started by  Deleted User You have mentioned in previous posts that the USB device module on the MCF5475 does not work. Does the USB module on the MCF5474 work Thank you, Jon
2 1436
by  Deleted UserJump to last post
20 Dec 2005 02:25 PM
1 Replies and 1501 Views Using MCF547x Fire Engine on a PCI card  1501  1 Started by  Deleted User I was wondering if it was possible to use the Fire Engine module on a card plugged into the PCI bus of a standard Pentium 4 personal computer I notice that the MCF547x/8x series contain many of the PCI host support functions such as bus arbitration. Can these be disabled to that the PC's North Bridge arbiter and PCI support functions are used instead Are there any drivers available for the use of this board as a PCI add-on to a PC Thanks, James
1 1501
by  Jump to last post
20 Dec 2005 01:55 PM
3 Replies and 2079 Views Xilinx Xc2C128 CPLD ... cannot program this device. WHY?  2079  3 Started by  wmohat I am trying to use the PC-104 interface on the FireEngine. There are SERIOUS design flaws with this interface, which I have corrected. And, I have produced timing diagrams, documentation, and CPLD source code to make this interface functional. HOWEVER---- I am not able to program the Xilinx CPLD on the board, which controls many of I/O devices (like the Compact FLASH, etc) and the PC-104 connector. I have tried programming the XC2C128 CPLD, using both a Xilinx Parallel II...
3 2079
by  wmohatJump to last post
20 Dec 2005 01:55 PM
1 Replies and 1546 Views CPLD could not be updated, why?  1546  1 Started by  yingbohu I am trying to update the CPLD code but I get some error message: File CPLD code file name is: 5485 128MC CPLD update file.upd I also tried LoLo 2.04, the result is the same. Who can help me Thanks. Following is the message I got from Tera Term: spi not initialized: cpld code not detected. serial eeprom not initialized: cpld code not detected. spi not initialized: cpld code not detected. serial eeprom not initialized: cpld code not detected. CPLD not programmed. video-set-default: unabl...
1 1546
by  Jump to last post
20 Dec 2005 01:51 PM
7 Replies and 1520 Views GCC does not produce FPU code  1520  7 Started by  laslo Hello. I've been trying to compile some fpu code but gcc does not want to cooperate. If i use the -m5407 option then it compiles in soft fpu emulation, if i try to use -mcfv4e (i think that this should be the right target for fpu) then i get an error message cc1: error: invalid option 'cfv4e' after some investigation it seems that m68k-elf-as does support -mcfv4e but cc1 does not. Any sugestions Thanks in advance.
7 1520
by  lasloJump to last post
19 Dec 2005 01:09 PM
1 Replies and 1395 Views Metrowerks BSP: PCI on ColdFire 5485 EVB  1395  1 Started by  Deleted User I am having trouble with PCI on this board. I have built the Metrowerks linux kernel with PCI enabled and it will not boot. It gets stuck on 'PCI: Probing PCI hardware' Do you have any suggestions
1 1395
by  Jump to last post
05 Dec 2005 06:15 PM
1 Replies and 1598 Views 46V16M16 DDR  1598  1 Started by  Deleted User hello: I have never user DDR, but in my 5474lite board used it so ,I want elements map, Could you provide it in 'http://www.logicpd.com/support/' thank you !
1 1598
by  Deleted UserJump to last post
29 Nov 2005 09:08 AM
3 Replies and 1544 Views Exercising I2C from losh prompt  1544  3 Started by  GHlavenka Using information from pages 26-14 and 26-15 of Freescale's MCF547x Reference Manual (Rev 2.1) I issue the following commands to losh: > losh> w /b 0x10008f20 0 > losh> w /b 0x10008f08 0 > losh> w /b 0x10008f20 0x0a > losh> w /b 0x10008f0c 0 > losh> w /b 0x10008f08 0 > losh> w /b 0x10008f20 1 This should theoretically issue a STOP to all slaves and make sure the bus is idle. At this point, I dump the registers to see what state everything's in: > losh>...
3 1544
by  GHlavenkaJump to last post
22 Nov 2005 10:47 AM
1 Replies and 1616 Views Linux questions for ColdFire 5485 EVB  1616  1 Started by  Deleted User I am ready to build a kernel with the logic linux bsp and am trying to decide which default configuration file to use. I have a CF5485 EVB but don't know what afe and cfe mean in the file names. Is it necessary to use Logic Loader or can I use colilo to load the linux image and link the root file system via nfs on the host What is the status of USB device and host support with the logic tools How can I alter the config file to build a custom configured kernel I know that there are differ...
1 1616
by  Deleted UserJump to last post
15 Nov 2005 12:10 PM
1 Replies and 1618 Views Ecos for M5485EVB  1618  1 Started by  André Lämmer Is there a port of eCos for this board http://sources.redhat.com/ecos/ André Lämmer
1 1618
by  Jump to last post
15 Nov 2005 09:15 AM
5 Replies and 1584 Views Can't access upper half of M5474LITEKIT 4MB Flash  1584  5 Started by  craigdry My M5474LITEKIT has a 4MB flash(Intel 28F320). I can only access the first 2MB. I believe this is due to an error in the Logic Schematic which shows A0-A20 being in use for a 4MB part. However the Intel 28F320 says that A0-A21 are required. I need a workaround. On my board R426 is open and R427 has a resistor. Should I remove the resistor or close R426 Thanks.
5 1584
by  craigdryJump to last post
14 Nov 2005 02:07 PM
1 Replies and 1464 Views install_toolchain  1464  1 Started by  Deleted User hi I have download LinuxBSP-22012005-1.0.2.tar.bz2 LinuxTools-1.0.2.tar.bz2 thank you provide it. But after install the toolchain , in the /opt/logicpd/ColdFire/m68k-linux/gcc-3.4.3-glibc-2.3.5/bin just has 5: m68k-linux-insight ,m68k-linux-gdbtuim68k-linux-gdb tclsh8.4 wish8.4 so,when I make LinuxBSP,there is some problem: &91rootlocalhost LinuxBSP-22012005&93 make make -C linux-2.4.26 || exit 1 make&911&93: Entering directory `/my_linux/LinuxBSP-22012005/linux...
1 1464
by  Deleted UserJump to last post
14 Nov 2005 12:51 PM
1 Replies and 1407 Views Program saved in FLASH, but run in RAM  1407  1 Started by  newuser Hello, I would like my application stored in FLASH, but loaded to, and run from, RAM at boot-up. I know that “load” and “burn” can save the program into FLASH, but are there LOLO functions to unload the program from FLASH to RAM at boot-up time newuser
1 1407
by  newuserJump to last post
04 Nov 2005 08:52 AM
3 Replies and 1363 Views Boot time script  1363  3 Started by  newuser Hi I can’t seem to make a boot-time script work. Here is the command I used to store the script into eeprom:“losh> echo “VOVOhelp dir; info mem; exit;” /dev/serial_eeprom”. I then used the “cat” to confirm the script. When I reboot the Fire Engine board all I see is the standard power-up messages. What is wrong with the script newuser
3 1363
by  newuserJump to last post
03 Nov 2005 01:12 PM
You are not authorized to create a new topic
Page 5 of 8 << < 34567 > >>


RSS Feed Available