Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 4 of 8 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 1368 Views Swapping base boards  1368  1 Started by  vmo Is the mcf547x lite base board compatible to work with the mcf5475 fire engine
1 1368
by  Jump to last post
01 Aug 2006 10:43 AM
7 Replies and 1562 Views How to use both PCI slots?  1562  7 Started by  André Lämmer How can I use both PCI slots of the M5485EVB Is there a riser card which extends the bus to two new slots I found a card from Via, but this card works supposedly only with Via Epedia boards. http://www.tragant.de/produkte/artikel_ ... mmer=32309 André Lämmer
7 1562
by  André LämmerJump to last post
29 Jul 2006 09:35 AM
6 Replies and 1566 Views 5485 PCI failure  1566  6 Started by  kamilgrig Hi, We are using Zoom CDK MCF5485 board together with Freescale’s Linux Board Support Package ltib-mcf547x_8x-20051213.iso, based on kernel 2.6.10. Our project is actually in final stage, but we faced a problem with PCI communication. Our device makes reading information from PCI our device and transferring it through TCP/IP to host PC. The handshaking with PCI device is very simple. As soon as new device’s buffer is ready, the device pulls interrupt line down. We are using IRQ7 line for this ...
6 1566
by  Jump to last post
18 Jul 2006 02:11 PM
1 Replies and 1769 Views Performance. Coldfire vs ARM Is this as good as it gets?  1769  1 Started by  tbob Hello All, A colleague runs the included c program on his ARM system and gets times around 3.6 seconds. On my logicpd development board I'm getting about 16s. I know there are lots of variables here but I'm hoping to get an idea from the group as to whether we should expect more from the coldfire or not. Thanks The arm system: uname -a Linux (none) 2.6.17 7 Fri Jun 23 15:54:11 UTC 2006 armv4tl unknown cat /proc/cpuinfo Processor : ARM920Tid(wb) rev 0 (v4l) BogoMIPS : 88.47...
1 1769
by  tbobJump to last post
06 Jul 2006 01:31 PM
1 Replies and 1370 Views M5485CFE: LoLo issues on watchdog reboot?  1370  1 Started by  burelllil Hello, I am trying to debug an issue I get when the 5485 reboots due to the watchdog expiring. &91I know this should never happen, but that's another matter...). We are using the latest Logic LinuxBSP and LoLo 2.0.6. The problem is that sometimes the uC reboots but hangs before entering (or inside) LoLo, as no messages are output by the serial port (I have a boot script in the E2PROM starting with VOLO so that normally I see what's going on). Notes: - I'm sure the micro reboots, because outpu...
1 1370
by  burelllilJump to last post
16 Jun 2006 06:03 AM
2 Replies and 1539 Views M5485CFE PSC GPIO problems  1539  2 Started by  burelllil Hello, we have purchased two ColdFire development boards last winter, and we have developed our custom host/expansion board. Everything runs nicely except for a curious problem we have when trying to use some PSC pins as GPIO. I hope somebody could give me some insight to the problem... Details: pins affected : PSC0CTS, PSC3RTS, PSC3CTS PDDR_PSC3PSC2 : 0x02 (rts3 and cts3 as inputs) PDDR_PSC1PSC0 : 0xC4 (cts as input) The circuit connected to these GPIO li...
2 1539
by  burelllilJump to last post
16 Jun 2006 04:35 AM
2 Replies and 1512 Views Problem in loading .elf file to m5484 LITE kit  1512  2 Started by  Deleted User Hello All, I am wokring on m5484 LITE dev kit. I downloaded Linux BSP and Toolchain from http://www.logicpd.com. I built the image on Fedora 4. Then i followed all the instructions to download the file to kit- The following is the result what i got- losh> ifconfig sm0 dhcp WARNING -- valid config block not found - using default MAC address Starting DHCP on sm0 losh> load elf /tftp/192.168.0.190:image-m5484gfe-lite.elf loading from /tftp/192.168.0.190:image-m5484gfe-lite.elf: ignoring r...
2 1512
by  Deleted UserJump to last post
13 Jun 2006 10:52 AM
1 Replies and 1715 Views BDM question regarding 5475 and 5485  1715  1 Started by  hadi_dewan Hello, We are using 5475 eval boad and the BDM that comes with the package(P&E micro). Now what I have noticed,in the BDM the PSTCLK is enable(Synchronous mode) and the PSTCLK is running at 133Mhz. Gdb doesnt seem to work on Asynchronous mode(PSTCLK disabled). However the logicPD user Manual documentation says otherwise. Now how can I make GDB work on both mode. We have developed our own board with 5485. We are having issue with the BDM. PSTCLK is at 100Mhz in our board. gdb-bdm doesnt se...
1 1715
by  Jump to last post
03 May 2006 12:38 PM
1 Replies and 1320 Views burn image into flash  1320  1 Started by  Deleted User How do I reduce the image-size of LogicLinux to fit in built-in-flash on the M5484LITE-card My image is around 4.5 MB, and the card supports only 4MB (without CF). / Johan
1 1320
by  Deleted UserJump to last post
03 May 2006 12:13 PM
6 Replies and 1514 Views M5484LITE Kernel Panic  1514  6 Started by  piku Hey all, Just got the M5484lite and built the m5484gfe-lite-romfs image for it. When I load the kernel it goes through, decompresses the romfs image and attempts to boot and it claims it cannot find init and the kernel panics. I have no other coldfire hardware to ensure busybox or bash built correctly (using logic's toolchain that I also built myself). Any ideas http://pikachu.dynup.net:8001/coldfire/ There is my kernel image build, the romfs image by itself and bash and busybox tarred up...
6 1514
by  pikuJump to last post
03 May 2006 11:52 AM
1 Replies and 1392 Views [M547xLITE] Debugging the Linux Kernel  1392  1 Started by  kwong Hi, I'm new to the Coldfire series and debugging via BDM. I'm currently having trouble debugging a Linux v2.6.10 kernel using BDM. I can't seem to properly step to the next statement in the kernel... everytime I try, I get the following error: BDM error: Target Bus Error Admittedly, my environment has some quirks to it that may be the cause. Here's how everything is setup: (1) build the kernel and bootloader (from the ltib package) under Linux under VMware (2) start the board up, connect ...
1 1392
by  Jump to last post
27 Apr 2006 11:40 PM
5 Replies and 1525 Views 5474LITE Evaluation Problems  1525  5 Started by  gary.carlson I am a principal engineer that is presently tasked with developing a next generation instrument platform within my company. Since I am leaning towards using the Freescale 5474 running a Linux OS, I decided to buy the evaluator board. Needless to say, this has not been a very rewarding experience. Problem 1: It is very confusing who exactly is responsible for the Linux build image. Freescale has instructions posted on their website for this board and Logic has theirs. Needless to say Frees...
5 1525
by  kwongJump to last post
25 Apr 2006 09:11 AM
1 Replies and 1392 Views BDM Issues  1392  1 Started by  vmo I am trying to do development work on my laptop that has a Quatech parallel PCMCIA card installed. After installing Cygwin and the GNU Cross Development Toolchain v2.4, I ran gdb and tried to open up the BDM device (by entering 'target bdm /dev/bdmcf0'. GDB returned an error saying 'BDM error: No such device'. The LPT port is set to 1 and I know that bdmcf0 corresponds to that. I also have set up another development machine on a desktop and I've gotten it to work with the same setup files. ...
1 1392
by  Jump to last post
29 Mar 2006 05:02 PM
22 Replies and 2476 Views Starting Lolo just outputs garbage.  2476  22 Started by  Andy Daytona
(Topic has multiple pages1 2 )
Hi, I have the 5475EVB rev B and I am trying to start lolo from dBug. I start it with the command go ff840000 Two LEDs on the board starts blinking alternately and I get garbage text in my terminal. It seems to understand what I am typing because different command give different amounts of garbage... I tried upgrading to the latest version on the Logic website but nothing changed so I suppose it was the latest version from the start. My terminal is set to 115200bps. dBug works fine at 11520...
22 2476
by  vmoJump to last post
29 Mar 2006 09:55 AM
1 Replies and 1430 Views SDRAM configuration in MCF5485  1430  1 Started by  hadi_dewan Hi, I was just wondering if anyone have all the configuration values for MCF5485Evb SDRAM initialization. Currently I have the following. I set my $bar to 0x1000000. Any help would be really appreciated. If you can send me the dump of the your lolo at those memory address. Hadi set *0x10000004 = 0x000002AA set *0x10000020 = 0x00000019 set *0x10000108 = 0x73722930 set *0x1000010C = 0x46370000 set *0x10000104 = 0xE10F0002 set *0x10000100 = 0x40010000 set *0x10000100 = 0x058D0...
1 1430
by  hadi_dewanJump to last post
28 Mar 2006 04:02 PM
1 Replies and 1373 Views LoLo will not start!!  1373  1 Started by  djr3203 I recently purchased an MCF5474Lite evaluation board from freescale. Using teraterm I could enter dbug just fine. After I set my baud rates, I tried to access LoLo, but when I typed 'go ff840000' the board just hung there not doing anything. I reset the board and tried again and same thing happened. When I did a memory display of ff840000 it looked as if the old LoLo was loaded, version 1.5. I uploaded version 2.0.5 as directed by application note 257, yet LoLo would still not come up. Tod...
1 1373
by  Jump to last post
27 Mar 2006 03:30 PM
1 Replies and 1486 Views GDB/BDM support under Cygwin for PCI parallel cards  1486  1 Started by  vmo The GNU Cross Toolchain does not work for computers with non standard parallel ports. Since PCI parallel cards do not use the standard port addresses, GDB is not able to find the BDM device. In the "BUGS" file of the m68k-bdm-1.3.0 source folder, it says "- PCI parallel ports with non-standard port-addresses not supported.". Does this mean that GDB/BDM will not work on computers with PCI parallel cards at all Or do we have to edit the source code ourselves to make it wor...
1 1486
by  Jump to last post
22 Mar 2006 10:14 AM
1 Replies and 1403 Views i2c header 5485EVB  1403  1 Started by  tmloos I am wondering if there are any know issues with the i2c header J22 on the main board. I wired in a Microchip 24LC256 eeprom and ran i2cdetect 0 in Linux and did not see the part at address 0x04 where I expected. I did see the rtc part at address 0x32. I was able to run i2cdump 0 0x32 and see the rtc registers without the 24LC256 wired in. I then tried to run i2cdump 0 0x32 with the 24LC256 wired in to J22, with no power, and now i2cdump 0 0x32 hangs, with or without the 24LC256 wired in ...
1 1403
by  tmloosJump to last post
02 Mar 2006 03:15 PM
2 Replies and 1442 Views MCF5474 AE5 pin  1442  2 Started by  Deleted User I am using the MCF5474lite I found the AE5 pin of MCF5474 is low when the CPU be reset or power on who can explane the phenomena thanks
2 1442
by  Deleted UserJump to last post
21 Feb 2006 04:10 PM
1 Replies and 1443 Views PCB for mcf5474lite  1443  1 Started by  Deleted User hi: the PCB for mcf5474lite can be provided for the user in "All Downloads" I meet some problem of hardware, so can you provide or the ZEB document thank you very much!!
1 1443
by  Deleted UserJump to last post
14 Feb 2006 10:25 AM
You are not authorized to create a new topic
Page 4 of 8 << < 23456 > >>


RSS Feed Available