Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 3 of 8 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
4 Replies and 1548 Views Error building image  1548  4 Started by  bibhu85@gmail.com Make fresh and make config-m5485afe-evb-romfs work fine. I have installed cygwin and the cross-tools from the CD that comes with the FreeScale package. This is whats happening when I am trying to create dependencies. D:\LinuxBSP-22012005-1.0.2\LinuxBSP-22012005>make dep make -C linux-2.4.26 dep make&911&93: Entering directory `/cygdrive/d/LinuxBSP-22012005-1.0.2/LinuxBSP-220120 05/linux-2.4.26' gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o scripts/mkdep scripts/ mkdep.c gcc.exe...
4 1548
by  bibhu85@gmail.comJump to last post
12 Jun 2007 10:50 AM
5 Replies and 1498 Views System Speed  1498  5 Started by  newuser Dear Sirs, We too are experiencing performance problems similar to one seen by Dawdyka and Vincent. Because of start-up issues we are using debug instead of Logic Loader. At this point we don’t know if the performance loss is due to slower ram settings from debug or some other problem. Could you send the SDRAM initialization code, or at least the register values Also we are seeing 50Mhz at the processor clock input, however it looks more like a sinusoidal.
5 1498
by  newuserJump to last post
29 May 2007 06:37 AM
7 Replies and 1581 Views 5484Lite system speed  1581  7 Started by  dawdyka I've been evaluating the 5484 Fire Engine module for potential use and the only way I can get close to the 200 MHz performance is to have the code and instruction caches enabled (I have code and data both in SDRAM, but I am using 16M blocks for each and using the ACRx registers to differentiate between the two), branch cache enabled, stack in internal SRAM, and the code in internal SRAM. If the code is running in SDRAM, performance is closer to 50 MHz. As far as I can tell, all registers are...
7 1581
by  VincentJump to last post
17 May 2007 10:17 AM
0 Replies and 1459 Views error building toolchain  1459  0 Started by  henrys gcc -DHAVE_CONFIG_H -I. -I/home/henry/BSP/LinuxTools/insight-6.3.50/bfd -I. -I. -I/home/henry/BSP/LinuxTools/insight-6.3.50/bfd -I/home/henry/BSP/LinuxTools/insight-6.3.50/bfd/../include -I/home/henry/BSP/LinuxTools/insight-6.3.50/bfd/../intl -I../intl -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Werror -g -O2 -c /home/henry/BSP/LinuxTools/insight-6.3.50/bfd/elf32-m68k.c -o elf32-m68k.o cc1: warnings being treated as errors /home/henry/BSP/LinuxTools/insight-6.3.50/bfd/elf32-m68k.c: In fun...
0 1459
10 May 2007 08:20 PM
0 Replies and 1447 Views Display messages on the console  1447  0 Started by  Vincent Hello, Is there any function in the libc which can be used to display messages on the console I tried the most popular functions without any success. Thank you, Vincent
0 1447
02 May 2007 03:58 AM
1 Replies and 1366 Views Problem downloading the sample application  1366  1 Started by  Vincent Hello, I compiled the sample application led_flasher adn tried to send led_flasher.elf to the board. Unfortunately, the loading process failed with the following message: loading from stdin: 0x000c0000 7f 45 4c 46 34 34 38 34 20 28 54 90 90 4e 56 ff .ELF4484 (T..NV. 0x000c0010 fc 20 3c 90 2d 40 ff fc 20 3c 90 b0 ae ff fc 63 . <.-.. <.....c 0x000c0020 20 2e ff fc 20 40 42 90 58 ae ff fc 60 e6 61 ff ... B.X...`.a. 0x000c0030 f2 42 80 4e .B.N E...
1 1366
by  VincentJump to last post
27 Apr 2007 07:16 AM
5 Replies and 1433 Views problem running sample application  1433  5 Started by  ameer I tried running the sample application with both Flash and ram, but neither is working. I get ' error: invalid option '5407' '.
5 1433
by  VincentJump to last post
27 Apr 2007 02:54 AM
0 Replies and 1489 Views 5485 timing diagrams  1489  0 Started by  walder Has anyone found good 5485 timing diagrams I cannot accurately pin-point SRAM access on the FlexBus with the published information I have found (e.g. FB1, 2, 3, 4 ...). Walder
0 1489
20 Mar 2007 02:23 PM
0 Replies and 1434 Views Content of VBR for FLASH  1434  0 Started by  ViVu Hi All .. I'm wondering how does reset exception exactly work in case of M5485 processor. The reference manual describes that the VBR content is cleard upon reset. That means we load ZERO into PC at start, but i've configured flash at 0xFE000000. My program still works. Can anybody pls explain Sai
0 1434
05 Mar 2007 10:27 PM
1 Replies and 1359 Views config block  1359  1 Started by  Deleted User Is there a description of the config block in LogicLoader Best regards, André Lämmer
1 1359
by  Deleted UserJump to last post
26 Feb 2007 04:22 AM
1 Replies and 1387 Views M5485EVB Power Problem  1387  1 Started by  ViVu Hi .. I'm using this coldfire 5485 board -- I'm following the instructions in the CDK QuickStart step by step, and found these problems -- 1. The ITX board LED D14 starts blinking as soon as I connect a serial cable, and totally shuts off after a while. The case is the same when I first connect the cable, set TeraTerm and then give power supply. 2. I've other board where this problem isn't there, but, the Debug monitoer never shows up after we connect the board to the PC .. Pls lemme know if...
1 1387
by  ViVuJump to last post
06 Feb 2007 10:50 AM
5 Replies and 1692 Views toolchain m5475evb problem  1692  5 Started by  Cuccosss Hi. I have a problem with toolchain: Configuring in ./bfd configure: loading cache ./config.cache checking build system type... (cached) i686-pc-linux-gnu checking host system type... (cached) i686-pc-linux-gnu checking target system type... (cached) m68k-unknown-linux-gnu checking for i686-pc-linux-gnu-gcc... (cached) gcc checking for C compiler default output file name... a.out checking whether the C compiler works... yes checking whether we are cross compiling... no checking for suffix of exe...
5 1692
by  CuccosssJump to last post
08 Jan 2007 11:48 AM
0 Replies and 1485 Views PSC3 547X/548X  1485  0 Started by  zozoeng I am currently trying to get the PSC3 port to run in UART mode. Nothing seems to be transmitting. I have PSC0-PSC2 running in UART mode. Is there something additional I need to do with PSC3 that is different from the configuration for the other 3 uart ports (PSC0-PSC2). I have tried setting the PAR_DSPI to 0, with no luck. Additional info: I have tried to run PSC3 strictly in internal loopback mode as well...that does not work either. All other ports (PSC0-PSC2) work in internal loopback....
0 1485
30 Nov 2006 05:20 PM
15 Replies and 1743 Views Using EEPROM on 5485EVB  1743  15 Started by  tmloos I am using Freescale's PCS and BSP and was wondering if anyone doing the same has been able to get reads and writes working to the EEPROM... I see some EEPROM lines under the drivers-->I2C section of the kernel config, but don't see anything obvious. Also curious about how to interface to the device from a C program. Thanks!
15 1743
by  tmloosJump to last post
08 Nov 2006 01:07 PM
5 Replies and 1389 Views Lost DBUG  1389  5 Started by  Deleted User We have a M5485EVB with DBUG from Freescale and Logicloader from LogicPD. Logicloader uses ff840000 as address so that we can use both. Now I tried to save a Ethernet MAC address to the Logicload config. After this action I can not start DBUG anymore. There is no seriell output. But it is still possible to access the board with CodeWarrior an the BDM interface. Killed the Logicloader the DBUG How can we restore the DBUG Best regards, André
5 1389
by  Jump to last post
07 Nov 2006 02:54 PM
1 Replies and 1455 Views 5474 LiteKit USB device port using linux  1455  1 Started by  horsey Is there any linux usb gadget support for the 5474 usb device I have run across several readmes that say USB is not working, but they are not specific as to why/what are the problems Can anyone summarize what they know about using the device port
1 1455
by  Jump to last post
01 Nov 2006 10:20 AM
6 Replies and 1599 Views make toolchain and build the kernel for MCF5475EVB  1599  6 Started by  connie Hello, I downloaded Coldfire Linux BSP (v1.0.2) and Coldfire Linux Toolchain (v1.0.2) from http://www.logicpd.com and try to build it. By reading the readme and Freescale AN2950, I did below steps: (I am using Red Hat 9, login as root. The target board is MCF5475EVB) 1. uncompress two tar.bz2 files into folders /LinuxBSP-22012005 and /LinuxTools 2. create the /opt/logicpd and set the 775 permission for that folder 3. run "make toolchain" 4. run "make fresh" 5. run "m...
6 1599
by  connieJump to last post
18 Oct 2006 09:09 AM
0 Replies and 1416 Views I2C on M5485EVB (default project)  1416  0 Started by  marcel.frei Has anybody already used the I2C-bus in a standard project (stationary for 5485) Which steps are needed to be able to use the I2C bus (code example welcome) We do not use a linux or a RTOS. Thanks in advance
0 1416
12 Oct 2006 05:51 AM
1 Replies and 1473 Views Recommended BDM?  1473  1 Started by  CPMatt I see several replies about the stepping issue with gdb and the BDM packaged with the lite kits. I realize the one provided by logic and accompanying the kit is a third-party device, according to several posts dating back 2 years with issues with this BDM. So I'm wondering if maybe the issue has been identified or resolved Has nobody at logic tried to step wtih the provided BDM using GDB Is there some more details about why it won't step properly There is a gdb hack out there to simul...
1 1473
by  Jump to last post
07 Sep 2006 03:35 PM
0 Replies and 1434 Views M5475 - GPIO - need > 5 inputs in single PPDSDR  1434  0 Started by  DavidHearn We have a MCF5475 EVB. We sample 5 GPIO pins (configured for input) but we'd like up to 8 pins available for GPIO input. The problem is, they have to be sampled by the same PPDSDR register. We must sample just 1 register. Sampling 2 registers is not acceptable due to performance issues. At present we're using the Mini-ITX Case Header on the Logic MCF5475EVB which exposes 5 DSPI pins which can be configured for GPIO input (the other 2 pins in the register are used elsewhere on the board - USB an...
0 1434
22 Aug 2006 10:00 AM
You are not authorized to create a new topic
Page 3 of 8 << < 12345 > >>


RSS Feed Available