Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 7 of 14 << < 56789 > >>
Topics
 Replies
 Views
 Last Post
7 Replies and 1385 Views Error in Compact Flash  1385  7 Started by  Deleted User I'm a new user and I have a Compact flash that stores NK.bin file and Works in another devices; when I insert it into the slot and try to mount: losh> mount fatfs /fs timeout resetting cf card error: mount: failed to open (ATA) Any Idea
7 1385
by  Deleted UserJump to last post
20 Feb 2008 12:40 PM
0 Replies and 1284 Views TV-out  1284  0 Started by  Deleted User Hello all, Is there any add-on card or something like that for the litekit to get a TV-out connection using Linux Thanks
0 1284
20 Feb 2008 03:10 AM
1 Replies and 1312 Views iMX31 Litekit runs at 400MHz or 532MHz?  1312  1 Started by  serkam Dear Sirs I read the PLL registers from iMX31 of my Litekit using a JTAG Debugger ( SEGGER JLINK ) and the values showed me that this iMX31 is running at 400MHz, instead 532MHz. Is that correct I mean, the iMX31 Litekit runs at 400MHz If so, why this frequency The Litekit can't reach 532MHz Thanks. Sergio Kamakura Warp Tecnologia Ind Com Ltda
1 1312
by  freemJump to last post
18 Feb 2008 09:13 AM
73 Replies and 4650 Views Linux 2.6.19.2  4650  73 Started by  zonque
(Topic has multiple pages1 2 3 4 )
Hi everyone, just wanted to let you know that I got a Linux installation ready which supports many (almost all) features of the LITEKIT. Here is the list of peripherals I've successfully tested simultaniously: * USB HS host * USB OTG host * IDE in UDMA mode * PCMCIA * Ethernet SMSC9117 * MMC In the first place, I followed the instructions from http://www.logicpd.com/support/tdg/viewtopic.phpt=1074, but there was still some code missing here and there. I patched around for a couple of days an...
73 4650
by  olcoJump to last post
15 Feb 2008 08:37 AM
13 Replies and 5983 Views JTAG via BDI2000 - How to?  5983  13 Started by  Deleted User Hi! We would want to debug the LITELIT board via a BDI2000 JTAG interface and have some basic questions: 1. Where is the baseboard schematics 2. How should the JTAG debug jumpers be set 3. Does someone know how to configure (config file) a BDI2000 JTAG debug interface to use it with the LITEKIT board Thanks in advance, jesrui
13 5983
by  ptympsJump to last post
11 Feb 2008 05:21 PM
2 Replies and 1348 Views serial eeprom: how to erase it? URGENT!  1348  2 Started by  serkam I have a Litekit loaned from Future Electronics Brazil. This Litekit came with a script to boot Windows CE on power-on, probably done by a previous customer. I did try to erase the serial eeprom using: erase 0 128 /dev/serial_imx31_ff but the command didn't operate. I got an error: error: erase: erase failed ((0) start=0x0: len=0x80) and the Litekit continues to try to boot Windows CE. I did try also: erase 0 128 /dev/serial_eeprom as listed in the operating manual, but this device do...
2 1348
by  serkamJump to last post
11 Feb 2008 10:14 AM
0 Replies and 1327 Views Power Benchmarking?  1327  0 Started by  cmcp Hi! Is the LITEKIT SOM-LV a suitable platform for performing power benchmarking of the i.MX31 CPU What I would like to do is run various standalone benchmarks on a bare machine under a variety of conditions and be able to measure the current on each of the CPU's power rails (or, at least, be able to measure the CPU's total power draw) . I know there are current-sense resistors in the power paths from the LITEKIT to the SOM-LV. Is one of those paths dedicated solely to the CPU Regards. -...
0 1327
07 Feb 2008 08:24 AM
0 Replies and 1348 Views lolo test-mem is reliable?  1348  0 Started by  serkam Dear Sirs Is LoLo´s test-mem reliable enough to assure that the DDR ram is 100 operational I did a script where I runned 100 loops of test-mem over DDR ram without a single error: test = 100 while( $test ) test-mem test = $test-1 done After that, I tryed to decompress a Linux image into the DDR RAM, but a CRC error showed up. This Linux image was downloaded through Ethernet and RS232 using LoLo. Both downloaded without any error. In time, I have 2 Litekits. The first ( where the CRC erro...
0 1348
06 Feb 2008 05:48 AM
0 Replies and 1340 Views WinCE VFP kernel patch and floating point performance?  1340  0 Started by  spannring Has anyone tried the VFP kernel patch (lpd_imx31_vfp_imx31_50_1_0_0.zip) for LogicPD's i.MX31 BSP How much of a performance gain did you get on floating point benchmarks
0 1340
05 Feb 2008 05:05 PM
1 Replies and 1312 Views GoForce  1312  1 Started by  webjeff I figured I'd post this as another topic, but has anyone been able to hook up any of the GoForce mobile chips from NVIDIA to these boards I am interested in doing so, but not sure where to start looking for help. thanks! Jeff.
1 1312
by  webjeffJump to last post
05 Feb 2008 10:14 AM
5 Replies and 1603 Views WEIM bus examples  1603  5 Started by  Deleted User I am looking at connecting the i.MX31 module to an FPGA using the WEIM bus. Is there a driver in WinCE BSP for the WEIM bus Is there any example code available using the WEIM bus under WinCE Thanks, Pavel
5 1603
by  Deleted UserJump to last post
01 Feb 2008 01:37 PM
0 Replies and 1311 Views LCD not working  1311  0 Started by  Deleted User hai, we are working on linux-2.6.19.2 kernel, we are using daniel patch, we have configured as per the manual for LCD in kernel but we are not getting LCD pixel clock period and width. when we boot the WinCE image we are getting LCD pixel clock. please help us. thanks in advance.
0 1311
29 Jan 2008 01:40 AM
2 Replies and 1272 Views Just starting out (verify my screen)  1272  2 Started by  webjeff Hey guys: I just bought a i.MX31 LiteKit dev and I want to purchase LQ043T3DX02 screen for it. Has anyone interfaced with that screen before, is this going to cause any issues Also, a more general question, does anyone know if WindowsCE will allow me to run my own custom startup application so the user won't know CE is running in the background (I'm not too familiar with CE). I can run in linux if necessary, however, I would like to use Visual Studio for development... but I'm not glued to ...
2 1272
by  webjeffJump to last post
25 Jan 2008 04:34 PM
0 Replies and 1337 Views SDIO work only in 1bit mode  1337  0 Started by  Deleted User Hi, I am using imx31 device, arm113, WinCE 5.0 I have SDIO dongle that’s work fine only when the SDIO driver work in 1bit mode, when I am trying to work in 4 bit mode the driver fail on his first transaction, Did anyone familiar with this issue Does anyone know how to solve\workaround this issue Thanks, Eladr
0 1337
13 Jan 2008 03:07 AM
3 Replies and 1336 Views How to create partitions in NAND memory  1336  3 Started by  Deleted User I am interested in partitioning my NAND flash memory to store the stage 2 boot loader, the kernel image, and the rootfs. When I boot my kernel and examine my MTD devices (cat /proc/mtd), partitions already exist (not sure how they were created). dev size erasesize name mtd0: 00080000 00010000 "Bootloader" mtd1: 00180000 00010000 "Kernel" mtd2: 00200000 00004000 "nand.kernel" mtd3: 03e00000 00004000 "n...
3 1336
by  mattwickJump to last post
11 Jan 2008 11:39 AM
3 Replies and 1538 Views Micron CMOS sensor CSI interface  1538  3 Started by  Deleted User Hai We are trying to interface the CSI port of IMX31 using Micron MT9D131 CMOS sensor module We have currently done the following changes, we have enabled the CSI and MXC IPU interface and we are currently selected MT9V111 driver But the observation what we have is , it is found that I2C is not able to detect the CMOS SENSOR module and it is saying ACK not received We have currently done the changes in mx31lite_gpio.c and function like gpio_sensor_active/gpio_sensor_inactive as mentioned in...
3 1538
by  Deleted UserJump to last post
08 Jan 2008 06:49 AM
1 Replies and 1238 Views Signum JTAGJET on i.MX31 LiteKit  1238  1 Started by  Deleted User The Signum JTAGJET product is alternative to the Abatron BDI2000. The "chameleon" software was verified to work. Below is the .mac file I used: ; iMX31LiteKit&46;mac - Startup macro for LogicPD MCiMX31LiteKit board with Freescale i&46;MX31 processor &40;ARM1136JF_S&41; ; Version 1&46;00 12/11/2007 - Initial version ; refresh mode disable ; disable display of windows here if __CPU_STATE__ == "Unknown" echo off echo echo Error&58; Cannot access the CPU&46; ...
1 1238
by  DrOctaviusJump to last post
05 Jan 2008 02:09 AM
0 Replies and 1273 Views Saving to the CompactFlash Card  1273  0 Started by  Fred Dyer Hi - I am unable to load a file onto the CompactFlash Card. The software documentation shows how to download a file from the CF card, but not in the other direction. Specifically, I want to download an elf file from my PC to the CF card, and then set the file up for autoboot on system power up. Thanks! - Fred
0 1273
03 Jan 2008 12:09 PM
6 Replies and 1290 Views PCMCIA Bus Timing Problem  1290  6 Started by  davek Has anyone experienced timing problems on the PCMCIA bus I'm using a Compact Flash ethernet card, and it seems that the output enable from the MX31 is turning off before the MX31 samples the data bus, due to delays in the buffering. Has anyone else seen this problem It seems to be violating the timing requirements of the MX31.
6 1290
by  davekJump to last post
19 Dec 2007 09:42 AM
2 Replies and 1244 Views Problem using the floating point unit  1244  2 Started by  Deleted User I am currently working with the ARM GNU toolchain V 3.-1 provided by logicpd. I have encountered the following problems 1) The compiler does not accept the option -mfpu=vfp. What option do I need for the compiler to use vfp 2)I tried compiling my code with the compiler option --msoft-float but looking at the disassembled code, the floating point functions do not seem to be called. Below are the options passed to gcc and part of the disassembled code. Any ideas on this ---- gcc command -----...
2 1244
by  Deleted UserJump to last post
17 Dec 2007 01:39 AM
You are not authorized to create a new topic
Page 7 of 14 << < 56789 > >>


RSS Feed Available