Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 4 of 14 << < 23456 > >>
Topics
 Replies
 Views
 Last Post
0 Replies and 1061 Views Power charging using USB port  1061  0 Started by  durian We like to have a USB host charge the MX27 LITEKIT board via the USB OTG port. Has anyone done it before on the LITEKIT board Any additional hardware needed or board modification needed Any sample code for the MC13783 PMIC chip that shows me how to do this charging
0 1061
03 Sep 2008 01:40 PM
3 Replies and 1219 Views Serial port driver/timing in windows CE  1219  3 Started by  freem Logic The serial port not buffering any out going chars. Somebody(Logic or MS) is blocking my threads when I write to the port. I have put together a test app that if the serial port driver was interrupt driven and has a buffer should generate a pulsetrain with a period of 10mS - 11mS. It does not, I see the Writefile blocking until char is sent. I need to know why and how to fix this! My Windows image has all of latest drivers in it. Here is test my code: int _tmain(int argc, _TCHAR* argv&9...
3 1219
by  freemJump to last post
03 Sep 2008 09:17 AM
1 Replies and 1193 Views non-functioning pmic when switching to lolo version 2.4.0  1193  1 Started by  Deleted User Has anyone noticed that the pmic no longer functions when switching from lolo version 2.3.5p2 to 2.4.0 We are running lolo version 2.3.5p2 and the PMIC is functional. The result from the function pmic_get_revision function is: rev1=3, rev2=3, icid=2, finid=0. However, switching into lolo version 2.4.0 makes the pmic non-functional. The result of the pmic_get_revision function is: rev1=3, rev2=4, icid=4, finid=3. Upon further investigation, we've discovered that the icid needs be 2 in order fo...
1 1193
by  colingibbsJump to last post
27 Aug 2008 04:10 PM
2 Replies and 1448 Views Use of oprofile and gprof  1448  2 Started by  Deleted User Hello, I've successfully built and booted Linux 2.6.19.2 following the instructions by DrOctavius and others. I am also able to run my application. Now I'd like to gather some profiling information on my application; I built it with the -pg option and ran it on the board. After processing the gmon.out with gprof on the host I get correct call graph information but the times for all functions are reported to be 0.00. This is despite running the application for several minutes. I also checked ...
2 1448
by  Deleted UserJump to last post
12 Aug 2008 10:11 PM
0 Replies and 1104 Views Anybody using Compact Flash on Linux?  1104  0 Started by  Deleted User I am using Poky linux for "imx31litekit", and it does not seem to detect CF cards. LoLo is accessing the cards perfectly. The kernel is 2.6.19.2 and apparently has the right config options: CONFIG_PCCARD=y CONFIG_PCMCIA_DEBUG=y CONFIG_PCMCIA=y CONFIG_PCMCIA_LOAD_CIS=y CONFIG_PCMCIA_PROBE=y CONFIG_PCMCIA_MX31ADS=y (Serial) ATA is not enabled though: Serial ATA (prod) and Parallel ATA (experimental) drivers CONFIG_ATA is not set
0 1104
08 Aug 2008 09:32 AM
16 Replies and 2085 Views A script to do the whole linux caboodle  2085  16 Started by  tombrus While I was trying to get linux on my LITEKIT I developed the script below. You will need bash to run it. Put it in a dir of its own and run it.It will first help you to download the BSP from Freescale (I could not find a method to do that automatically )it will download the other thingsbuild and patch whatever is neededsetup tftp and nfs sharessend the commands to the LITEKIT (/dev/ttyS0) In the first few lines you can tune network stuff and some names. The DO_DOWNLOADS can be ...
16 2085
by  tombrusJump to last post
08 Aug 2008 08:32 AM
4 Replies and 1966 Views Poky Linux Development supporting iMX31 Lite board  1966  4 Started by  ecastelo Found this Linux Development site Poky http&58;//pokylinux&46;org/ They include a zImage and rootfs for for the iMX31 Lite board prebuilt. I have it running, just need to change the screen settings it looks like. Haven't tested what all works yet. To load this linux was simple. Download the zImage and rootfs. For iMX31 Lite they do not use a JFFS2. Quick install: untar the rootfs to a SD memory card load zImage just type "exec" Detailed install: Need to be in linux for the inst...
4 1966
by  ecasteloJump to last post
07 Aug 2008 02:01 PM
0 Replies and 1052 Views LOLO for additional function  1052  0 Started by  Deleted User i use litekit as a evaluation,now i build application on the base of it and add some additional function such DVB-T.may i use the LOLO as beforeor there need some changehow
0 1052
28 Jul 2008 11:12 PM
1 Replies and 1328 Views LoLo can't mount CF: "bad magic"  1328  1 Started by  jimtrethewey HW: LiteKit w/ i.MX31 SOM. LoLo: Version 2.3.5-IMX31_10 0001 My first out-of-box experience; trying to load sample WinCE5 NK.BIN image ("imx31_sample_image_03072008"). Only was able to "mount fatfs /cf" once, all other times have failed with "bad magic" message. CF cards tried: SanDisk 30MB CF (too small to hold sample NK.BIN, but tried it anyway) SanDisk 256MB CF Lexar 2GB CF Platinum II 80x SanDisk 8GB CF Extreme III (I think this one failed because...
1 1328
by  jimtretheweyJump to last post
28 Jul 2008 07:35 AM
3 Replies and 1229 Views How to test USB ethernet gadget in imx31 LITE KIT.  1229  3 Started by  Deleted User I am using linux 2.6.19.2 (after applying linux-2.6.19.2-mx31lite.patch file) on imx31 LITE KIT and wanted to try g_ether.ko on the imx31 LITE kit. After loading the g_ether.ko module (this also needs arcotg_udc.ko), i got an interafce "usb0" and could config the ip address for the usb0. But when i connect imx31 LITE kit otg device to windows XP host PC, the windows is not able to recognise the USB device. I am not sure what i am missing here. Also i tried in Linux Host PC (FC6), but...
3 1229
by  Deleted UserJump to last post
24 Jul 2008 03:48 PM
0 Replies and 1054 Views 802.11 devices  1054  0 Started by  rbunce I have Linux working nicely, but now I need to demonstrate a wireless LAN, preferably using the SD socket, failing that the CF. Ideally 802.11g but 802.11b might be adequate. Has anyone tried this and if so what were the results Thanks in advance, Roy
0 1054
17 Jul 2008 02:27 AM
0 Replies and 1394 Views USB OTG peripheral mode - anyone got it working?  1394  0 Started by  durian Hi, I have a MX27 Lite Kit and I cannot get USB OTG to work in peripheral mode. We are not required to work in host mode. So far when I connect the Lite Kit to my Linux FC5 laptop, the PC does not detect it. Can someone take a look at my config below to see if I am missing something Also the Lite Kit uses the SMSC USB3311 transceriver chip. Does anyone have the programming manual I only have the Data Brief. I am not sure how different it is from the Philips 1504 chip, which the MX27ADS board...
0 1394
02 Jul 2008 02:22 PM
0 Replies and 1129 Views I2C  1129  0 Started by  rajani@mfintel.com Hi, Has any one been able to connect an I2C device to say port I2C1 and use the mxc_i2c_read interface provided by freescale Per the document, there is supposed to be an mxc_i2c_client.c file which is the client driver. I dont have it. Any one else have the same issue Thank you, Rajani
0 1129
26 Jun 2008 01:47 PM
1 Replies and 1336 Views How to biuld the LogicLoader?  1336  1 Started by  Deleted User If LoLo getting corrupted, how to burn it into NOR Flash
1 1336
by  Deleted UserJump to last post
24 Jun 2008 10:00 AM
0 Replies and 1143 Views NAND boot  1143  0 Started by  durian Hi, we have LoLo running from NOR flash and we can have it copy a Linux kernel stored in flash to DRAM and boot there. But we want to delete the NOR flash device and use the NAND instead. Does anyone know about getting NoLo and having it load LoLo, which in turn then loads a Linux image from NAND Does any know how to get a NoLo binary for a MX27 LiteKit board Any help would be much appreciated...
0 1143
23 Jun 2008 07:31 PM
0 Replies and 1103 Views LoLo flash burn not working  1103  0 Started by  durian Hi, I have a Linux XIP (Execute In Place) image built that I like to burn into flash at offset 0xc0000 in NOR flash memory space. Here is what I have done: load raw 0xa0400000 1327892 /tftp/192.168.1.109:xipImage /* load Linux image into DRAM at offset 4MB in ram space */ burn /dev/flash0 B12 /* Burn the image into flash starting at block 12, which is 0xc0000 offset */ However when I do 'x /w 0xc00c0000', the flash memory contents are all zeros. I am suspecting that the burn commands grabbe...
0 1103
21 Jun 2008 06:47 PM
0 Replies and 1128 Views embedded Visual C examples  1128  0 Started by  ravi.mahankali Hi, I am looking for example projects for this kit (using embedded Visual C) apart from the "Hello World" given in the website. If anybody can share some examples, it would be really helpful for me. Thanks, Ravi
0 1128
20 Jun 2008 07:29 PM
0 Replies and 1067 Views Access GPIO using eVC  1067  0 Started by  ravi.mahankali Hi, I am new to the i.MX31 LITEKIT. I need to access the GPIO pins. Are there any functions available in the embedded Visual C (eVC) SDK provided by LogicPD If not what are the other ways to do it. Any examples or guidance in this direction would be helpful. Thanks, Ravi
0 1067
20 Jun 2008 07:28 PM
0 Replies and 1105 Views LogicLoader script to collect user input  1105  0 Started by  MarkH I am using LogicLoader (Lolo) version 2.4.0. I have searched the documentation, and have not found anywhere where it shows how to do the following: I would like to be able to present a short menu of choices to the user, and have the user input the selection. For example: 1) Run 'bootme' 2) Run 'exec' string 3) Boot image from NAND 4) Return to Lolo shell Enter choice: I would not expect the user to have to enter 'setvar selection 1'. Any one have any ideas Thank you. MarkH
0 1105
18 Jun 2008 10:37 AM
0 Replies and 1164 Views USB Host2 Controller issue with WinCE 5.0  1164  0 Started by  MarkH I am using the SOM-LV i.MX31 with Windows CE 5.0. I have all the latest QFE's for ARM, and LogicPD's WinCE 5.0 BSP. I am not new to WinCE development. This is my first time using Logic's board, but using Lolo 2.4.0, I had built up an image that I could download via Ethernet and run in very little time. I think the documentation was excellent, and things were going well. I am writing a USB Host Class driver for a custom device. This device enumerates fine when connected to a Windows XP system...
0 1164
17 Jun 2008 09:19 AM
You are not authorized to create a new topic
Page 4 of 14 << < 23456 > >>


RSS Feed Available