Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 3 of 14 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
1 Replies and 1262 Views sample app using the GP100 & GP101 LED  1262  1 Started by  aschnaufer Does anyone have a sample app in WinCE 5.0 showing how to use the GP100 &/OR GP101 LEDs
1 1262
by  aschnauferJump to last post
03 Feb 2009 01:36 PM
2 Replies and 1315 Views cross compiling  1315  2 Started by  Deleted User Does anyone know of an easy way to do this. I have python compiled into the file system, but the problem is I need to add a library PyCrypto. The problem is that it is looking for gcc when I try to compile it on the board. And I don't know how to tell the python script to use the arm-gcc in /opt/.... mx31 python setup&46;py build running build running build_py running build_ext building 'Crypto&46;Hash&46;MD2' extension gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -f...
2 1315
by  Deleted UserJump to last post
22 Jan 2009 03:33 PM
2 Replies and 1408 Views fail to load linux kernel (load address 0xc0008000)  1408  2 Started by  charleskow I built latest linux kernel 2.6.27.10 for imx31 litekit. When I tried to load kernel image vmlinux into the board, I got following message. Any suggestion to solve this problem Thanks. losh> load elf /tftp/192.167.1.12:vmlinux loading from /tftp/192.167.1.12:vmlinux: ................................................................................ ................................................................................ ..................................................................
2 1408
by  serkamJump to last post
20 Jan 2009 06:09 AM
0 Replies and 1116 Views is iMX31 GPIO linux driver available?  1116  0 Started by  serkam I need to use 8 pins of iMX31 as GPIO, 4 as inputs, 4 as outputs. As I am accessing theses pins through a user program, I need a driver to do this. Is there a GPIO linux driver already available or I need to create one Any help will welcome. Thanks.
0 1116
20 Jan 2009 06:05 AM
4 Replies and 1370 Views Interfacing to LCDs  1370  4 Started by  Deleted User We've tried to make it as straight-forward as possible to interface new displays to our products. LogicLoader 2.x has some new features to allow for this. If you are looking to interface a display, this document should help you along the process. You will need to be up to speed on how the specific LCD controller operates and how the adjustments to its registers affect the display timing. Integrating Custom Displays with LogicLoader Application Note 298 http://www.logicpd.com/downloads/647/ I...
4 1370
by  Deleted UserJump to last post
03 Jan 2009 02:02 AM
9 Replies and 1350 Views Problem with CompactFlash and SD  1350  9 Started by  oscarmarmar Hi, In my imx31 Lite kit I don't mount the CF in LOLO 2.4. losh> mount fatfs /cf timeout resseting cf card. unsuccessfull mounterror: mount: unable to mount (/) losh> mount fatfs /dev/ata0a /cf timeout resseting cf card. unsuccessfull mounterror: mount: unable to mount (/) mount losh> mount fatfs /dev/sdmmc0a /sd sdmmc_open:583 Fail - 00000000! sdmmc error opening unsuccessfull mounterror: mount: unable to mount (/) ¿Why don't I mount the cards Thanks
9 1350
by  oscarmarmarJump to last post
04 Dec 2008 02:27 PM
5 Replies and 1211 Views c  1211  5 Started by  Deleted User Can we develop applications for the card in c or is it only c I see in the BSP you can include the c headers when configuring the ltib, but I wasn't sure if it was actually supported by the LITEKit.
5 1211
by  Deleted UserJump to last post
20 Nov 2008 08:44 AM
0 Replies and 1051 Views audio driver problems  1051  0 Started by  AlanREI We are using the audio driver included with the windows CE bsp. We need to be able to programatically switch between mic1, mic2, RXIN inputs and speaker, headphone, and I2S outputs in an application. From my understanding, and audio driver is responsible for hooking the windows waveform audio interface calls to support certain mixer functions. After studying the API I wrote an application to query the mixer, lines, and controls, but the result was that I got back mostly empty information and ...
0 1051
29 Oct 2008 10:18 AM
1 Replies and 1224 Views USB Ports on Expansion board  1224  1 Started by  Deleted User I tried to use the USB3 and USB4 ports on the expansion board. But i could not detect any usb device connected to the ports, no messages come through. Although when i connect a mouse or usb the light comes up(i.e. powered up). Anyone knows what could be the problem here Thanks
1 1224
by  mathieuJump to last post
27 Oct 2008 01:44 PM
0 Replies and 1085 Views Using SPI on Windows CE  1085  0 Started by  EViollet Hi. I'm trying to use the SPI bus on Windows CE. Can anyone send me information on how to use the SPI bus on the iMX31 development kit Any APIs/guidelines offered by LogicPD In advance, thanks.
0 1085
27 Oct 2008 06:58 AM
1 Replies and 1247 Views JFFS2 in NAND using LoLo, How to?  1247  1 Started by  serkam Any advice on How To mount a JFFS2 Linux filesystem in NAND using LoLo Thanks
1 1247
by  serkamJump to last post
21 Oct 2008 11:37 AM
0 Replies and 1158 Views EPI/Mentor Graphics Majic-LT JTAG ICE  1158  0 Started by  joncastillo Hi, anyone tried to use this debugger yet After hearing that it now supports the i.MX31 processor, I immediately searched for a used one in auction sites and luckily (or not) bought a cheap one. Unfortunately, it did not come with documentation nor CDs and I am having a difficult time obtaining them from mentor graphics' support site. If anyone out there who has this device, would you share the support files to me, please And does it work well with the litekit Do let us know Many thanks ...
0 1158
20 Oct 2008 06:27 AM
9 Replies and 1490 Views linux unable to see the files in yaffs partition  1490  9 Started by  Deleted User hi, i just got my litekit working with linux. i'm runnig the kernel and the bootloader from a yaffs partition in the nand-flash. i am starting the system like this: add-yaffs boot nand B0 B128 mount yaffs /boot load raw 0x81000000 1607272 /boot/kernel load elf /boot/loader jump everythings boots up just fine. the root partition is on the nand as well (jffs2). the trouble starts, when i try to mount the boot-partition within linux. linux is not showing the files i put in there using losh. it ...
9 1490
by  davekJump to last post
14 Oct 2008 10:37 AM
0 Replies and 1035 Views mounting JFFS2 image file in NAND using LoLo  1035  0 Started by  serkam Did somebody a JFFS2 Linux filesystem in NAND Any advice will welcome. Thanks.
0 1035
13 Oct 2008 05:23 PM
4 Replies and 1375 Views GPIO read and write with C  1375  4 Started by  Fred Dyer Hi - I need to write to and read from the GPIO lines using C. How is this done Also, are pull-up resistors needed on these outputs/inputs What is the high level voltage I am assuming 5 Volt Thanks! - Fred
4 1375
by  physicsengJump to last post
08 Oct 2008 09:51 AM
0 Replies and 1171 Views Having trouble erasing Yaffs partition in Nand flash  1171  0 Started by  Deleted User We have a problem with a IMX31 SOM which previously had Lolo 2.3.5 on it. We had a Yaffs partition on the Nand flash which was using blocks 72 thru 2120. Now we have upgraded Lolo to version 2.4.0, and we are trying to erase the old partition with Lolo's erase command: erase /dev/nand0 B1 B4095 The command executes and shows progress with no error messages. However, after rebooting, the old files are still there. However, any attempt to access the files results in a heap memory e...
0 1171
17 Sep 2008 03:13 PM
0 Replies and 1088 Views Does i.MX31 SOM-LV Schematic fit old MX31 silicon revision?  1088  0 Started by  Deleted User Hi, Logic We want to use Rev1.15 or 1.2 MX31 in our design. And we have bought i.MX31LITEKIT for reference. But We found MX31 SOM-LV use the Rev2.0 MX31. So I want to konw whether there are differences of schematic design between 1.15/1.2 and 2.0 MX31 Thank you!
0 1088
12 Sep 2008 10:01 PM
2 Replies and 1342 Views How to reload LOLO using JTAG?  1342  2 Started by  Deleted User Several Customers have has issues with LoLo getting corrupted. Here is a "How To" from one of Logic's Firmware engineers. If you have JTAG hardware this *should* be straight forward. - We do not make any permanent changes to the CPU (ie. burn any fuses). We make every effort to keep the CPU as it was delivered from Freescale, so as not to lock the customer down to any specific configuration. - There are many ways to flash a bricked board. We have found the most ...
2 1342
by  mathieuJump to last post
10 Sep 2008 12:22 PM
11 Replies and 1370 Views linux 2.6.22.6 network problem  1370  11 Started by  tombrus Hi, I got 2.6.22.6 booting now, but the network chip does not respond as expected. Anybody any hints (should I switch on the irqpoll option how): Quote:eth0: SMSC911x/921x identified at 0xc4a00000, IRQ: 90 eth0: SMSC911x MAC Address: 00:08:ee:01:7c:03 eth0: link down IP-Config: Complete: device=eth0, addr=192.168.3.250, mask=255.255.255.0, gw=192.168.3.1, host=192.168.3.250, domain=, nis-domain=(none), bootserver=255.255.255.255, rootserver=192.168.3.85, rootpath= Looking up ...
11 1370
by  hrhaanJump to last post
10 Sep 2008 08:32 AM
18 Replies and 1701 Views HOWTO: Run Linux 2.6.19.2 QT Application  1701  18 Started by  DrOctavius This how-to shows the steps to take a vanilla kernel 2.6.19.2, apply the megapatch v1.0.0, build a kernel, qtopia and pictureflow (application demo). OS host: Opensuse 10.3 Board: IMX31Lite Kernel: 2.6.19.2 LTIB: 3 Megapatch: linux-2.6.19.2-imx31lite-v1.0.0 What hardware and software worked/tested with the patch LTIB: USB Host, Device and OTG. UART. LCD 800x480 TFT (16 bpp). Touch. Audio. Ethernet. Leds. Microwindows. tslib. DirectFB. OpenGLES. Qtopia: 4.3.3. ma...
18 1701
by  DrOctaviusJump to last post
09 Sep 2008 02:49 PM
You are not authorized to create a new topic
Page 3 of 14 << < 12345 > >>


RSS Feed Available