Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Logic PD support staff and engineers participate, Logic PD does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Logic PD engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Logic PD product download, please subscribe to the TDG Forum of interest.

Search this forum:
Search
You are not authorized to create a new topic
Page 2 of 14 << < 12345 > >>
Topics
 Replies
 Views
 Last Post
8 Replies and 2071 Views Anyone loaded CE 6.0 successfully?  2071  8 Started by  AlanREI I have tried to load CE 6.0 through the serial port and it fails with a data abort. Has anyone been able to load the DEV image off their website Here's what it does. ls D : tftp 0 D : etc 0 D : dev 0 losh> erase B1 B4095 /dev/nand0 erasing nand: 100 erased '/dev/nand0' start=0x1: len=0xfff bytes/blocks skipped 0 losh> mount fatfs /cf losh> cd cf losh> load bin NK....
8 2071
by  AlanREIJump to last post
21 May 2010 10:32 AM
0 Replies and 1397 Views KernelIoControl IOCTL_HAL_REBOOT for windows ce on imx31_10  1397  0 Started by  Deleted User does the following work as is Or should something in the code like "lpd" change BOOL ret_value; DWORD dwResetType = 1; define IOCTL_HAL_REBOOT \ CTL_CODE(FILE_DEVICE_HAL,('l''p''d'0),METHOD_BUFFERED,FILE_ANY_ACCESS) ret_value = KernelIoControl(IOCTL_HAL_REBOOT ,&dwResetType ,sizeof( dwResetType ) ,NULL ,0 ,NULL); if ( !ret_value ) { printf("Hard reset failed! \r\n i",GetLastError()); }
0 1397
19 Apr 2010 09:01 AM
0 Replies and 1292 Views reset winows ce 5.0 on imx31 programmatically  1292  0 Started by  Deleted User does anyone know how to do this I need to force a device reboot programmatically from within Windows CE. Does this work: &91DllImport("aygshell.dll")&93 private static extern bool ExitWindowsEx(uint uFlags, int dwReserved); const uint EWX_REBOOT = 0x00000002; const uint EWX_POWEROFF = 0x00000008; private void SoftReset() { ExitWindowsEx(EWX_REBOOT, 0); }
0 1292
16 Apr 2010 02:43 PM
1 Replies and 1665 Views 4.3 WQVGA CE losh file  1665  1 Started by  webjeff I have the 4.3 WQVGA lcd w/ my i.mx31 board. I am putting CE on it and the losh files in my boot scripts directory doesn't contain one for the 4.3 screen. Any idea what the command is for that Or where I can find that losh file thanks Jeff.
1 1665
by  webjeffJump to last post
23 Dec 2009 12:13 PM
0 Replies and 1391 Views Yet another LOLO YAFFS vs Linux question  1391  0 Started by  Deleted User I'm developing a Linux based product with the i.MX31 SOM. I'm storing the kernel in a LOLO YAFFS partition. At some point I'd like the capability of doing in-field upgrades of the kernel in that YAFFS partition. The discussion in http&58;//tdg&46;logicpd&46;com/viewtopic&46;phpf=29&t=1108 pretty much covers my problem. A quick summary of that thread is that LOLO uses an ancient version of YAFFS with some LogicPD patches that Linux doesn't recognize. Last time around there really ...
0 1391
10 Dec 2009 09:08 PM
5 Replies and 1614 Views Linux support status...  1614  5 Started by  tdc1 Hi, What is the current status of the Linux support for iMX31Lite kit I see that in the latest official kernel tree (2.6.29) the support for the liteKit was added, but as far as I can see, the code is incomplete and doesn't boot the platform. I saw older posts on this subject about Linux 2.6.19, Freescale ADS BSP and LTIB. Is this still the only way to go to boot Linux on this board Thanks, tdc
5 1614
by  zonqueJump to last post
23 Nov 2009 08:48 AM
0 Replies and 1249 Views mount NOR flash in Windows on i.MX31 SOM  1249  0 Started by  Deleted User Is it possible using Logic's drivers to mount both the NAND and the NOR flash in Windows CE 5.0 on the i.MX31 SOM When we added the following to the registry file for the flash driver, still only the NAND mounted: &91HKEY_LOCAL_MACHINE\System\StorageManager\Profiles\lpd_yaffsbd\YAFFS_PARTDRV\PART01&93 ; For NOR Flash Devices "EndAddr"=dword:00200000 "StartAddr"=dword:00050000 ; Common for NOR/NAND Flash &q...
0 1249
11 Nov 2009 10:46 AM
2 Replies and 1472 Views Available memory  1472  2 Started by  magene I'm writing a WinCE 5.0 Visual Studio 2005 C/C application that makes use of the CSPI port, GPIO and needs as much RAM for data storage as I can get. After a lot of fumbling around I've got the CSPI port and the GPIO working. Unfortunately, I'm stuck on what I thought would be the easy part. I can't dimension more than about 12,000 unsigned integers. Seems like the memory is there. When I go to Settings->Control Panel->System->Memory, I have 29436KB of Storage Memory and 64768KB ...
2 1472
by  mageneJump to last post
11 Nov 2009 08:20 AM
2 Replies and 1334 Views u-boot compile using u-boot-1.3.3 source  1334  2 Started by  Deleted User Hai Has anyone tried running u-boot on top of LOLO on imx31 litekit board I am able to compile the u-boot source for imx_litekit but i am not able to run the commands used are export PATH="$PATH:/opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/" export CROSS_COMPILE=arm-none-linux-gnueabi- make imx31_litekit_config make clean all I am downloading the image in LOSH using the command load srec //tftp//192.168.50.1/u-boot.srec exec Please help A...
2 1334
by  Deleted UserJump to last post
11 Sep 2009 11:51 PM
0 Replies and 1027 Views Interrupt handling  1027  0 Started by  jiprinc We need the Windows CE 5.0 running on i.MX31 SOM to register the interrupt on GPIO pin. Can you provid me information what registers must be set and what values they should receive Thanks.
0 1027
29 Jul 2009 09:06 AM
3 Replies and 1350 Views imx31Lite ethernet controller  1350  3 Started by  babak The DOCS indicate that the Ethernet controller on imx31Lite MIMX31CSOMXR is the LAN9117, but at least according to http://support.logicpd.com/downloads/601/ the controller is LAN9218. Does anybody know about this hardware change and at what revision of the board this change took place and if this change is still present in the latest revs.
3 1350
by  babakJump to last post
23 Jul 2009 08:24 PM
3 Replies and 1448 Views arm-elf-gcc.exe Entry Point Not Found in sample program  1448  3 Started by  csabi911 Hi guys, Newbi here . After correctly installing the cygwin , GNUtools logicPDv3.1 and the sample application PRE2.5. I get an Windows error saying: arm-elf-gcc&46;exe Entry Point Not Found The procedure entry point _impure_ptr could not be located in the dynamic link library cygwin1&46;dll Now I uninstalled and removed the registry keys a couple of times thinking this might resolve my issue. But still the problem persists. These are the tools that LOGICPD has offered to download from t...
3 1448
by  csabi911Jump to last post
15 Jul 2009 03:55 AM
2 Replies and 1306 Views LCD Display Connector  1306  2 Started by  webjeff I am looking at the LQ043T3DX02 compared to the display kit. The display kit from LOGIC seems to have a board attached to the LCD with ribbon to the MX31 LITEKIT. Am I to assume the LQ043T3DX02 comes with everything necessary to plug into the MX31 ZOOM LITEKIT Or what else do I need to buy for the LQ043T3DX02 It looks like the LQ043T3DX02 has a tiny connector, nothing like what you connect on the LITEKIT. LQ043T3DX02: http://www.sharpsma.com/Page.aspx/ameri ... 043T3DX02/ Display Kit: ht...
2 1306
by  webjeffJump to last post
08 Jul 2009 08:09 AM
1 Replies and 1249 Views pata_fsl working?  1249  1 Started by  mattwick Hi, Does anyone have a real hard drive working with the litekit If so are you running it with pata or ata drivers Is it fully functional with DMA etc We are running a patched 2.6.24 kernel from the freescale PDK and have modified the gpio code to select the ata pins. We can connect a drive, identify the drive, and have basic communication working, using the pata_fsl driver. The problems we are having mostly occur with higher DMA levels, but we're having trouble tracking down the cause. If...
1 1249
by  mattwickJump to last post
18 May 2009 03:29 PM
5 Replies and 1399 Views WinCE and CompactFlash Driver and speed  1399  5 Started by  AlanREI CE 5.0. PCMCIA driver 50_0_1_0 I need to be able to read through many gigs of data off CF as fast as possible. I am trying to get CompactFlash cards to work. I loaded the sample CE image project that came with the dev kit, and I added the PCMCIA driver to it. Then I created a new image and loaded it. It sees the compact flash card as "Storage Card" in the OS. However, when reading from the compactflash card the system hangs and it takes about 24 seconds to read a megabyte off th...
5 1399
by  steveJump to last post
04 May 2009 11:57 AM
12 Replies and 1316 Views Windows CE 6.0  1316  12 Started by  juanluna Hi Guys, I have downloaded the Windows CE 5.0 sample image, and it has run succesfully on my system. Now, I am trying to build by myself a new Windows CE 6.0 image , using Microsoft Visual Studio 2005 Professional Edition. I have made many NK.BINs, but none of them run successfully. First, the NK.BIN is loaded succesfully to the memory, but it is not the same for the exec command. So, I need help. Are the boot parameters for Windows CE 6.0 different There is any guide for to build a WinCE ...
12 1316
by  AlanREIJump to last post
04 May 2009 10:31 AM
1 Replies and 1178 Views loosing compact flash card after CE suspend/wake cycles  1178  1 Started by  steve We're running the standard iMX31 ZOOM LITEKit, LoLo 2.4.0p1, and have problems loosing the CF card in CE50 after suspend & wake cycles. For example, if the system enters Suspend (either with system timers or forced via Start-Suspend), then wake-up (via touch screen) at least two cycle, you will loose the CF card. Either you will get a CE error box looking to select the desired CF driver, or the system will hang trying to navigate a couple directories into the CF card. Performing Suspend-Wak...
1 1178
by  AlanREIJump to last post
04 May 2009 10:00 AM
0 Replies and 961 Views video console time out  961  0 Started by  Deleted User Hai, Video console /dev/vc/0 goes blank after a few minutes of operation. I think it is a power save timeout but I can't track down where to change the timeout period, or disable it. I would appreciate any ideas about where to look. Thanks in advance,
0 961
10 Apr 2009 04:17 AM
12 Replies and 2094 Views Port of LTIB R13 for the PDK (Linux 2.6.24) to MX31 Litekit  2094  12 Started by  Deleted User Here is a port of Freescale's PDK BSP R13 to the litekit. The PDK also contains support for the MX31 ADS, and it is this code that forms the basis for the Litekit port. Note: This kernel works with Lolo v2.3.5p2 & U-boot, but not with Lolo v2.4.0. I am sure that it is simply a control register bit that has been set. The problem manifests itself as the MCU being unable to communicate with the PMIC over the SPI bus. If anybody is able to discover the problem, I'll be glad to add a quick f...
12 2094
by  Deleted UserJump to last post
09 Apr 2009 09:27 AM
1 Replies and 1296 Views How to disable telnet on ttymxc0?  1296  1 Started by  Deleted User System: Linux (iMX31 Litekit) I need to disable telnet on serial port, but nothing related to tty was found in inittab rc.conf init.d/ rc.local I expected to find in the inittab the line like: 1:2345:respawn:/sbin/mingetty tty0
1 1296
by  Deleted UserJump to last post
13 Feb 2009 08:04 AM
You are not authorized to create a new topic
Page 2 of 14 << < 12345 > >>


RSS Feed Available