Search

Technical Discussion Group Forum

This forum is provided for user discussion. While Beacon EmbeddedWorks support staff and engineers participate, Beacon EmbeddedWorks does not guarantee the accuracy of all information within in the Technical Discussion Group (TDG).

The "Articles" forums provide brief Articles written by Beacon EmbeddedWorks engineers that address the most frequently asked technical questions.

To receive email notifications when updates are posted for a Beacon EmbeddedWorks product download, please subscribe to the TDG Forum of interest.

TDG Forum

Search this forum:
Search
You are not authorized to create a new topic
Page 12 of 14 << < 1011121314 > >>
Topics
 Replies
 Views
 Last Post
3 Replies and 1226 Views Full beginner need HELP  1226  3 Started by  bart PLEASE and THANKS IN ADVANCE. some one of the guys here, can tell me for the LiteKit What compiler are you using. How are you dowloadint it. There are some "Visual" IDE enverioment for the LiteKIt There are some Example to start Ther are something to begin to learn I am completely lost, and There are any support from the LOGIC people. Thanks Bart
3 1226
by  spannringJump to last post
27 Jul 2007 09:26 AM
2 Replies and 1270 Views Cannot connect ethernet.  1270  2 Started by  Deleted User I have a problem with my IMX31 Litekit. It seems that I cannot bring up my 'sm0' Ethernet interface statically or through DHCP. I was able to access the board throug a serial connection and when I apply ifconfig sm0 dhcp or ifconfig sm0 192.168.10.102 255.255.255.0 192.168.10.1 I get no result. I can't even get the Ethernet lights to come on. Anyone see this problem before Regards, Blair
2 1270
by  Deleted UserJump to last post
26 Jul 2007 08:28 AM
4 Replies and 1454 Views where find zoom sample application  1454  4 Started by  Pixel Hi!! I am in my first day with IMX Litekit... I have install teraterm, cygwin and gnu tools, to begin to develope. I would like to download Zoom Sample Application, that is the led flasher as my first program but I don't know where can find it... You know where can I find zoom sample application... I use de manual but I can find and of course I am logged (and also my product) to the logicpd web page!! Thank you!!!
4 1454
by  bartJump to last post
23 Jul 2007 09:48 AM
3 Replies and 1256 Views Not able to load .out file  1256  3 Started by  Deleted User Hi, We wrote a simple program to flash LED's. We got the output as a.out after compiling with the arm-none-linux-gnueabi-gcc-4.1.1 compiler. When we try to load the file using load elf we get following error: losh> load elf /tftp/192.168.0.3:led3.out loading from /tftp/192.168.0.3:led3.out: .. ELF section 0: download address: 0x802004bc load address: 0x000084bc ELF section 1: download address: 0x80200034 load address: 0x00008034 ELF section 2: download address: 0x80200114 load address: 0x...
3 1256
by  lwalkeraJump to last post
19 Jul 2007 06:22 PM
2 Replies and 1330 Views Write Sample Application  1330  2 Started by  Deleted User Hi All, We want to build a sample application something like an led flasher. Can somebody tell us how to compile and build the code. Also tell us what tool chain we need to use for i.Mx31 Litekit. And if somebody has done it already please tell us the procedure you followed. Thanks Arjun
2 1330
by  Deleted UserJump to last post
13 Jul 2007 12:49 AM
2 Replies and 1252 Views OTG/USB Suddenly nonresponsive  1252  2 Started by  Deleted User We have an IMX31 board 1006581 Rev 2. After using it for weeks, suddenly I cannot get ActiveSync to work, even with the Dev image downloaded from the website. It had always worked up until this point. The symptoms are that the when the cable is plugged in, nothing happens on either the Windows XP host, nor the device side. Nothing shows in Device Manager, no debug output nor anything on the WinCE screen. I have tested the cable with a mobile phone, and that seems fine. I have tried ...
2 1252
by  Deleted UserJump to last post
10 Jul 2007 08:53 AM
2 Replies and 1320 Views Burn problem with jffs2 image files  1320  2 Started by  Deleted User Hi I have problem with burning jffs2 image file losh> load raw 0x81300000 8388608 /tftp/10.105.20.24:rootfs.jffs2 loading from /tftp/10.105.20.24:rootfs.jffs2: loading raw binary to 0x81300000 (ram) len 00800000: ............................................................................................................................e file loaded losh> burn 128 /dev/nand0 error: burn: image does not fit in flash (128) error: burn: image does not fit in flash losh> is anything wro...
2 1320
by  EricHolmbergJump to last post
06 Jul 2007 05:32 PM
1 Replies and 1328 Views CF card on IDE port  1328  1 Started by  zonque Hi, is there any hardware constraint that could prevent CompactFlash cards (in TrueIDE mode) from working on the EIDE port of a LiteKit I'm not sure if it's a hardware or software problem I'm facing here, however on Linux, it's currently not working. Could someone try this under WinCE maybe Thanks for any hint, Daniel
1 1328
by  zonqueJump to last post
06 Jul 2007 07:09 AM
1 Replies and 1297 Views How to use GPIO0 and GPIO1 on Linux  1297  1 Started by  Deleted User Hi, Somebody can help me on how to use GPIO on Linux I'm using Kernel 2.6.19.2! I want to turn on/off the leds of litekit. Thanks SB
1 1297
by  zonqueJump to last post
05 Jul 2007 02:19 PM
4 Replies and 1307 Views error booting a windows CE image including smsc_lan911x  1307  4 Started by  Deleted User Hello, I have an iMX Litekit (1006581 Rev 2). I created an OS image including the ethernet driver lpd_smsc_lan911x_imx31_50_0_3_0. Sometimes this image boots well and sometimes not. When it doesn't, the boot process starts normally and then sends two debug messages : - 20 messages "SMSC911X: MiniportHandleInterrupt() hardware not ready..." - and then, endless - an infinite loop I think -, the message "SMSC911X: DPC event pool empty..." The boot logs are here : http://reve...
4 1307
by  Deleted UserJump to last post
04 Jul 2007 05:19 AM
2 Replies and 1416 Views Steps to 'mainlining' i.MX31 LITEKIT Linux support  1416  2 Started by  TomCooksey I've been following the arm-linux kernel mailing list for some time. It seems neither the i.MX31 or the MXC platform have been mainlined, let alone the LITEKIT. A chap from Freescale has submitted a patch to the arm-linux maintainer (Russel King) to add basic i.MX31 and ADS board support. From what I understand, this patch was rejected (for various reasons). I believe work is continuing at Freescale to improve the patch in order to get i.MX31 mainlined. I think the problem is that it's not just ...
2 1416
by  TomCookseyJump to last post
27 Jun 2007 04:55 PM
0 Replies and 1420 Views JTAG on the i.MX31 with the Macraigor RAVEN  1420  0 Started by  Deleted User A customer sent in the following help for those of you that are using the Macraigor RAVEN. ******* Run Macraigor's JTAGScanChainAnalyzer.exe, set the JTAG device and port, and hit analyze. Four devices are found when SJC_MOD is low. Instructions to setup the CONNection in the OCDCommander. The chain consists of : 1) OTHER JTAG DEVICE Scan length = 4 2) Freescale MX31 3) OTHER JTAG DEVICE Scan Length = 4 4) OTHER JTAG DEVICE Scan Length = 5 The chain is found and the OCDCommander is ...
0 1420
25 Jun 2007 12:34 PM
1 Replies and 1205 Views How do you get a members card  1205  1 Started by  freem We have paid for CE support. When do I get members card Or a letter telling me how the support works Thanks Michael Freeman Update Systems Inc
1 1205
by  freemJump to last post
25 Jun 2007 11:24 AM
0 Replies and 1347 Views please HELP me  1347  0 Started by  Deleted User I am very new to I.mx 31. we are going to bye little kit. Please help me which version IDE from code warrior is supporting i.MX31 processor on Host operating system Windows xp. Where to download free software for it Thanx
0 1347
23 Jun 2007 02:38 PM
2 Replies and 1204 Views Power refs aka NVCCx  1204  2 Started by  freem Is there a doc on voltage and milliamps on the various NVCC rails Please do not point to the user manual, it does not have this info. Also, the schematic on page 11 of the SOM has R199 marked on my SOM as installed. However the PCB does not have this resistor. Thanks Michael Freeman Update Systems Inc.
2 1204
by  freemJump to last post
20 Jun 2007 03:25 PM
0 Replies and 1285 Views Green hill probe  1285  0 Started by  Deleted User Hi Can anyone tell my if it’s possible to use the JTAG probe from green hill to connect to the LITE board And if its possible how should the JTAG jumpers be set. Thanks in advance Kim Schjodt
0 1285
18 Jun 2007 07:30 AM
13 Replies and 1333 Views Cannot mount Compact Flash using LOLO  1333  13 Started by  Deleted User I just got our MIMXC31SOM Zoom kit today. I have tried several Compact Flash cards in the slot, including the one that works fine with our PXA270 kit. However, when us the LOLO command mount fatfs /cf I get the following error: timeout resetting cf card error: mount: failed to open (ATA) I have successfully updated to version 2.3.5 of Lolo, but this did not help. Thanks for your time, -Kevin
13 1333
by  Deleted UserJump to last post
12 Jun 2007 08:29 AM
4 Replies and 1207 Views activesync  1207  4 Started by  Deleted User On my PC, activesync cannot find the iMX31 Lite Kit with the sample image or with an image created following the LoCE Quickstart Guide. Yet, I have enabled the items to enable USB : .\Shell and User Interface\User Interface\Network User Interface .\Applications - End User\ActiveSync .\Device Drivers\USB Function\USB Function Clients\Serial I read on this forum that activesync can't work with iMX31 Lite Kit, but didn't find a confirmation on the faq. Is the issue still remaining
4 1207
by  Deleted UserJump to last post
08 Jun 2007 09:31 AM
0 Replies and 1242 Views Components on baseboard  1242  0 Started by  OradFarez I just wanted to double check that I can place 0603 sized capacitors/resistors on a custom baseboard anywhere under the LV module. Is this okay Is the 1mm clearance available everywhere or just on portions of the PCB that are open Thanks!
0 1242
07 Jun 2007 09:41 PM
0 Replies and 1552 Views buildroot toolchain  1552  0 Started by  zonque Moin, as an alternative to the ads-ltib-rpm hack, I can recommend the buildroot environment availble from http://buildroot.uclibc.org/. Check out the latest svn and (if you need it) my config from here: http://caiaq.org/download/imx31/br2-010 ... ite.config On a recently updated Debian/unstable box with gcc-4.1.2, you should be able to create a clean, uClibc and busybox-based EABI rootfs with < 10MB in total. But please don't get back to me with endless compile logs of broken builts now ...
0 1552
31 May 2007 07:43 PM
You are not authorized to create a new topic
Page 12 of 14 << < 1011121314 > >>


RSS Feed Available